Wert mit Buchstaben&Zahlen in Range suchen

Bild

Betrifft: Wert mit Buchstaben&Zahlen in Range suchen
von: Christian
Geschrieben am: 12.05.2015 11:00:25

Guten Morgen,
ich möchte gerne einen Wert mit Buchstaben und Zahlen (bsp:AB-J123) in einer bestimmten Range in einem anderem Tab suchen lassen (A238 bis A266). Falls er den Wert findet, soll ein bestimmter Text in die Zelle eingefügt werden (JA), falls nicht soll ein anderer Text eingefügt werden (Nein).
Ich bekomme es nicht hin, dass er nur in einer bestimmte Range sucht. Mit IF()/WENN() sucht er nur nach einer Zelle, mit Vlookup/SVERWEIS für die ganzen Spalten.
Kann mir jemand helfen?
Danke und Gruß,
Christian

Bild

Betrifft: AW: Wert mit Buchstaben&Zahlen in Range suchen
von: Hajo_Zi
Geschrieben am: 12.05.2015 11:07:48
Hallo Christian,
warum nicht Strg+H?
Wo soll was ersetzt werden falls nicht gefunden?


Bild

Betrifft: AW: Wert mit Buchstaben&Zahlen in Range suchen
von: Rudi Maintaire
Geschrieben am: 12.05.2015 11:08:52
Hallo,
soll ein bestimmter Text in die Zelle eingefügt werden (JA), falls nicht soll ein anderer Text eingefügt werden (Nein).
in welche Zelle?
mit Vlookup/SVERWEIS für die ganzen Spalten.
Kann man doch eingrenzen.
Gruß
Rudi

Bild

Betrifft: AW: Wert mit Buchstaben&Zahlen in Range suchen
von: Christian
Geschrieben am: 12.05.2015 11:17:57
Soll alles in Zelle E43 kopiert werden - hier die bisherige Formel:
E43=IF(VLOOKUP($C$41;'Sheet1'!$A$238:$A$268;1;FALSE)=$C$41;"2 years (XYZ)";"2 years (XY)")
Hier bringt er #Value als Fehler...
Falls er C41 in der Range findet soll: "2 years (XYZ)" eingetragen werden, falls nicht: "2 years (XY)"
Danke,
Christian

Bild

Betrifft: AW: Wert mit Buchstaben&Zahlen in Range suchen
von: Rudi Maintaire
Geschrieben am: 12.05.2015 11:26:09
Hallo,
Excel gut?
Schau dir mal die Syntax von Sverweis() an.
if(iserror(vlookup(C41;'Sheet1'!$A$238:$A$268;1;FALSE));"2 years (xy)";"2 years(xyz")
Gruß
Rudi

Bild

Betrifft: AW: Wert mit Buchstaben&Zahlen in Range suchen
von: UweD
Geschrieben am: 12.05.2015 11:09:27
Hallo
Tabelle1

 BCDEFG
1      SuchwortAB-J123Ja
2AB-J121         
3AB-J122         
4AB-J123         
5AB-J124         
6AB-J125         
7AB-J126         
8AB-J127         
9AB-J128         

verwendete Formeln
Zelle Formel Bereich
G1 =WENN(ZÄHLENWENN(B2:B10;"*"& F1 & "*");"Ja";"Nein") 

Tabellendarstellung in Foren Version 5.49


Der Suchwert kann innerhalb des Textes vorkommen.
Bei Eindeutigkeit reicht. =WENN(ZÄHLENWENN(B2:B10;F1);"Ja";"Nein")
Gruß UweD

Bild

Betrifft: AW: Wert mit Buchstaben&Zahlen in Range suchen
von: Christian
Geschrieben am: 12.05.2015 11:25:08
Hat funktioniert, danke.
Eine Verständnisfrage noch:
=WENN(ZÄHLENWENN(B2:B10;"*"& F1 & "*");"Ja";"Nein")
Was würde hier der "fette" Teil prüfen?
DANKE und Grüße,
Christian

Bild

Betrifft: AW: Wert mit Buchstaben&Zahlen in Range suchen
von: UweD
Geschrieben am: 12.05.2015 11:41:15
Hallo nochmal
in F1 steht das, was gefunden werden soll.
Kannst du natürlich auch in die Formel direkt reinschreiben.
also so...
=WENN(ZÄHLENWENN(B2:B10;"*AB-J123*");"Ja";"Nein")
die * bewirken, dass auch innerhalb einer Zeichenkette gefunden wird
xyzAB-J123bbb
Wenn in der Zelle genau der suchtext vorkommen muss, dann reicht
=WENN(ZÄHLENWENN(B2:B10;"AB-J123");"Ja";"Nein")
Gruß UweD

Bild

Betrifft: na den String aus F1 -> AB-J123 owT
von: Matthias L
Geschrieben am: 12.05.2015 11:41:16


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wert mit Buchstaben&Zahlen in Range suchen"