Microsoft Excel

Herbers Excel/VBA-Archiv

Zahlen in Spalten zählen, wenn Überschrift üstimmt | Herbers Excel-Forum


Betrifft: Zahlen in Spalten zählen, wenn Überschrift üstimmt von: René
Geschrieben am: 09.02.2012 17:03:22

Guten Tag,

ich bin seit heute neu hier angemeldet, war bisher nur stiller Mitleser. Heute komme ich nicht mehr weiter und deshalb bitte ich um Hilfe.

Die Situation ist folgende:

Ich arbeite an einem Post Office und bearbeite Emails. Kalkulation dafür ist folgende: Antworten = 1 Punkt, Weiterleiten = 0,5 Punkte, Bearbeitet = 0,5 Punkte. Diese Zahlen kopiere ich aus einer online Seite und das funktioniert nur, wenn ich die Wörter mitkopiere.

Wenn diese drei Wörter vorkommen, ist die Kalkulation korrekt. Es kommt aber nicht immer vor, dass weitergeleitete dabei sind, also fehlt eine Spalte (es kommen noch mehr Begriffe vor, die aber nicht relevant sind für die Berechnung).

Wie kann das berechnet werden, wenn diese Spalte nicht vorhanden ist? Es kalkuliert jetzt nämlich die Spalte TEST mit, was nicht passieren sollte und darf (siehe Anlage https://www.herber.de/bbs/user/78827.xlsx
).

Konnte ich mich einigermaßen verständlich ausdrücken?

Vielen Dank für eure Hilfe,

René

  

Betrifft: AW: Zahlen in Spalten zählen, wenn Überschrift üstimmt von: Daniel
Geschrieben am: 09.02.2012 17:42:10


Hallo Rene,

das Einzig unglücklich war, dass die Namen schon in der Tabelle drüber erschienen sind. Der sverweis nimmt ja immer die erste Zelle auf die die Suchfunktion trifft. Ich habe die Namen in der oberen Tabelle auf Nummer 1 usw geändert.

Anbei die Lösung. Nicht elegant aber scheint zu funktionieren :-)

https://www.herber.de/bbs/user/78829.xls

Grüße

Daniel


  

Betrifft: AW: Zahlen in Spalten zählen, wenn Überschrift üstimmt von: Uwe (:o)
Geschrieben am: 09.02.2012 18:08:36

Hallo René,
wirklich zufrieden bin ich mit meiner "Monster"-Formel auch nicht, aber es sollte zumindest klappen (wenn die Überschriften immer in der gleichen Zeile stehen:

=WENNFEHLER(INDEX(B3:D3;1;(VERGLEICH("Antworten";$B$2:$D$2;0)));0)+WENNFEHLER(INDEX(B3:D3;1; (VERGLEICH("Weiterleiten";$B$2:$D$2;0)));0)*0,5+WENNFEHLER(INDEX(B3:D3;1;(VERGLEICH("Bearbeitet"; $B$2:$D$2;0)));0) *0,5

Hier die Datei: https://www.herber.de/bbs/user/78830.xlsx

Gruß
Uwe
(:o)


  

Betrifft: AW: Zahlen in Spalten zählen, wenn Überschrift üstimmt von: René
Geschrieben am: 09.02.2012 20:33:15

Vielen Dank euch beiden. Das sieht schon super aus und ich werde mich morgen nochmals damit beschäftigen. Bin überzeugt, dass das hilft.


Freue mich!


René


Beiträge aus den Excel-Beispielen zum Thema "Zahlen in Spalten zählen, wenn Überschrift üstimmt"