Microsoft Excel

Herbers Excel/VBA-Archiv

Bestimmte Wörter in einer Zelle zählen und die Sum

Betrifft: Bestimmte Wörter in einer Zelle zählen und die Sum von: Julia
Geschrieben am: 21.08.2014 16:32:31

https://www.herber.de/bbs/user/92224.xlsx

Hallo zusammen,

in meinem oben hinzugefügten Beispiel möchte ich das es in Spalte B alle Mitarbeiter zusammenzählt die in der Spalte J Ausbildung stehen haben.
Ich bekomme das soweit hin, dass ich wenn nur Ausbildung darin steht, sich die Formel das zieht.

Sobald aber ein weiterer Kommentar dabei steht funktioniert das nicht mehr.
Ich habe versucht eine Teil Formel hinzuzufügen. Das klappt aber leider nicht.

Kann mir dabei bitte jemand helfen?
Vielen Dank im Voraus.
Grüße Julia

  

Betrifft: AW: Bestimmte Wörter in einer Zelle zählen und die Sum von: Sheldon
Geschrieben am: 21.08.2014 16:41:27

Hallo Julia,

in Zelle B3:
{=SUMME(WENN(($H$1:$H$12=A3)*(NICHT(ISTFEHLER(SUCHEN("Ausbildung";$J$1:$J$12))));1))}

Matrixfunktion: ohne geschweifte Klammern eingeben, Eingabe mit Strg+Shift+Enter abschließen.

Dann in Zelle B4 kopieren.


Gruß
Sheldon


  

Betrifft: ohne { } und 2 Funktionen weniger von: WF
Geschrieben am: 21.08.2014 17:16:01

Hi,

=SUMMENPRODUKT((H1:H12=A3)*ISTZAHL(SUCHEN("Ausbildung";J1:J12)*1))

Salut WF


  

Betrifft: AW: Bestimmte Wörter in einer Zelle zählen und die Sum von: Daniel
Geschrieben am: 21.08.2014 17:43:53

Hi

=ZÄHLENWENNS(H1:H12;A3;I1:I12;"Anwesend";J1:J12;"*Ausbildung*")

die ZählenWenns-Funktion kann auch die Jokerzeichen * für beliebige Zeichen in beliebiger Anzahl (auch keine) und ? für genau ein beliebiges Zeichen verarbeiten.


"*Ausbildung*" zählt "enthält Ausbildung"
"Ausbildung*" zählt "beginnt mit Ausbildung"
"*Ausbildung" zählt "endet mit Ausbildung"

Gruß Daniel


  

Betrifft: AW: Bestimmte Wörter in einer Zelle zählen und die Sum von: rene
Geschrieben am: 22.08.2014 01:13:08

Danke , wieder was gelernt

rene


 

Beiträge aus den Excel-Beispielen zum Thema "Bestimmte Wörter in einer Zelle zählen und die Sum"