Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrere Strings aus Zelle extrahieren

Betrifft: Mehrere Strings aus Zelle extrahieren von: Heinz
Geschrieben am: 07.08.2014 09:24:17

Guten Morgen liebe Excellenten,

ich habe folgendes Problem:
Ich habe Zellen in denen Zahlenkombinationen wie folgt stehen:
7; 20; 24; 8; 9;
Zur Info:
Der gesamte Text steht in einer Zelle.
Die Anzahl der Zahlen in der Zelle variiert.
Vor jeder Zahl ist immer eine Leerstelle, nach jeder Zahl immer ein Strichpunkt.

Ich kann natürlich den Text in Spalten ausgeben, aber ich brauche leider eine Formellösung.

Mein Ziel:
Ich möchte, das die Ziffern (mit oder ohne Strichpunkt ist egal,
auch mit oder ohne Leerstelle ist egal)
untereinander ausgebeben werden

Also:
7;
20;
24;
8;
9;

Mein Ansatz ist die Formel "Teil", aber ich kann immer nur eine Zahl (die erste)
rausziehen. Die Formel in der ersten Zelle müsste also den ersten Strichpunkt suchen und die beiden Stellen davor ausgeben ( 7), die Formel in der Zelle darunter müsste den zweiten Strichpunkt suchen und die die beiden Stellen davo ausgeben (20) usw.

Könnt Ihr mir helfen?
... ich habe bei Excel gut angegeben, aber es ist wohl eher etwas zwischen Basiskenntnisse und gut ...

Ich wünsche allen einen schönen und erfolgreichen Tag.

Heinz

  

Betrifft: AW: Mehrere Strings aus Zelle extrahieren von: hary
Geschrieben am: 07.08.2014 10:27:31

Moin
Meinst du das so?



Tabelle3

 AB
27; 20; 24; 8; 97
3 20
4 24
5 8
6 9
7  

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B2:B7=TEIL(LINKS("; "&$A$2;FINDEN("#";WECHSELN("; "&$A$2;"; ";"#";ZEILE(B2))&"#")-1);FINDEN("#";WECHSELN("; "&$A$2;"; ";"#";ZEILE(A1))&"#")+1;99)  =MID(LEFT("; "&R2C1,FIND("#",SUBSTITUTE("; "&R2C1,"; ","#",ROW(RC))&"#")-1),FIND("#",SUBSTITUTE("; "&R2C1,"; ","#",ROW(R[-1]C[-1]))&"#")+1,99)

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: AW: Mehrere Strings aus Zelle extrahieren von: Daniel
Geschrieben am: 07.08.2014 10:32:12

Hi

Du kannst doch bei Finden die Startposition angeben, ab der gesucht werden soll.
Dh wenn du das zweite ; suchst, musst du als Startposition die Position des ersten ; plus 1 verwenden.

Ich würde mir hier die Position der Semikolons in eine Hilfsspalten schreiben, damit das Formelwerk nicht allzu kompliziert wird.

Gruß Daniel


  

Betrifft: Sensationnel von: Heinz
Geschrieben am: 07.08.2014 11:26:49

Hallo Harry, Hallo Daniel,

es klappt.
und: die Formel ist der Wahnsinn.

Vielen Dank und einen schönen Tag an Euch beide

Heinz


  

Betrifft: alternativ, Ermittlung der Zahlenwerte .... von: neopa C (paneo)
Geschrieben am: 07.08.2014 11:37:54

Hallo Heinz,

... Hary Formel in D2 ergibt Textwerte und für den letzten Wert auch mit Semikolon.

Folgende Formel in E2 (Formel nach unten kopieren) ergibt gleich die echten Zahlenwerte (siehe E1). Die Formel in E2 könnte bei Bedarf noch mit WENNFEHLER() geklammert werden:

Tabelle1

 ABCDE
1   077
27; 29; 24; 8; 9;   77
3    2929
4    2424
5    88
6    9;9
7     

Formeln der Tabelle
ZelleFormel
D1=SUMME(D2:D9)
E1=SUMME(E2:E9)
D2=TEIL(LINKS("; "&$A$2;FINDEN("#";WECHSELN("; "&$A$2;"; ";"#";ZEILE(B2))&"#")-1); FINDEN("#";WECHSELN("; "&$A$2;"; ";"#";ZEILE(A1))&"#")+1;99)
E2=LINKS(TEIL(A$2;FINDEN("#";WECHSELN(";"&A$2;";";"#";ZEILE(A1))); 9^9); FINDEN(";";TEIL(A$2;FINDEN("#";WECHSELN(";"&A$2;";";"#";ZEILE(A1))); 9^9))-1)+0


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Tabelle1

 ABCDE
1   077
27; 29; 24; 8; 9;   77
3    2929
4    2424
5    88
6    9;9
7     

Formeln der Tabelle
ZelleFormel
D1=SUMME(D2:D9)
E1=SUMME(E2:E9)
D2=TEIL(LINKS("; "&$A$2;FINDEN("#";WECHSELN("; "&$A$2;"; ";"#";ZEILE(B2))&"#")-1); FINDEN("#";WECHSELN("; "&$A$2;"; ";"#";ZEILE(A1))&"#")+1;99)
E2=LINKS(TEIL(A$2;FINDEN("#";WECHSELN(";"&A$2;";";"#";ZEILE(A1))); 9^9); FINDEN(";";TEIL(A$2;FINDEN("#";WECHSELN(";"&A$2;";";"#";ZEILE(A1))); 9^9))-1)+0


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: alternativ, Ermittlung der Zahlenwerte .... von: Heinz
Geschrieben am: 07.08.2014 14:17:45

Hallo Werner,

ich habe mich der Strichpunkte mit einer Hilfsspalte und "Wechseln" entledigt und mit einer weiteren
Hilfsspalte mit 1 mulitpliziert, um aus den Texten Zahlen zu machen.

... und ich war Stolz und glücklich ...
und jetzt kommst Du mit einer AIO-Formel

Spaß: Ich habe Harrys Formel schon in meine "brauch-ich-öfter-mal" Datei aufgenommen und werde das
auch mit Deiner Formel tun.

Vielen Dank und schöne Grüße aus dem Süden

Heinz


 

Beiträge aus den Excel-Beispielen zum Thema "Mehrere Strings aus Zelle extrahieren"