Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Text in Spalte
08.06.2018 17:55:18
Kaufmann
ich stehe vor dem folgenden Problem
ich habe in einer Spalte verschiedene Formen einer Bezeichnung und möchte diese in einer zweiten Spalte vereinheitlichen
FEA-3-0001 0001
FEA-4-0002 0002
FEA-5-999 0999
FEA-6-555 0555
Roboter 999 999
Roboter 888 888
Roboter A1234 1234
Roboter A4321 4321
So soll das Ergebniss aussehen.
Links habe ich die Daten mit überschüssigen informationen, rechts die Daten die vom System erfasst werden können. Aber durch die Option Tex in Spalte komme ich nciht weiter, Gibt es eine funktion die mir durch wenn funktionen ermöglicht verschiedene bedingungen zu erstellen womit ich dann die entscheidenden stellen aus der linken Spalte ausschneiden kann und in die rechte Spalte einfügen kann?
Habe eine funktion erstellt mit der ich aber nur 2 von 4 fälle abdecke, weiter komm ich nicht :(
=WENN(LINKS(B3;3)="FEA";RECHTS(B3;6);WENN(LINKS(B3;7)="Roboter";RECHTS(B3;3);0))
Vielen Dank im Voraus

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Text in Spalte
08.06.2018 17:56:53
Kaufmann
sorry die spalten Trennung hab ich jetzt mit ----- gekennzeichnet
FEA-3-0001 -----0001
FEA-4-0002 -----0002
FEA-5-999 -----0999
FEA-6-555 -----0555
Roboter 999 -----999
Roboter 888 -----888
Roboter A1234 -----1234
Roboter A4321 -----4321
AW: mit VERWEIS() , INDEX() & Textfunktionen ...
08.06.2018 19:04:07
neopa
Hallo,
.. so: =TEIL(A1;VERWEIS(9;1/ISTFEHL(--TEIL(A1;SPALTE(A1:INDEX(1:1;LÄNGE(A1)));1));SPALTE(A1:INDEX(1:1;LÄNGE(A1))))+1;9)
Gruß Werner
.. , - ...
AW: zur "Vereinheitlichung" ergänzend ...
08.06.2018 19:34:05
neopa
Hallo,
... addiere zum bisherigen Formelergebnis noch eine 0 und weise der Ergebniszelle das benutzerdefinierte Zahlenformat 0000;;
Die Auswertungsformel würde dann z.B. so aussehen:
=0+TEIL(A1;VERWEIS(9;1/ISTFEHL(--TEIL(A1;SPALTE(A1:INDEX(1:1;LÄNGE(A1)));1)); SPALTE(A1:INDEX(1:1;LÄNGE(A1))))+1;9)
Gruß Werner
.. , - ...
Anzeige
AW: zur "Vereinheitlichung" ergänzend ...
10.06.2018 12:35:49
Kaufmann
die erste formel ohne die 0 vorne funktioniert so wie ich es möchte. aber Ich
verstehe die formel einfach nciht xD
ich bin in excel nicht der profi, könntest du mir die Formel erklären?
AW: Text in Spalte
08.06.2018 19:25:00
Günther
Moin,
wenn dein Muster wirklich exemplarisch ist, dann wird doch in jedem Fall nach dem letzten Leerzeichen getrennt. Da bietet sich Power Query, -> http://www.excel-ist-sexy.de/power-query-das-add-in/ an, wo du ein Äquivalent des Text-in-Spalten hast, wo du beim ersten Leerzeichen (OderWasAuchImmer) splitten kannst.
AW: Trennung nach der letzten NichtZiffer...
08.06.2018 19:39:04
neopa
Hallo Günther,
... mit Deiner Aussage: "... dann wird doch in jedem Fall nach dem letzten Leerzeichen getrennt" hast Du Dich geirrt. Damit würden von den Beispieldaten nur 2 korrekt getrennt. Wie offensichtlich getrennt werden soll, kannst Du meiner hiesigen Betreffzeile entnehmen.
Gruß Werner
.. , - ...
Anzeige

310 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige