Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
356to360
356to360
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

SVerweis: Suche nach Teil einer Zelle

SVerweis: Suche nach Teil einer Zelle
01.01.2004 17:41:53
Franz W.
Hallo Fachleute,

ich hoffe, ich kann deutlich machen, worum es mir geht, es geht um folgende Formel:

=SVERWEIS(LINKS(A4;6);GebDaten;2;0)

- in A4 steht ein Datum (des aktuellen Jahres)
- in der Suchmatrix "GebDaten" ist die erste ein Datum - ein Geburtsdatum

Also soll nur nach dem Tag und dem Monat gesucht werden. Für das Suchkriterium lässt sich das mit " LINKS(A4;6) " lösen. Wie aber muss die Formel lauten, damit in der Suchmatrix "GebDaten" in der ersten Spalte auch nur nach den ersten 6 Zeichen gesucht wird? Ist das mit SVerweis überhaupt möglich?

Für Eure Hilfe schon mal besten Dank im Voraus und Grüße
Franz

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: SVerweis: Suche nach Teil einer Zelle
01.01.2004 17:53:48
Boris
Hi Franz,

das funktioniert nicht mit LINKS. Wenn in A4 13.12.2004 steht - dann ergbit =LINKS(A4;6) dann 38030.

So geht´s aber (Array-Formel! - GebDaten ist der Bereich C1:D5):

Toll!!
01.01.2004 18:01:36
Franz W.
Hi Boris,

super, das funktioniert!! Ganz vielen Dank!!

Beste Grüße
Franz
AW: SVerweis: Suche nach Teil einer Zelle
01.01.2004 17:54:00
andre
hallo franz,
du musst mal mit der letzten zahl/option experimentieren - funktion findet z.b. das exakte suchmuster oder das nächstliegende. dann über wenn auswerten, ob beim nächstliegenden tag und monat mit dem gesuchten übereinstimmen ...
gruss andre
AW: SVerweis: Suche nach Teil einer Zelle
01.01.2004 18:02:01
andre
pardon,
geht nur bei text bzw. wenn das datum als text in der zelle steht:
=SVERWEIS("ab*";A1:A4;1;0)
=SVERWEIS("01.01.*";C1:C4;1;0)
gruss andre
Anzeige
AW: SVerweis: Suche nach Teil einer Zelle
01.01.2004 18:02:43
Franz W.
Hallo Andre,

vielen Dank für Deine Hilfe, habe von Boris eine tolle Formel bekommen.

Trotzdem danke und viele Grüße
Franz
Und ein gutes neues Jahr Euch beiden!!
01.01.2004 18:07:46
Franz W.
Hi Boris und Andre,

sorry, war schon wieder so mit Excel verstrickt, dass ich ganz entrückt bin :-))).
Aber dazu sollte Zeit sein! Also ein gutes 2004 Euch!

Grüße
Franz
Danke - the same to you! oT
01.01.2004 18:17:18
Boris
Grüße Boris
AW: schliesse mich dem an .. oT
01.01.2004 18:19:13
andre

338 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige