Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Werkzeug
BildScreenshot zu Werkzeug Werkzeug-Seite mit Beispielarbeitsmappe aufrufen

SVerweis mit Teilstrings? | Herbers Excel-Forum


Betrifft: SVerweis mit Teilstrings? von: Martin
Geschrieben am: 04.12.2009 14:38:52

Also hier kommt mein Problem (siehe Datei https://www.herber.de/bbs/user/66371.xls):

Spalte A ist gegeben. Spalte B soll erzeugt werden. Und zwar mit SVerweis - oder ähnlichem - auf Bereich E1:F7. Denn der Eintrag in Spalte B richtet sich nach einem gefundenen Teilstring in der Zelle in Spalte A. Also, wenn in A1 der Teilstring "aus" enthalten ist, soll in B1 entsprechend E1:F7 "Gebäude" erscheinen.
USW für B2:B....
Wenn zwei oder mehr Teilstrings aus Spalte E enthalten sind, solllte ggf. nur der erste gefundene berücksichtigt werden.
Gut wäre weiterhin, wenn Gross/Kleinschreibung nicht berücksichtigt würden.

Danke Euch

Martin

  

Betrifft: AW: SVerweis mit Teilstrings? von: Jockel
Geschrieben am: 04.12.2009 15:14:12

hi Martin, meinst du so?



Tabelle1 (2)

 EF
1ausGebäude
2allSpielzeug
3roFarbe
4   
5   
6   
7   

verwendete Formeln
Zelle Formel
F1 =WENN(ODER(E1="";ISTNV(VERGLEICH("*"&E1&"*";$A$1:$A$1000;0)));"";INDEX(B:B;VERGLEICH("*"&E1&"*";$A$1:$A$1000;0)))

Tabellendarstellung in Foren Version 4.31

















cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: AW: SVerweis mit Teilstrings? von: Martin
Geschrieben am: 04.12.2009 15:57:30

Hallo Jockel,
Leider nein!
Die Spalten E und F sind fixe Grunddaten, die nicht verändert werden sollen (wie sonst auch die Verweis-Tabelle ja meistens eine gegebene Matrix ist)
Gefüllt werden soll nur die Spalte B - hätte erwartet, dass dann auch die Formeln in Zellen der Spalte B stehen müssen.
Bin aber kein Profi :-)

Sonst eine Idee?????

Martin


  

Betrifft: AW: SVerweis mit Teilstrings? von: fcs
Geschrieben am: 04.12.2009 17:34:51

Hallo Martin,

Die Formeln in Spalte B sind Matrix-Formeln. Die Formeleingabe muss mit der Tastenkombination Strg+Shift+Enter abgeschlossen werden. Formel in B2 eingeben, dann nach unten kopieren. Für die Bereiche E1:E7 (Suchwertebereich) und F1:F7 (Ergebnisbereich) hab ich Bereichsnamen festgelegt.

Geht auch anders ( http://www.excelformeln.de/formeln.html?gruppe=3 ) und kürzer.

Gruß
Franz

Tabellenblattname: Tabelle2

       A              B          C   D    E        F       
1   Begriff          Gefunden           aus     Gebäude   
2      Haus           Gebäude           unt       Blume   
3      Maus           Gebäude           ein     Schwein   
4     Mäuse          #nichts#           las   Blasebalg   
5      Glas         Blasebalg           sel       Vogel   
6       las         Blasebalg           dre    Werkzeug   
7  Drehbank          Werkzeug           ten      Gewerk   

Benutzte Formeln:
B2:  =WENN(MIN(WENN(ISTFEHLER(SUCHEN(Data.Suchen;A2;1));999;ZEILE(Data.Suchen)))=999;
    "#nichts#";INDEX(Data.Ergebnis;MIN(WENN(ISTFEHLER(SUCHEN(Data.Suchen;A2;1));999;
    ZEILE(Data.Suchen)));1))
B3:  =WENN(MIN(WENN(ISTFEHLER(SUCHEN(Data.Suchen;A3;1));999;ZEILE(Data.Suchen)))=999;
    "#nichts#";INDEX(Data.Ergebnis;MIN(WENN(ISTFEHLER(SUCHEN(Data.Suchen;A3;1));999;
     ZEILE(Data.Suchen)));1))

Namen in der Tabelle:
Data.Ergebnis:  =Tabelle2!$F$1:$F$7
Data.Suchen  :  =Tabelle2!$E$1:$E$7



  

Betrifft: AW: SVerweis mit Teilstrings? von: Martin Mühlhoff
Geschrieben am: 04.12.2009 22:29:22

Hallo Franz,

Das sieht super aus, nur ich werde es erst am Montag ausprobieren können.
Glaube du bist der Wizzard !!!

Danke soweit

Martin


Beiträge aus den Excel-Beispielen zum Thema "SVerweis mit Teilstrings?"