Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Name der Matrix erst in SVERWEIS-Funktion ermittel

Betrifft: Name der Matrix erst in SVERWEIS-Funktion ermittel von: Marek
Geschrieben am: 06.09.2004 10:49:31

Hallo,

ich möchte folgendes Matrix-Formel benutzen:
=SVERWEIS(A2;SVERWEIS(B2;MATRIX_Name;2);2)

Wobei Matrix_Name eine Hilfsmatrix ist, die den eigentlichen Matrix-Namen zurückgeben soll.

Das heißt, ich gehe mit gleichen Argumenten auf verschiedene Tabellen los.

Danke vorab

Marek






  


Betrifft: AW: Name der Matrix erst in SVERWEIS-Funktion ermittel von: Gert Seler
Geschrieben am: 06.09.2004 11:18:19

Hallo Marek,
was soll denn der SVERWEIS berechnen?
Bitte mehr Info.
mfg
Gert


  


Betrifft: AW: Name der Matrix erst in SVERWEIS-Funktion ermittel von: Marek
Geschrieben am: 06.09.2004 11:31:23

Hallo an Alle,
Hi Gerd!

Konkret arbeite ich mit Ländern und Postleitzahlen. Die Europäischen Länder habe ich in PLZ-Zonen eingeteilt. Jetzt existiert zu jedem Land eine Matrix, wo in einer Spalte die PLZ steht und in der nächsten die Zone.

Ich möchte also mit PLZ und Länderkennzeichen die dazugehörige Zone ermitteln.
Die PLZ 10100 ist in D sowie in F güligt, liegt aber in anderen Zonen.

Mit dem ermittelten Wert rechne ich dann weiter.
Hoffe, die Infos helfen weiter.

Marek


  


Betrifft: AW: Name der Matrix erst in SVERWEIS-Funktion ermittel von: Gert Seler
Geschrieben am: 06.09.2004 12:10:11

Hallo Marek,
mit "Format" --->"Sonderformate", findest Du verschiedene EU_PLZ-Formate.
Es ist berücksichtigen, das die EU-PLZ 4 bis 6stellige Werte beinhalten.
Zusätzlich sollte ein "Benutzerdefiniertes PLZ-Format" in dem Stil von "D 56564"
oder "CH 2324" gefertigt werden.
In Access2000 git es dieses Format als Vorlage (in Tabelle mit Assistent zu erstellen).
mfg
Gert


  


Betrifft: AW: Name der Matrix erst in SVERWEIS-Funktion ermittel von: Marek
Geschrieben am: 06.09.2004 12:24:41

Hallo Gerd,

Lieben Dank für Deine Antwort, aber dies hilft nicht weiter. Hintergrund ist, daß ich die Zonen-Daten regelmäßig extern einspiele. Zum Administrieren ist es tatsächlich das Einfachste, je Land eine Matrix zu haben. Natürlich muß ich GB gesondert behandeln.

Habe ich hier etwas schwieriges gefunden?

Marek


  


Betrifft: Lösung gefunden von: Marek
Geschrieben am: 06.09.2004 20:19:57

Hallo,

habe die Lösung inzwischen selber gefunden:

=SVERWEIS(A2;INDIREKT(SVERWEIS(B2;MATRIX_Name;2));2)

Marek


 

Beiträge aus den Excel-Beispielen zum Thema "Name der Matrix erst in SVERWEIS-Funktion ermittel"