Teile einer Zelle in eine neue Zelle schreiben

Bild

Betrifft: Teile einer Zelle in eine neue Zelle schreiben
von: {mskro}
Geschrieben am: 05.08.2015 10:46:33

Hallo Excelfreunde,
ich habe wieder mal ein kleines Problem und benötige Hilfestellung.
Ich muß aus einer Zelle 3 Zahlen (keinen Text), die jeweils dur einen Schrägstrich getrennt sind herausholen und in eine andere Zelle Schreiben. Die Zahlen können 1- oder 2-stellig sein. Da komme ich mit der mir bekannten Formel ala "LINKS(B11;FINDEN("/";B11)-1" oder auch"RECHTS(...)" nicht wirklich weiter, da der Schrägstrich ja nicht nur einmal darin enthalten ist.
Hat hier jemand eine Lösung für mich?
Mögliche Zelleninhalt:
Lager1/2/1
Standortname10/8/12
Name5/10/40
Ergebnisse sollen sein:
1/0/1
10/8/12
5/10/40
-leer-, wenn kein / in der Zelle vorhanden ist.
Vielleicht sogar in einzelne Zellen geschrieben. Das wird sich aber erst später zeigen, was für die Weiterverabeitung dann besser sein wird.
Gruß Manfred

Bild

Betrifft: wenn die /-Zahlen immer am Schluss stehen
von: WF
Geschrieben am: 05.08.2015 11:00:03
Hi,
folgende Arrayformel:
{=TEIL(A1;VERGLEICH(WAHR;ISTZAHL(TEIL(A1;ZEILE(1:99);1)*1);0);99)}
Salut WF

Bild

Betrifft: besser -> ZEILE($1:$99) ? kwT
von: Matthias L
Geschrieben am: 05.08.2015 11:08:56


Bild

Betrifft: Du meintest -> ZEILE(A1:A99)
von: WF
Geschrieben am: 05.08.2015 11:13:22
.

Bild

Betrifft: verdammt -> ZEILE(A$1:A$99)
von: WF
Geschrieben am: 05.08.2015 11:16:05
.

Bild

Betrifft: AW: Du meintest -> ZEILE(A1:A99)
von: Matthias L
Geschrieben am: 05.08.2015 11:19:20
Hallo WF
Hab ichs falsch verstanden ?
Wenn ich in B1 Deine Formel eingebe und runterkopiere ändert sich ja der Zeilen-Bezug, oder?

 AB
1Lager1/2/11/2/1
2Standortname10/8/12e10/8/12
3Name5/10/40me5/10/40

Formeln der Tabelle
ZelleFormel
B1{=TEIL(A1;VERGLEICH(WAHR;ISTZAHL(TEIL(A1;ZEILE(1:99);1)*1);0);99)}
B2{=TEIL(A2;VERGLEICH(WAHR;ISTZAHL(TEIL(A2;ZEILE(2:100);1)*1);0);99)}
B3{=TEIL(A3;VERGLEICH(WAHR;ISTZAHL(TEIL(A3;ZEILE(3:101);1)*1);0);99)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Deshalb dachte ich, ich machs mal Absolut
 AB
1Lager1/2/11/2/1
2Standortname10/8/1210/8/12
3Name5/10/405/10/40

Formeln der Tabelle
ZelleFormel
B1{=TEIL(A1;VERGLEICH(WAHR;ISTZAHL(TEIL(A1;ZEILE($1:$99);1)*1);0);99)}
B2{=TEIL(A2;VERGLEICH(WAHR;ISTZAHL(TEIL(A2;ZEILE($1:$99);1)*1);0);99)}
B3{=TEIL(A3;VERGLEICH(WAHR;ISTZAHL(TEIL(A3;ZEILE($1:$99);1)*1);0);99)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Klär mich bitte auf wenn ichs falsch verstanden habe.
Gruß Matthias

Bild

Betrifft: AW: wenn die /-Zahlen immer am Schluss stehen
von: {mskro}
Geschrieben am: 05.08.2015 11:30:00
Hallo WF,
das sieht schon richtig gut aus, nur fehlt mir der Teil, wo die Zellen ohne einen Schrägstrich betrachtet bzw. mit "-leer-" gekennzeichnet werden.
Gruß Manfred

Bild

Betrifft: einfach Länge nach Wechseln abfragen
von: Matthias L
Geschrieben am: 05.08.2015 11:43:12
Hi

 AB
1Lager1/2/11/2/1
2Standortname10/8/1210/8/12
3Name5/10/405/10/40

Formeln der Tabelle
ZelleFormel
B1{=WENN(LÄNGE(WECHSELN(A1;"/";""))<LÄNGE(A1);TEIL(A1;VERGLEICH(WAHR;ISTZAHL(TEIL(A1;ZEILE($1:$99);1)*1);0);99);"")}
B2{=WENN(LÄNGE(WECHSELN(A2;"/";""))<LÄNGE(A2);TEIL(A2;VERGLEICH(WAHR;ISTZAHL(TEIL(A2;ZEILE($1:$99);1)*1);0);99);"")}
B3{=WENN(LÄNGE(WECHSELN(A3;"/";""))<LÄNGE(A3);TEIL(A3;VERGLEICH(WAHR;ISTZAHL(TEIL(A3;ZEILE($1:$99);1)*1);0);99);"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: Super, danke (owt)
von: {mskro}
Geschrieben am: 05.08.2015 11:58:28


Bild

Betrifft: oder kürzer ...
von: Matthias L
Geschrieben am: 05.08.2015 12:01:14
Hallo

 AC
1Test0/8/150/8/15
2Test0815 

Formeln der Tabelle
ZelleFormel
C1{=WENN(ISTZAHL(FINDEN("/";A1));TEIL(A1;VERGLEICH(WAHR;ISTZAHL(TEIL(A1;ZEILE($1:$99);1)*1);0);99);"")}
C2{=WENN(ISTZAHL(FINDEN("/";A2));TEIL(A2;VERGLEICH(WAHR;ISTZAHL(TEIL(A2;ZEILE($1:$99);1)*1);0);99);"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: Danke Matthias (owt)
von: {mskro}
Geschrieben am: 05.08.2015 12:06:19


Bild

Betrifft: Geht auch VBA?
von: {mskro}
Geschrieben am: 06.08.2015 10:13:23
Nochmals Hallo,
kann ich diese Matrixformel, bzw. das Ergebnis aus dieser Formel auch per VBA in eine Variable schreiben?
Gruß Manfred

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Teile einer Zelle in eine neue Zelle schreiben"