Microsoft Excel

Herbers Excel/VBA-Archiv

Nach Text und Zahl suchen


Betrifft: Nach Text und Zahl suchen von: kesici
Geschrieben am: 11.07.2018 11:55:27

Hallo zusammen,

ich brauche eure Hilfe. Es geht um eine Tabelle bzw. eine Spalte aus der ich bestimmte Werte in eine andere Spalte übertragen muss. Dabei muss ich nur Werte in die nächste Spalte mitnehmen, die das Wort "Task" und daraufhin beliebige Ziffern haben.

Ein Beispiel:

Das ist ein Test - Task 12345
Das ist ein Test

Von den beiden Werten da oben sollte nur Das ist ein Test - Task 12345 in die nächste Spalte übertragen werden. Die eindeutige Bedingung hierfür wäre das Wort Task und dann beliebige Ziffern. Jedoch krieg ich das nicht hin.

Was ich bisher geschafft habe ist die folgende Formel:
=WENNFEHLER(TEIL(B2;SUCHEN(B2;B2;1);SUCHEN(" Task";B2;1)-1);"")

Ich finde keine Möglichkeit nach einem String und Ziffern gleichzeitig zu suchen.

Kann mir jemand weiterhelfen?

  

Betrifft: AW: Nach Text und Zahl suchen von: UweD
Geschrieben am: 11.07.2018 12:04:38

Hallo

so...

Tabelle1

 ABC
1 sooder so
2Das ist ein Test - Task 12345Task 12345Task 12345
3Das ist ein Test  

verwendete Formeln
Zelle Formel Bereich N/A
B2:B3=WENN(ISTZAHL(SUCHEN("Task ";A2));TEIL(A2;SUCHEN("Task ";A2);999);"")  
C2:C3=WENNFEHLER(TEIL(A2;SUCHEN("Task ";A2);999);"")  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




LG UweD


  

Betrifft: AW: Nach Text und Zahl suchen von: kesici
Geschrieben am: 11.07.2018 12:12:35

Hallo,

danke für die schnelle Antwort, aber das klappt nicht ganz.

Ich habe in der Spalte auch Werte, die nur das Wort Task ohne eine beliebige Zahl danach haben. Mit der obigen Formel werden auch diese Werte mit in die neue Spalte genmommen.

Was ich vielleicht noch erwähnen sollte ist, in die nächste Spalte soll nur der Inhalt bis zum Wort Task übernommen werden.

Ein Beispiel:

Das ist ein Test - Task 12345
Das ist ein Test ohne die Bedingung


"Das ist ein Test" soll in die nächste Spalte und "Das ist ein Test ohne die Bedingung" nicht


  

Betrifft: AW: Nach Text und Zahl suchen von: Hajo_Zi
Geschrieben am: 11.07.2018 12:08:04


Data UTL

 AB
1Das ist ein Test - Task 12345Das ist ein Test - Task 12345
2Das ist ein Test 

verwendete Formeln
Zelle Formel Bereich N/A
B1:B2=WENN(ISTZAHL(SUCHEN("Task";A1));WENN(ISTZAHL(TEIL(A1;SUCHEN("Task";A1)+5;1)*1);A1;"");"")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




GrußformelHomepage

Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.


  

Betrifft: AW: Nach Text und Zahl suchen von: kesici
Geschrieben am: 11.07.2018 12:21:34

Genau das hat geklappt. Endlich nach stundenlanger Suche. Ich weiß zwar nicht wie, aber es klappt. Dankeee :)

Jetzt muss ich noch herausfinden, wie ich nur den Text bis zum Wort Task in die nächste Spalte übernehme


  

Betrifft: AW: Nach Text und Zahl suchen von: Hajo_Zi
Geschrieben am: 11.07.2018 12:23:45


Data UTL

 ABC
1Das ist ein Test - Task 12345Das ist ein Test - Task 12345Das ist ein Test -
2Das ist ein Test  

verwendete Formeln
Zelle Formel Bereich N/A
B1:B2=WENN(ISTZAHL(SUCHEN("Task";A1));WENN(ISTZAHL(TEIL(A1;SUCHEN("Task";A1)+5;1)*1);A1;"");"")  
C1:C2=WENN(ISTZAHL(SUCHEN("Task";A1));WENN(ISTZAHL(TEIL(A1;SUCHEN("Task";A1)+5;1)*1);LINKS(A1;SUCHEN("Task";A1)-1);"");"")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Nach Text und Zahl suchen von: kesici
Geschrieben am: 11.07.2018 12:27:13

Vielen vielen Dank.


  

Betrifft: AW: Nach Text und Zahl suchen von: Rudi Maintaire
Geschrieben am: 11.07.2018 12:20:42

Hallo,
=WENN(ISTZAHL(TEIL(A2;SUCHEN("Task";A2)+5;99)*1);LINKS(A2;SUCHEN("Task";A2)-4);"")

Gruß
Rudi


  

Betrifft: AW: Nach Text und Zahl suchen von: kesici
Geschrieben am: 11.07.2018 12:26:58

Vielen vielen Dank.


Beiträge aus dem Excel-Forum zum Thema "Nach Text und Zahl suchen"