Microsoft Excel

Herbers Excel/VBA-Archiv

wenn text in zelle, dann... | Herbers Excel-Forum


Betrifft: wenn text in zelle, dann... von: flo
Geschrieben am: 27.01.2010 10:35:14

Hallo zusammen,

ich habe ein kleines Problem mit einer Formel und würde mich freuen, wenn mir jemand von euch die Lösung erklären könnte. Es geht um Folgendes:


Ich habe zwei Zellen: Wenn in der einen Zelle (z.B. Zelle A1) ein Text steht, dann soll in der anderen (z.B. A2) "JA" stehen.

Wenn A1 aber leer ist, dann soll in A2 "Nein" stehen.

Weiß zufällig jemand wie man das macht? Danke für eure Hilfe

Beste Grüße Flo

  

Betrifft: AW: wenn text in zelle, dann... von: klausk
Geschrieben am: 27.01.2010 10:45:51

Moin Flo,

versuchs mal so an Deinem Beispiel in A 2 folgende Bedingung:

=WENN(A1="";"Ja";"Nein")


Liebe Grüße vom Klaus


  

Betrifft: AW: wenn text in zelle, dann... von: Beverly
Geschrieben am: 27.01.2010 10:46:49

Hi Flo,

Tabelle1

 AB
1AlleJa
2  Nein
3  Nein
4  Nein
5HalloJa

verwendete Formeln
Zelle Formel
B1 =WENN(A1="";"Nein";"Ja")
B2 =WENN(A2="";"Nein";"Ja")
B3 =WENN(A3="";"Nein";"Ja")
B4 =WENN(A4="";"Nein";"Ja")
B5 =WENN(A5="";"Nein";"Ja")

Tabellendarstellung in Foren Version 5.5



GrußformelBeverly's Excel - Inn


  

Betrifft: AW: wenn text in zelle, dann... von: Peter Feustel
Geschrieben am: 27.01.2010 10:47:04

Hallo flo,

dann schreib in A2 =WENN(A1="";"Nein";"Ja")

Gruß Peter


  

Betrifft: AW: wenn text in zelle, dann... von: flo
Geschrieben am: 27.01.2010 10:48:39

Vielen Dank euch allen.

Hat wunderbar geklappt :-)

Schönen Tag noch


  

Betrifft: vorsicht, leezeichen!!! von: jockel
Geschrieben am: 27.01.2010 11:09:38

hi Flo, wenn in der der vermeintlich leeren zelle einfach nur ein leerzeichen (versteckt) ist, funzt das nicht mehr... ... deshalb mein vorschlag..:

Tabelle2

 ABC
1text   
2jaachtung leerzeichen!nein
3JaJaNein

verwendete Formeln
Zelle Formel
A2 =WENN(A1="";"nein";WENN(CODE(A1)=32;"achtung leerzeichen!";"ja"))
B2 =WENN(B1="";"nein";WENN(CODE(B1)=32;"achtung leerzeichen!";"ja"))
C2 =WENN(C1="";"nein";WENN(CODE(C1)=32;"achtung leerzeichen!";"ja"))
A3 =WENN(A1="";"Nein";"Ja")
B3 =WENN(B1="";"Nein";"Ja")
C3 =WENN(C1="";"Nein";"Ja")

Tabellendarstellung in Foren Version 5.5




cu jörg eine rückmeldung wäre ganz reizend



Beiträge aus den Excel-Beispielen zum Thema "wenn text in zelle, dann..."