Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl unterschiedlicher Teilstrings

Betrifft: Anzahl unterschiedlicher Teilstrings von: Josi
Geschrieben am: 04.11.2014 11:35:28

Hallo zusammen
ich stehe vor folgendem Problem
In Zeilen steht folgendes

08.06.MO 14.06.RE 15.06.MY 12.07.RE 13.07.RE
das können bis zu 50 Einträge sein. nun sollte ich wissen wieviel unterschiedliche Einträge es sind bezüglich den letzten 2 Stellen (also den Buchstaben) in dem Beispiel sollte als Lösung 3 rauskommen.
Wenn möglich als Formellösung.
Im Voraus schon besten Dank
Gruß
Josi

  

Betrifft: AW: Anzahl unterschiedlicher Teilstrings von: Rudi Maintaire
Geschrieben am: 04.11.2014 11:46:13

Hallo,
per Hilfsspalte:

ABC
108.06.MOMO3
214.06.RERE 
315.06.MYMY 
412.07.RERE 
513.07.RERE 

ZelleFormel
B1=RECHTS(A1;2)
C1{=SUMME(1/ZÄHLENWENN(B1:B5;B1:B5))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.


Gruß
Rudi


  

Betrifft: ohne Hilfsspalte von: WF
Geschrieben am: 04.11.2014 12:19:28

Hi,

{=SUMME((VERGLEICH(RECHTS(A1:A5;2);RECHTS(A1:A5;2);0)=ZEILE(1:5))*1)}

sonstige Alternativen in unserer
http://excelformeln.de/formeln.html?welcher=42

Salut WF


  

Betrifft: AW: ohne Hilfsspalte von: Josi
Geschrieben am: 04.11.2014 15:59:30

Danke für die Lösungsansätze aber ihr geht immer von Spalten aus meine Daten stehen in einer Zeile
von A1 bis A20
Wenn ihr da auch was wüsstet wäre echt super

Vielen Dank
Josi


  

Betrifft: Baby - überleg mal ! von: WF
Geschrieben am: 04.11.2014 16:23:12

"meine Daten stehen in einer Zeile von A1 bis A20"

A1 bis A20 ist eine SPALTE
A1 bis M1 wäre eine ZEILE

WF


  

Betrifft: AW: Baby - überleg mal ! von: Josi
Geschrieben am: 04.11.2014 17:26:47

Oh Mann sorry das ist wenn man mehreres nebenher macht natürlich von a1 bis M1

Seufz

Schöne Grüße
Josi


  

Betrifft: Was ist so schwer, das entsprd anzupassen, ... von: Luc:-?
Geschrieben am: 04.11.2014 17:41:07

…Josi;
als MatrixFml zB so: {=SUMME(--(VERGLEICH(RECHTS(A1:M1;2);RECHTS(A1:M1;2);0)=SPALTE(A:M)))}
bzw kürzer und normal, aber wg verwendeter UDFs außer Konkurrenz:
=ANZAHL2(Splint(ListOn(TransFor(A1:M1;"MaskOn(#1,""gb"")");;1)))
Luc :-?


  

Betrifft: Falls jeder Eintrag in einer separaten Zelle ... von: Luc:-?
Geschrieben am: 04.11.2014 11:59:03

…steht, Josi,
dann für stets 2 EndBuchstaben bspw mit dieser MatrixFml:
{=SUMME(--(HÄUFIGKEIT(100*(CODE(LINKS(RECHTS(A4:A8;2)))-64)+CODE(RECHTS(A4:A8))-64; 100*(CODE(LINKS(RECHTS(A4:A8;2)))-64)+CODE(RECHTS(A4:A8))-64)>0)) }
Gruß, Luc :-?


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl unterschiedlicher Teilstrings"