Microsoft Excel

Herbers Excel/VBA-Archiv

Aggregat mit Teilstring

Betrifft: Aggregat mit Teilstring von: hkoepp63
Geschrieben am: 29.01.2020 13:10:15

Hallo Zusammen,
ich muss eine Formel dahingehend anpassen, daß Aggregat den Teilstring in einer Spalte berücksichtigt.

Original:

=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!A$3:A$5000)/
(Tabelle1!P$3:P$5000>=D$3)/(Tabelle1!P$3:P$5000<=F$3)/(Tabelle1!P$3:P$5000 <>0)/
(Tabelle1!J$3:J$5000<>"Berlin");ZEILE(B3)));"")
Geänderte Formel:
=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!A$3:A$5000)/
(Tabelle1!P$3:P$5000>=D$3)/(Tabelle1!P$3:P$5000<=F$3)/(Tabelle1!P$3:P$5000 <>0)/
(Tabelle1!J$3:J$5000<>"Berlin")/((Tabelle1!S$3:S$5000="[1000]*")+(Tabelle1!S$3:S$5000="[1015]*"));ZEILE(A1)));"")
In Tabelle 1 in Spalte S sind Einträge:

  • [1000] ...Text
    [1009] ... Text
    [1050] ... Text

  • Diese sollen als "ODER" Abfrage hinzugefügt werden.
    Anbei die Tabelle:
    https://www.herber.de/bbs/user/134819.xlsx

    Was mache ich falsch?
    Beste Grüße
    Hinnerk

    Betrifft: AW: Aggregat mit Teilstring
    von: SF
    Geschrieben am: 29.01.2020 13:15:41

    Hola,
    =..../((links(Tabelle1!S$3:S$5000;6)="[1000]")+(links(.....))...
    Gruß,
    steve1da

    Betrifft: AW: Aggregat mit Teilstring
    von: hkoepp63
    Geschrieben am: 29.01.2020 13:41:55

    Hallo steve1da,
    vielen Dank für die schnelle Antwort.

    Hat Super funktioniert.

    Beste Grüße
    Hinnerk

    Beiträge aus dem Excel-Forum zum Thema "Aggregat mit Teilstring"