Formelteile aus Zellen beziehen

Bild

Betrifft: Formelteile aus Zellen beziehen
von: Nils
Geschrieben am: 19.04.2005 15:49:40
Hallo Forum,
wie kann ich Formelteile in einer anderen Zelle zu einer kompletten Formel zusammenfügen?
BSP:
ZELLE A1: ($D$462:$D$557,$D$558:$D$597,$D$700:$D$754,$D$1364,$D$755)
In Zelle A2 soll dann die
SUMME($D$462:$D$557,$D$558:$D$597,$D$700:$D$754,$D$1364,$D$755)
berchnet werden.
Bevor die Fragen kommen: Von diesen Additionsformeln habe ich ca 200, die in etwa 50 Tabellenblättern auftauchen, um das Ganze transparent und variabel zu gestalten, wäre ein indirekter Zellbezug prima. Mit INDIREKT bekomme ich ein #REF...
Dank und Gruss

Bild

Betrifft: AW: Formelteile aus Zellen beziehen
von: Volker
Geschrieben am: 19.04.2005 18:04:40
Hallo Nils,
was mir sofort aufgefallen ist, ist dass Du die Bereiche durch Kommas trennst.
Wenn man eine Summenformel über nicht zusammenhängende Bereiche erstellt, werden die Teilbereiche durch Semikolon getrennt. Hab ich ausprobiert, also
ZELLE A1: ($D$462:$D$557;$D$558:$D$597;........usw)
hat aber nichts geholfen.
Zusammengesetzte Summenformeln hat Mikrosoft so wohl nicht vorgesehen.
Wenn ich es probiere, erhalte ich allerdings #WERT oder #BEZUG statt #REF.
Schade, aber wir lassen uns gern eines Besseren belehren.
Was geht ist das Aufteilen der Teilbezüge auf mehrere Zellen:
Bsp.:
A1: a3:a10
A2: C3:C11
B1 enthält Formel =SUMME(INDIREKT(A1);INDIREKT(A2)) und rechnet richtig.
Vielleicht bringt Dich das erstmal weiter.
Gruß
Volker
Bild

Betrifft: AW: Formelteile aus Zellen beziehen
von: HermannZ
Geschrieben am: 19.04.2005 20:09:49
Hallo Nils,
du kannst wohl du Summe nicht zusammenhängender Bereiche berechnen mit Summe Indirekt
und zwar so;
=SUMME(INDIREKT({"D462:D557"."D558:D597"."D700:D754"."D1364"."D755"}))
Gruß hermann
Bild

Betrifft: AW: Fehler gemacht........mT
von: HermannZ
Geschrieben am: 19.04.2005 20:25:55
Hallo Nils,
habe gerade gemerkt das, das was ich geschrieben habe Blödsinn ist,mann sollte doch besser es erst ausprobieren.
hier die richtige Formel;
=SUMME(SUMMEWENN(INDIREKT({"D462:D557"."D558:D597"."D700:D754"."D1364"."D755"});">"&0))
Gruß hermann
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formelteile aus Zellen beziehen"