mehrere Abfragen von Anzahl zwischen 2 Werten

Bild

Betrifft: mehrere Abfragen von Anzahl zwischen 2 Werten
von: Hacho1
Geschrieben am: 09.03.2005 17:07:43
Hallo,
möchte gerne eine Auswertung von Mitarbeiter Stunden machen, die folgende Kriterien abfragen :
Anzahl der MA die im Bereich 0 - 30 Std. positiv liegen,
Anzahl der MA die im Bereich 0 - 30 Std. negativ liegen,
Anzahl der MA die im Bereich grösser 30 - 60 Std. positiv liegen,
Anzahl der MA die im Bereich grösser 30 - 60 Std. negativ liegen,
Anzahl der MA die im Bereich grösser 60 - 90 Std. positiv liegen
Anzahl der MA die im Bereich grösser 60 - 90 Std. negativ liegen
Anzahl der MA die grösser 90 Std. positiv haben
Anzahl der MA die grösser 90 Std. negativ haben
Mit der Funktion "Zählenwenn" komm ich nicht weit.
Oder irre ich mich da ?
Hat jemand Ideen wie man das am galantesten lösen könnte ??
Beispiel Datei : https://www.herber.de/bbs/user/19415.xls

Bild

Betrifft: AW: mehrere Abfragen von Anzahl zwischen 2 Werten
von: Matthias G
Geschrieben am: 09.03.2005 17:19:29
Hallo Hacho,
=ZÄHLENWENN($A$8:$A$180;"<="&B3)-ZÄHLENWENN($A$8:$A$180;"<"&B2)

B2: Untergrenze
B3: Obergrenze
A8:A180: Suchbereich
Gruß Matthias
Bild

Betrifft: AW: mehrere Abfragen von Anzahl zwischen 2 Werten
von: Hacho1
Geschrieben am: 10.03.2005 13:06:38
Hallo Matthias,
sorry für späte Antwort !
Es klappt nicht mit Deiner Formel, so gibt er mir einen falschen Wert raus.
schau hier : https://www.herber.de/bbs/user/19454.xls
Bild

Betrifft: AW: mehrere Abfragen von Anzahl zwischen 2 Werten
von: Matthias G
Geschrieben am: 10.03.2005 15:18:50
Hallo Hacho,
du hast die Formel nicht richtig übertragen:
mein Vorschlag:
=ZÄHLENWENN($A$8:$A$180;"<="&B3)-ZÄHLENWENN($A$8:$A$180;"<"&B2)
deine Umsetzung:
=ZÄHLENWENN($B$2:$B$17;"<="&F1)-ZÄHLENWENN($B$2:$B$17;">="&E1)

Du siehst, das zweite Ungleichheitszeichen ist falsch.
Wichtig ist, dass die Obergrenze minus die Untergrenze gezählt wird, also in deiner Beispielmappe muss die Zahl in Spalte F immer größer sein als die in Spalte E (was bei Zeile 2 nicht zutrifft!).
Gruß Matthias
Bild

Betrifft: AW: mehrere Abfragen von Anzahl zwischen 2 Werten
von: Hacho1
Geschrieben am: 11.03.2005 17:44:26
...kleiner Tippfehler, grosse Wirkung ;-(
Besten DANK !!!!!
So hat's geklappt, hast mir sehr geholfen.
 Bild

Beiträge aus den Excel-Beispielen zum Thema "mehrere Abfragen von Anzahl zwischen 2 Werten"