Microsoft Excel

Herbers Excel/VBA-Archiv

WENNFEHLER Fkt mit zwei alternativen Werten

Betrifft: WENNFEHLER Fkt mit zwei alternativen Werten von: Chris
Geschrieben am: 13.11.2014 13:39:16

Hallo,
ich habe mir gerade eine Excelfunktion aus dem Internet gezogen wie in diesem Beispiel:
http://www.at-exceltraining.de/index.php/fragen-a-anworten-zu-excel/49-formeln-und-funktionen/179-sverweis-mit-mehreren-suchergebnissen.html

Nun würde ich diese Funktion gerne mit zwei alternativen Suchkriterien ausstatten. Sofern das möglich ist. In der Formel unten sollte dann für $E$1 so etwas stehen wie ODER(11;12).

Kann man so etwas irgendwie hinbekommen??

=WENNFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=$E$1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14; $E$1)+1-ZEILE(A1)));"")

Besten Dank und Grüße
Chris

  

Betrifft: teste mal ... von: neopa C (paneo)
Geschrieben am: 13.11.2014 13:50:47

Hallo Chris,

... so: {=WENNFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14={11.12})*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14; $E$1)+1-ZEILE(A1)));"")}

bzw. {=WENNFEHLER(INDEX($B$2:$B$14;KGRÖSSTE((($A$2:$A$14=11)+($A$2:$A$14=12))*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14; $E$1)+1-ZEILE(A1)));"")}


Gruß Werner
.. , - ...


  

Betrifft: AW: teste mal ... von: Chris
Geschrieben am: 13.11.2014 17:18:09

Hi Werner,

danke für die schnelle Antwort. Leider funktionieren deine Funktionsvorschläge bei mir nicht. Ich habe beide Varianten ausprobiert. Hier meine Formel für den zweiten Versuch (Mit den Daten meines Excels)

=WENNFEHLER(INDEX('OpRisk Reference Data'!$A:$A;KGRÖSSTE((('OpRisk Reference Data'!$L:$L="11") +('OpRisk Reference Data'!$L:$L="21"))*(ZEILE('OpRisk Reference Data'!$L:$L)-1); ZÄHLENWENN((('OpRisk Reference Data'!$L:$L="11")+('OpRisk Reference Data'!$L:$L="21")) +1-ZEILE('OpRisk Reference Data'!L1)));"")

Er zeigt da folgenden Fehler:


Weisst du, was ich falsch gemacht habe??

Grüße
Chris


  

Betrifft: AW: teste mal ... von: Matze Matthias
Geschrieben am: 13.11.2014 17:24:24

Ja die Formelmusst du mit STRG+SHIFT+ENTER abschließen!


  

Betrifft: ooops weiterhin offen von: Matze Matthias
Geschrieben am: 13.11.2014 17:30:31

Hallo Ihr Beiden,
(ZEILE('OpRisk Reference Data'!$L:$L)-1 du willst doch Zeilen angeben und nicht L:L Spalte

ich blick leider nicht genau was du da vorhast und bitte daher Werner um weitere Hilfe, danke
Gruß Matze

Denk daran das es eine Matrixformel ist.
einfacher für solche Aufgaben ist eine simple Musterdatei mit dem Aufbau.


  

Betrifft: hier ist wohl einiges im Argen ... von: neopa C (paneo)
Geschrieben am: 13.11.2014 17:37:30

Hallo Chris,

... jetzt nur auf die Schnelle. Im ZÄHLENWENN()-Formelteil fehlt das Argument. Unabhängig davon ist der Ansatz wahrscheinlich so auch nicht richtig.

Stell doch mal einen relevanten Auszug (können Dummy-Daten sein) aus der Tabelle OpRisk Reference Data' hier als Arbeitsmappe ein und schreibe dazu was Drin Ziel ist. Dann sehen wir weiter. ich aber frühestens Morgen.


Gruß Werner
.. , - ...


  

Betrifft: AW: WENNFEHLER Fkt mit zwei alternativen Werten von: Chris
Geschrieben am: 14.11.2014 12:26:51

Hallo zusammen,

ich habe jetzt mal eine Testdatei hochgeladen, in der ich auch nochmal mein Ziel erläutert habe. Ich hoffe ihr könnt mir weiterhelfen.

https://www.herber.de/bbs/user/93769.xlsx


Schon mal danke
Chris


  

Betrifft: jetzt ist es eindeutig ... von: neopa C (paneo)
Geschrieben am: 14.11.2014 14:03:49

Hallo Chrsi,

... Formel nach unten kopieren:

 E
6KRI No.
7BOCFFM03
8BOCFFM06
9BOCFFM12
10BOCFFM14
11BOCFFM16
12BOCFFM18
13BOCFFM19
14 

Formeln der Tabelle
ZelleFormel
E7{=WENN(ZEILE(A1)>SUMME(ZÄHLENWENN('OpRisk Reference Data'!H:H;{11;12})); "";INDEX('OpRisk Reference Data'!A:A;KKLEINSTE(WENN('OpRisk Reference Data'!H$1:H$99={"11"."12"};ZEILE(A$1:A$99)); ZEILE(A1))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: WENNFEHLER Fkt mit zwei alternativen Werten von: Chris
Geschrieben am: 15.11.2014 13:03:32

Hallo Werner,

danke für die detaillierte Lösung... So läuft das Ding einwandfrei!

Beste Grüße
Chris


 

Beiträge aus den Excel-Beispielen zum Thema "WENNFEHLER Fkt mit zwei alternativen Werten"