Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Funktion

Betrifft: Wenn Funktion von: Peter Knierim
Geschrieben am: 17.08.2008 11:53:50

Hallo,
brauche mal wieder Hilfe
Ich bin dabei einen Ampelreport zu basteln

Ich haben einen errechneten Wert von -5% in C35 dann ergibt sich in D35 mit der Formel =ABS(C35*100/5) der Wert 100%

dem zufolge bei -4% = 80% bis 0% =0%

jetzt das Problem und die Frage:

ist der Wert in C35 grösser 0 also 1 wird in der Formel der wert 20 berechnet soll aber 0% ausgeben

das gleiche in die andere Richtung

Ist der Wert kleiner gleich -5% also -6% muss der Wert in D35 bei 100% bleiben

Kann man hier die Wenn Formel anwenden wenn ja wie, oder hat jemand eine andere Idee

Vielen Dank vorab an das Forum, was mir schon viel geholfen hat

Gruß Peter Knierim

  

Betrifft: AW: Wenn Funktion von: Reinhard
Geschrieben am: 17.08.2008 12:17:18

Hallo Peter,

zwei Lösungen:

Tabellenblatt: [Mappe2]!Tabelle1
   |    C   |    D    |    E    |
---|--------|---------|---------|
35 | -5,0 % | 100,0 % | 100,0 % |
---|--------|---------|---------|
36 | -5,1 % |   0,0 % |   0,0 % |
---|--------|---------|---------|
37 | -6,0 % |   0,0 % |   0,0 % |
---|--------|---------|---------|
38 |  0,0 % |   0,0 % |   0,0 % |
---|--------|---------|---------|
39 |  1,0 % |   0,0 % |   0,0 % |
---|--------|---------|---------|
40 | -3,0 % |  60,0 % |  60,0 % |
--------------------------------'
Benutzte Formeln:
D35:  =WENN(UND(C35>=-5;C35<0);C35/-5*100;0)
D36:  =WENN(UND(C36>=-5;C36<0);C36/-5*100;0)
D37:  =WENN(UND(C37>=-5;C37<0);C37/-5*100;0)
D38:  =WENN(UND(C38>=-5;C38<0);C38/-5*100;0)
D39:  =WENN(UND(C39>=-5;C39<0);C39/-5*100;0)
D40:  =WENN(UND(C40>=-5;C40<0);C40/-5*100;0)
E35:  =UND(C35>=-5;C35<0)*C35/-5*100
E36:  =UND(C36>=-5;C36<0)*C36/-5*100
E37:  =UND(C37>=-5;C37<0)*C37/-5*100
E38:  =UND(C38>=-5;C38<0)*C38/-5*100
E39:  =UND(C39>=-5;C39<0)*C39/-5*100
E40:  =UND(C40>=-5;C40<0)*C40/-5*100

C35:E40
haben das Zahlenformat: 0,0 "%"


Gruß
Reinhard


  

Betrifft: UND bei derselben Zelle funktioniert ..... von: WF
Geschrieben am: 17.08.2008 12:42:46

..... logischerweise NIE !


  

Betrifft: AW: UND bei derselben Zelle funktioniert ..... von: Reinhard
Geschrieben am: 17.08.2008 13:06:23

Hallo WF,

sorry, verstehe ich nicht kann ich grad nicht nachvollziehen, bei -6% sollte doch 0 % rauskommen!?

Tabellenblatt: [Mappe2]!Tabelle1
   |    C   |    D    |    E    |    F    |
---|--------|---------|---------|---------|
35 | -5,0 % | 100,0 % | 100,0 % | 100,0 % |
---|--------|---------|---------|---------|
36 | -5,1 % |   0,0 % |   0,0 % | 100,0 % |
---|--------|---------|---------|---------|
37 | -6,0 % |   0,0 % |   0,0 % | 100,0 % |
---|--------|---------|---------|---------|
38 |  0,0 % |   0,0 % |   0,0 % |   0,0 % |
---|--------|---------|---------|---------|
39 |  1,0 % |   0,0 % |   0,0 % |   0,0 % |
---|--------|---------|---------|---------|
40 | -3,0 % |  60,0 % |  60,0 % |  60,0 % |
------------------------------------------'
Benutzte Formeln:
D35:  =WENN(UND(C35>=-5;C35<0);C35/-5*100;0)
D36:  =WENN(UND(C36>=-5;C36<0);C36/-5*100;0)
D37:  =WENN(UND(C37>=-5;C37<0);C37/-5*100;0)
D38:  =WENN(UND(C38>=-5;C38<0);C38/-5*100;0)
D39:  =WENN(UND(C39>=-5;C39<0);C39/-5*100;0)
D40:  =WENN(UND(C40>=-5;C40<0);C40/-5*100;0)
E35:  =UND(C35>=-5;C35<0)*C35/-5*100
E36:  =UND(C36>=-5;C36<0)*C36/-5*100
E37:  =UND(C37>=-5;C37<0)*C37/-5*100
E38:  =UND(C38>=-5;C38<0)*C38/-5*100
E39:  =UND(C39>=-5;C39<0)*C39/-5*100
E40:  =UND(C40>=-5;C40<0)*C40/-5*100
F35:  =MIN(100;-C35*20*(C35<0))
F36:  =MIN(100;-C36*20*(C36<0))
F37:  =MIN(100;-C37*20*(C37<0))
F38:  =MIN(100;-C38*20*(C38<0))
F39:  =MIN(100;-C39*20*(C39<0))
F40:  =MIN(100;-C40*20*(C40<0))

C35:F40
haben das Zahlenformat: 0,0 "%"


Gruß
Reinhard


  

Betrifft: black out - vergiß den Blödsinn, den von: WF
Geschrieben am: 17.08.2008 13:11:30

ich da verzapft habe.
Deine Formel ist absolut OK.

Gruß WF


  

Betrifft: =MIN(100;-C35*20*(C35<0)) von: WF
Geschrieben am: 17.08.2008 12:39:41

.


  

Betrifft: AW: =MIN(100;-C35*20*(C35<0)) von: Peter Knierim
Geschrieben am: 17.08.2008 13:19:41

Hallo
erstmal Danke für die hilfe
habe hier mal eine Dateiauzug hoch geladen
https://www.herber.de/bbs/user/54665.xls

Der Wert in A32 ist der veränderbare
A23 =110 dann -5% =100%
A23 =100 dann -6% = 100% und nicht 120%

Gruß peter


  

Betrifft: AW: =MIN(100;-C35*20*(C35<0)) von: Reinhard
Geschrieben am: 17.08.2008 14:31:38

Hallo Peter,

bevor ich meine umstricke, hatte da was falsch gelesen, nimm doch die Formel von WF.

Gruß
Reinhard


  

Betrifft: AW: =MIN(100;-C35*20*(C35<0)) von: Peter Knierim
Geschrieben am: 17.08.2008 14:36:17

Hallo
die Formel klappt
ich hatte ein Formatierungsfehler mit den Prozentformaten

Jetzt klappt das

vielen Dank

bis zum nächsten Problem

Gruß Peter


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn Funktion"