Microsoft Excel

Herbers Excel/VBA-Archiv

Summen von zusammengehörenden Zeilen


Betrifft: Summen von zusammengehörenden Zeilen von: Heiko
Geschrieben am: 19.09.2019 15:18:14

Hallo zusammen,

ich stehe etwas auf dem Schlauch was mein Problem angeht.

Zur Beschreibung:

In Spalte A befinden sich die Ebenen mehrerer Stücklisten, Ebene 0 ist immer das Endprodukt
In Spalte B befinden sich die Zeiten zu dem Produkt der jeweiligen Stücklistenebene
In Spalte C möchte ich jeweils immer bei 0 in Spalte A die Summe der Produktzeiten des jeweiligen Artikels berechnen

Ich habe das ganze an einer Beispieldatei verdeutlicht wobei hier die Summe der Einzelzeiten in C manuell berechnet ist. Kann man diese Aufgabe automatisieren bzw. mit einer Formel abbilden? Denke mal aber das es auf VBA hinausläuft.

Bin für jede Hilfe dankbar.

Gruß, Heiko

https://www.herber.de/bbs/user/132121.xlsx

  

Betrifft: Teilsummen von: 1713939.html
Geschrieben am: 19.09.2019 15:46:06

Hi,

in C2 folgende Formel:
=WENN(A2=0;SUMME(B2:B$99)-WENNFEHLER(SUMME(INDEX(B3:B$99;VERGLEICH(0;A3:A$99;0)):B$99);0);"")
runterkopieren

WF

  

Betrifft: AW: Teilsummen von: 1713942.html
Geschrieben am: 19.09.2019 15:56:12

Funktioniert perfekt!

Vielen Dank für die schnelle Hilfe

Beiträge aus dem Excel-Forum zum Thema "Summen von zusammengehörenden Zeilen"