Microsoft Excel

Excel und VBA: Beitrag aus Herbers Excel-Forumsarchiv

Zeichen ersetzen

Betrifft: Zeichen ersetzen
von: Ulli Sopart
Geschrieben am: 29.03.2003 - 21:51:05

Wie kann ich die unterschiedlichen Formen der Telefon-Nummern, die so wie angegeben untereinander und vielfach in einer Spalte stehen dazu bringen, dass sie alle letztlich das Format wie folgt haben 0261123456
Die Rohdaten sehen z.B. so aus:
+49261123456
0049261123456
49261123456
0261123456 (muss natürlich dann bleiben).

Danke voraus für eine schnelle Hilfe (ggfls. per E-Mail an mich, wenn möglich)

Gruss - Ulli Sopart

  

Re: Zeichen ersetzen
von: Ramses
Geschrieben am: 29.03.2003 - 22:00:54

Hallo,

Spalte markieren
Format - Zellen >> Register Zahlen >>> Benutzerdefiniert
13x die 0 eingeben

0000000000000

Das +Zeichen vor der Telefonnummer musst du mit
Bearbeiten - Ersetzen >> "+" gegen "00"
ersetzen.

Gruss Rainer

  

Re: Zeichen ersetzen
von: Boris
Geschrieben am: 29.03.2003 - 22:05:48

Hi Ulli,

wenn die einzige Auslandsvorwahl die von Deutschland ist (49), dann reicht:


MS Excel von Boris an Ulli Sopart
 AB
1+492611234560261123456
200492611234560261123456
3492611234560261123456
402611234560261123456


Formel in B1 und runterkopiert:
=WENN(ISTFEHLER(FINDEN("49";A1));A1;"0"&TEIL(A1;FINDEN("49";A1)+2;99))

Wenn´s noch andere Varianten geben sollte, dann melde dich nochmal.

Gruß Boris

  

Meine Lösung ist schlecht, wenn...
von: Boris
Geschrieben am: 29.03.2003 - 22:10:59

...in der normalen Telefonnummer die 49 vorkommt.

Ich warte jetzt erstmal deine Reaktion ab, ob nur Deutschland als Vorwahl vorkommen kann (oder auch andere Länder). Dann bastel ich weiter.

Gruß Boris

  

Re: noch eine Lösung
von: M@x
Geschrieben am: 29.03.2003 - 22:13:06

Hi Ulli,
sollte alle erwähnten Fälle abdecken:
'=WECHSELN(WECHSELN(WECHSELN(A2;"+";"");"00";"");"49";"0")

Gruss

M@x

  

Re: auweh, mir gehts genauso wie Boris
von: M@x
Geschrieben am: 29.03.2003 - 22:16:40

Hi,
die "49" mitten in der Zahl drf man nicht ausschließen
muß ich mir was anders überlegen

Gruss

M@x

  

Nicht nur die 49;-))...
von: Boris
Geschrieben am: 29.03.2003 - 22:20:22

Hi Max,

es soll auch Telefonnummern geben wie 08945009877,
also mit ner "00" drin...(nicht nur "49")

Daher hatte ich schon die Wechseln-Variante ausgeschlossen.

Gruß Boris

  

Mach jetzt Feierabend...
von: Boris
Geschrieben am: 29.03.2003 - 22:49:25

Hi,

daher noch eine Lösung (die sicherlich noch zu verkürzen ist, doch da hab ich jetzt keine Lust mehr zu):


MS Excel von Boris an Boris
 AB
1+492611234560261123456
200492611234560261123456
3492611234560261123456
402611234560261123456
5+432611234560261123456
60039261123495602611234956
7+3926121002365026121002365


Formel in B1 und runterkopiert:
=WENN(LINKS(A1;1)="+";"0"&TEIL(A1;4;99);WENN(LINKS(A1;2)="00";"0"&TEIL(A1;5;99);WENN(LINKS(A1;1)<>"0";"0"&TEIL(A1;3;99);A1)))

Gruß Boris

  

OFF TOPIC
von: L.Vira
Geschrieben am: 29.03.2003 - 22:51:22

Hi,
du bist doch so eine Art Outlook- Guru? Weißt du, wo die
Änderungen in den Outlook- Symbolleisten abgelegt werden?
Gruß L.Vira

  

Re: OFF TOPIC
von: Ramses
Geschrieben am: 29.03.2003 - 23:57:15

Hallo L.Vira,

Guru ist gut :-)
Ich weiss wie man Mail sendet und empfängt :-)

Die Symbolleisten werden gespeichert:

Outlook XP
C:\Dokumente und Einstellungen\Username\Anwendungsdaten\Microsoft\Office\MSOut10.PIP

Outlook 2000
C:\Dokumente und Einstellungen\Rainer\Anwendungsdaten\Microsoft\Office\MSOut.PIP

Für Versionen vorher gab es glaube ich mal eine
MSOutlo.PIP
im Programmordner C:\Programme\Microsoft Office\Office

Hope you feeling better :-))

Gruss Rainer

  

Re: OFF TOPIC
von: L.Vira
Geschrieben am: 30.03.2003 - 00:10:02

Eldructary better!
Wenn ich dich schon mal "gestellt" habe, gleich noch ne Frage.
Ich hab mich gestern erstmalig mit Outlook beschäftigt und in diesem Zusammenhang rund 3000 Namen, Vornamen und Geburtstage von Excel nach Outlook geschaufelt. Das hat, bei direktem Auslesen aus den Zellen, ca. 14 Minuten gedauert und bei vorherigem Einlesen in ein Datenfeld immer noch exakt 10 Minuten.
Ist das aus deiner Sicht normal?
Gruß L.Vira

  

Re: OFF TOPIC
von: Ramses
Geschrieben am: 30.03.2003 - 00:35:24

Hallo L.Vira,

die Interaktion ist schon etwas langsam und hängt stark von der Prozessor und RAM-Leistung ab. Aber 14 Minuten erscheint mir schon ein wenig lang.
Da hätte ich jetzt aus der Hand, bei einem 1.5 GHz Rechner, ca. 3 - 4 Minuten erwartet.
Wenn EXCEL und Outlook gestartet sind, gibt es für mich so eine Faustregel aus Erfahrungswerten zum lesen:
Ca 10 - 15 Adressen pro Sekunde, ... natürlich abhängig von der Anzahl der ausgefüllten Datenfelder. Die Faustregel gilt für einen normalen Adressdatensatz mit Telefonnummern usw.

Gruss Rainer


  

Re: OFF TOPIC
von: L.Vira
Geschrieben am: 30.03.2003 - 00:45:33

Hi,
2,4 GHz, 512 MB DDR RAM, daran sollte es wohl nicht liegen.
Ich hab jetzt aber gerade auch keinen anderen PC mit Office 2000
zum Testen. Na ja, ist auch nicht sooooo wichtig. Jedenfalls Dank für deine Anteilnahme.
Gruß L.Vira

  

Re: Meine Lösung ist schlecht, wenn...
von: Ulli Sopart
Geschrieben am: 30.03.2003 - 11:51:47

Erst mal vielen Dank für die superschnelle Hilfe.
Klappt schon mal hervorragend.
Leider ist es aber auch so, dass Auslandsvorwahlen dabei sind
(z.B. 0038... oder auch +38)
Die müssten dann mit 0038.. beginnend angezeigt werden. Kannst Du das noch in die Formel einbauen - wäre toll, dann glaube ich, dass ich alles hätte.

  

Re: Mach jetzt Feierabend...
von: Ulli Sopart
Geschrieben am: 30.03.2003 - 12:01:16

Hallo Boris,
danke für die schnelle Hilfe.
Allerdings funktioniert Deine letzte Variante (Zeile 7) bei mir
nicht. Die Auslandsvorwahl +3812345 wird bei mir umgewandelt in 012345.
Kannst Du mir noch mal helfen?
Wäre toll.
Vielen Dank

  

Re: Mach jetzt Feierabend...
von: Ulli Sopart
Geschrieben am: 30.03.2003 - 12:13:11

Hallo Boris,
ja, leider ist es so, dass auch Auslandsvorwahlen vorkommen, die natürlich erhalten bleiben müssen und bei denen die Anzeige dann wie folgt aussehen müsste: 003812345
Boris Hilf!!!!!!!!!!!!!!!

Danke vielmals

Gruss - Ulli

  

Re: Mach jetzt Feierabend...
von: Peter Haserodt
Geschrieben am: 30.03.2003 - 13:56:41

hi,
 AB
1+49645315406453154
2+3964531550396453155
301234560123456
400491234560123456
Formeln der Tabelle
B1 : =WENN(LINKS(A1;1)="+";WECHSELN(WECHSELN(A1;"+49";"0");"+";"0");WENN(LINKS(A1;4)="0049";WECHSELN(A1;"049";"");A1))
B2 : =WENN(LINKS(A2;1)="+";WECHSELN(WECHSELN(A2;"+49";"0");"+";"0");WENN(LINKS(A2;4)="0049";WECHSELN(A2;"049";"");A2))
B3 : =WENN(LINKS(A3;1)="+";WECHSELN(WECHSELN(A3;"+49";"0");"+";"0");WENN(LINKS(A3;4)="0049";WECHSELN(A3;"049";"");A3))
B4 : =WENN(LINKS(A4;1)="+";WECHSELN(WECHSELN(A4;"+49";"0");"+";"0");WENN(LINKS(A4;4)="0049";WECHSELN(A4;"049";"");A4))
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Gruss Peter

www.haserodt.de

  

Re: Mach jetzt Feierabend...
von: Ulli Sopart
Geschrieben am: 30.03.2003 - 14:07:50

Danke Janine für die Hilfe.
Aber mein vorerst letztes Problem ist damit noch nicht gelöst. Die beliebigen Auslandsvorwahlen (also alle außer 0049 oder + 49) sollen im Format beginnend mit 2 Nullen dargestellt werden (z.B. aus +39... wird 0039...).
Kannst ja noch mal drüberschauen, wenns nicht zu viel Mühe macht. Vielen Dank

Gruss
Ulli

  

etwas kürzer und fehler weg
von: Peter Haserodt
Geschrieben am: 30.03.2003 - 14:08:11

hi,
war bisserl umständlich und mit fehler:
 AB
1+49645315406453154
2+39645315500396453155
301234560123456
400491234560123456
Formeln der Tabelle
B1 : =WECHSELN(WECHSELN(WECHSELN(A1;"+49";"0");"+";"00");"0049";"0")
B2 : =WECHSELN(WECHSELN(WECHSELN(A2;"+49";"0");"+";"00");"0049";"0")
B3 : =WECHSELN(WECHSELN(WECHSELN(A3;"+49";"0");"+";"00");"0049";"0")
B4 : =WECHSELN(WECHSELN(WECHSELN(A4;"+49";"0");"+";"00");"0049";"0")
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Gruss Peter

  

Re: Mach jetzt Feierabend...
von: Boris
Geschrieben am: 31.03.2003 - 12:14:17

Hi Ulli,

das dürte jetzt alles befriedigen (bezogen auf A1):

=WENN(LINKS(A1;2)="49";RECHTS(A1;LÄNGE(A1)-2);WECHSELN(WECHSELN(WECHSELN(A1;"+49";"0");"0049";0);"+";"00"))

Gruß Boris

  

Jetzt aber endgültig:
von: Boris
Geschrieben am: 31.03.2003 - 12:29:09

Hi Ulli,

wieder auf A1 bezogen (jetzt sollte wirklich alles stimmen):

=WENN(LINKS(A1;2)="49";"0"&RECHTS(A1;LÄNGE(A1)-2);WENN(UND(LINKS(A1;1)<>"+";LINKS(A1;1)<>"0");"00"&A1;WECHSELN(WECHSELN(WECHSELN(A1;"+49";"0");"0049";0);"+";"00")))

Gruß Boris

  

Re: Jetzt aber endgültig:
von: Ulrich Sopart
Geschrieben am: 31.03.2003 - 22:16:21

Vielen Dank - das war wirklich super!!