Microsoft Excel

Herbers Excel/VBA-Archiv

Problem mit Sortierung von Text/Zahl gemischt


Betrifft: Problem mit Sortierung von Text/Zahl gemischt
von: Chris
Geschrieben am: 08.11.2018 16:00:50

Hallo Profis,

ich versuche vergeblich meine ausgewerteten Daten zu sortieren - anhand der bekannten Formel für Text/Zahlen gemischt.
http://www.excelformeln.de/formeln.html?welcher=236

Mein Problem ist nur, dass aufgrund dieser Formel meine Zahlen zu Text werden und ich dies aufgrund der Mischung von Zahlen/Texten nicht mit "*1" oder "=Wert" beheben kann, da sonst die Textpositionen eine Fehlermeldung erzeugen.

Eine Beispiel-Datei findet Ihr hier:
http://www.herber.de/bbs/user/125267.xlsx

Hat jemand eine Lösung für diese Problematik?

Danke im Voraus!

Gruß,
Chris

  

Betrifft: entweder mit Hilfsspalte oder mit WENNFEHLER
von: WF
Geschrieben am: 08.11.2018 17:30:23

Hi,

eine Hilfsspaltenlösung steht doch in dem link.

Ansonsten Deine jetzige Lösung mit WENNFEHLER drumrum:
=WENNFEHLER(Formel*1;Formel)

WF


  

Betrifft: AW: entweder mit Hilfsspalte oder mit WENNFEHLER
von: Günther
Geschrieben am: 08.11.2018 18:15:47

Hmmm,
wenn ich die Basisdaten in Power Query importiere und sortiere habe ich sofort das Ergebnis aus Spalte_B, ohne Formeln und so ...


  

Betrifft: AW: entweder mit Hilfsspalte oder mit WENNFEHLER
von: Günther
Geschrieben am: 08.11.2018 18:17:06

Hmmm,
wenn ich die Basisdaten in Power Query importiere und sortiere habe ich sofort das Ergebnis aus Spalte_B, ohne Formeln und so ... Und natürlich als Zahl und Text. ;-)


  

Betrifft: AW: Sortierung von Text/Zahl gemischt
von: Josef B
Geschrieben am: 08.11.2018 21:50:10

Hallo Chris

Meinst du so?

Tabelle1

 AB
1DatenSortierung
2201'710
3201'711201'711
4201'710201'713
5201'714201'714
6201'713201'804
7201711A201'805
8201'804201711A
9201804A201804A
10201'805201805A
11201805A201879A
12201879A 

Formeln der Tabelle
ZelleFormel
B2=WENNFEHLER(VERWEIS(2;1/(AGGREGAT(14;6;ZÄHLENWENN((A$3:A$99); ">="&A$3:A$99)+99*ISTZAHL(A$3:A$20); ZEILE(A1))/(A$3:A$99<>"")=ZÄHLENWENN(A$3:A$99;">="&A$3:A$99)+99*ISTZAHL(A$3:A$20)); A$3:A$99); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Gruss Sepp


  

Betrifft: AW: Sortierung von Text/Zahl gemischt
von: Chris
Geschrieben am: 09.11.2018 07:42:21

Hallo zusammen,

danke für eure Hilfe, ich stand da wirklich extrem auf den Schlauch diesbzgl...
Natürlich geht ein simples WENNFEHLER, aber auch die Lösung von Sepp funktioniert einwandfrei.

@Günther, danke auch für deinen Vorschlag, leider ist das bei mir keine Option :-)

Gruß,
Chris