Microsoft Excel

Herbers Excel/VBA-Archiv

ABC Analyse plus Tortengrafik

Betrifft: ABC Analyse plus Tortengrafik
von: Franco
Geschrieben am: 01.12.2013 17:18:31

Guten Abend Forumsgemeinde,

Ich habe zwei Probleme.....

1. ich muß eine Variabele ABC Analyse erstellen ohne die ( kum ) Werte vorher sortieren zu können. Feld für die Berechnung ist 85 % = A; 15 % = B Rest = C.
Dachte es geht mit einem Sverweis..... gibt aber nur "c" wieder ( SVERWEIS(K5;$O$5:$P$7;2))

das 2. Problem liegt darin das Ganze in eine "Tortengrafik" abschließend zu verwandeln.....

Kann mir da bitte jemand helfen ?

Vielen Dank Franco

  

Betrifft: AW: ABC Analyse plus Tortengrafik
von: Franco
Geschrieben am: 01.12.2013 18:13:36

Die Formel von mir ergibt auf jeden fall falsche Werte zurück....

hier die von mir probierte Formel:

SVERWEIS(J5;$O$5:$P$7;2)

wobei in o und p die Werte und prozentzahlen stehen...

Danke im vorraus


  

Betrifft: Ungetestet: =SVERWEIS(J5;$O$5:$P$7;2;0)
von: Matthias L
Geschrieben am: 01.12.2013 18:20:40

Hallo

Probiers mal mit dem 4.Parameter 0

Gruß Matthias


  

Betrifft: AW: Ungetestet: =SVERWEIS(J5;$O$5:$P$7;2;0)
von: Franco
Geschrieben am: 01.12.2013 18:31:57

Hallo Matthias,

hmm das gibt "Wert" zurück.....eigentlich erscheint mir die Formel generell unsinnig,
denn es sollte doch erkannt werden wann der Wert die richtige Prozentzahl
beträgt _ gerechnet an der Gesamtsumme.....

ich habe eine Denkblockade......


  

Betrifft: kann sein ...
von: Matthias L
Geschrieben am: 01.12.2013 18:38:09

Hallo

Zitat

eigentlich erscheint mir die Formel generell unsinnig,
Das ist durchaus möglich. Liegt aber sicher nicht am 4.Parameter
Ohne Bsp. kann ja niemand wissen was Du wirklich zurückgeben willst

Gruß Matthias


  

Betrifft: AW: kann sein ...
von: Franco
Geschrieben am: 01.12.2013 18:45:04

Hallo Matthias,

ich versuche mal die Zeilen darzustellen:

Zusammenfassung
kum Auswertung Definition
WKZ allgemein 117.861,40 € 17,127% 17,127% #WERT! 0% A
mech. WKZ 55.654,60 € 8,088% 25,215% #WERT! 15% B
SIGA 23.825,78 € 3,462% 28,677% A 85% C
hydr. WKZ 128.981,67 € 18,743% 47,421% B
hydr. Pumpen 143.897,00 € 20,911% 68,332% B
Set WKZ 100.873,48 € 14,659% 82,990% A
AKKU WKZ 24.104,35 € 3,503% 86,493% A
EINSÄTZE 92.946,88 € 13,507% 100,000% A
Gesamt 688.145,16 €


  

Betrifft: das nützt aber so nichts ...
von: Matthias L
Geschrieben am: 01.12.2013 18:58:05

Hallo

Zitat

ich versuche mal die Zeilen darzustellen:
Das mag ja gut gemeint sein, aber es kann ja niemand wissen was wo (also in wlechen Zellen) steht.

Gruß Mastthias


  

Betrifft: AW: das nützt aber so nichts ...
von: Franco
Geschrieben am: 01.12.2013 19:14:45

Hallo Matthias,

leider weiß ich nicht wie man die Tabelle hier reinkopiert.....

aber simpel erklärt:

a1 Produkt und b1 kumulierter Wert
a2 Produkt............

in den Zellen o und P stehen die % Angaben und der Wert der zurückgeschrieben werden soll.....

Gruß & Haare raufend

Franco


  

Betrifft: ABC Analyse HILFE
von: Franco
Geschrieben am: 01.12.2013 19:35:04

Liebe Mitlesende -

hat sonst noch jemand eine Idee ??

*seufz*


  

Betrifft: Hinweis ...
von: Matthias L
Geschrieben am: 01.12.2013 19:43:57

Hallo Franco

Im Antwortformular befindet sich oben rechts ein Button
"Zum File-Upload"
Da kannst Du Deine Datei hier hochladen.

Markiere bitte in der Datei die Zelle in der Du die Formel benötigst
und was Du, warum als Ergebnis erwartest

Das Du jetzt nach weiterer Hlfe "rufst"
hat sonst noch jemand eine Idee ??
finde ich nicht gerade Lösungsproduktiv

Ich werde mich dann ab jetzt raushalten,
da ich Dir anscheinend nicht schnell genug bin.
Viel Erfolg ...

Gruß Matthias


  

Betrifft: AW: Hinweis ...AB C Analyse
von: Franco
Geschrieben am: 01.12.2013 21:11:00

Oh je - isorry ich wollte dich nicht brüskieren - stehe nur unter Zeitdruck....

hier der upload..

http://www.herber.de/bbs/user/88334.xlsx


würde mich freuen wen Du das hinbekommst....


  

Betrifft: Hilfe: ABC Analyse
von: Franco
Geschrieben am: 02.12.2013 08:14:07

Liebe Forumsleser....

ich bin immer noch nicht wirklich weiter....

Weiß noch jemand einen Rat ?

Lieben Gruß

Franco


  

Betrifft: AW: Hilfe: ABC Analyse
von: Bastian
Geschrieben am: 02.12.2013 09:11:05

Hallo,

versuchs mal so:
Aus "Wert A", "Wert B", "Wert C" kannst Du dann Dein Tortendiagramm erstellen.

Gruß, Bastian

 HIJKLMNOPQRS
3Zusammenfassung           
4   RangkumAuswertungDefinition Wert AWert BWert C
5WKZ  allgemein117.861,40 €17,127%356,782%A0%A 584.560,44 €55.654,60 €47.930,12 €
6mech. WKZ55.654,60 €8,088%693,035%B85%B    
7SIGA23.825,78 €3,462%8100,000%C10%C    
8hydr. WKZ128.981,67 €18,743%239,654%A      
9hydr. Pumpen143.897,00 €20,911%120,911%A      
10Set WKZ100.873,48 €14,659%471,440%A      
11AKKU WKZ24.104,35 €3,503%796,538%C      
12EINSÄTZE92.946,88 €13,507%584,947%A      
13Gesamt688.145,16 €          

Formeln der Tabelle
ZelleFormel
H5=C3
I5=F21
J5=I5/$I$13
K5=RANG.GLEICH(J5;$J$5:$J$12;0)
L5=WENNFEHLER(J5+INDEX($L$5:$L$12;VERGLEICH(K5-1;$K$5:$K$12;0)); J5)
M5=WENN(L5<$N$6;"A";WENN(L5<($N$6+$N$7); "B";"C"))
Q5=SUMMEWENN($M$5:$M$12;O5;$I$5:$I$12)
R5=SUMMEWENN($M$5:$M$12;O6;$I$5:$I$12)
S5=SUMMEWENN($M$5:$M$12;O7;$I$5:$I$12)
H6=C23
I6=F25
J6=I6/$I$13
K6=RANG.GLEICH(J6;$J$5:$J$12;0)
L6=WENNFEHLER(J6+INDEX($L$5:$L$12;VERGLEICH(K6-1;$K$5:$K$12;0)); J6)
M6=WENN(L6<$N$6;"A";WENN(L6<($N$6+$N$7); "B";"C"))
H7=C27
I7=F28
J7=I7/$I$13
K7=RANG.GLEICH(J7;$J$5:$J$12;0)
L7=WENNFEHLER(J7+INDEX($L$5:$L$12;VERGLEICH(K7-1;$K$5:$K$12;0)); J7)
M7=WENN(L7<$N$6;"A";WENN(L7<($N$6+$N$7); "B";"C"))
H8=C30
I8=F34
J8=I8/$I$13
K8=RANG.GLEICH(J8;$J$5:$J$12;0)
L8=WENNFEHLER(J8+INDEX($L$5:$L$12;VERGLEICH(K8-1;$K$5:$K$12;0)); J8)
M8=WENN(L8<$N$6;"A";WENN(L8<($N$6+$N$7); "B";"C"))
H9=C36
I9=F38
J9=I9/$I$13
K9=RANG.GLEICH(J9;$J$5:$J$12;0)
L9=WENNFEHLER(J9+INDEX($L$5:$L$12;VERGLEICH(K9-1;$K$5:$K$12;0)); J9)
M9=WENN(L9<$N$6;"A";WENN(L9<($N$6+$N$7); "B";"C"))
H10=C40
I10=F42
J10=I10/$I$13
K10=RANG.GLEICH(J10;$J$5:$J$12;0)
L10=WENNFEHLER(J10+INDEX($L$5:$L$12;VERGLEICH(K10-1;$K$5:$K$12;0)); J10)
M10=WENN(L10<$N$6;"A";WENN(L10<($N$6+$N$7); "B";"C"))
H11=C44
I11=F46
J11=I11/$I$13
K11=RANG.GLEICH(J11;$J$5:$J$12;0)
L11=WENNFEHLER(J11+INDEX($L$5:$L$12;VERGLEICH(K11-1;$K$5:$K$12;0)); J11)
M11=WENN(L11<$N$6;"A";WENN(L11<($N$6+$N$7); "B";"C"))
H12=C48
I12=F58
J12=I12/$I$13
K12=RANG.GLEICH(J12;$J$5:$J$12;0)
L12=WENNFEHLER(J12+INDEX($L$5:$L$12;VERGLEICH(K12-1;$K$5:$K$12;0)); J12)
M12=WENN(L12<$N$6;"A";WENN(L12<($N$6+$N$7); "B";"C"))
I13=SUMME(I5:I12)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: Hilfe: ABC Analyse
von: Franco
Geschrieben am: 02.12.2013 12:38:14

Hallo Bastion,

danke für die Idee - aber kann man das nicht einfacher lösen ?
Das Problem was ich sehe ist der "Schwellenbereich..." also von z.B10,1 - 84,999 %

Kannst du mir da helfen ?

Gruß Franco


  

Betrifft: AW: Hilfe: ABC Analyse
von: Bastian
Geschrieben am: 02.12.2013 14:32:42

Hallo Franco,
das Problem ist, die Prozentwerte richtig zu kumulieren, wenn die Liste vorher nicht sortiert werden darf (wie von Dir vorgegeben). Daher die etwas längere Formel in Spalte L und die Hilfsspalte mit dem Rang. So, wie Du in Deiner hochgeladenen Datei kumuliert hast, war es auf jeden Fall falsch. Die gepostete Lösung funktioniert, aber da Du eine einfachere Lösung suchst lasse ich den Thread offen.

Gruß, Bastian


  

Betrifft: AW: Hilfe: ABC Analyse
von: Franco
Geschrieben am: 02.12.2013 15:06:36

Hallo Bastian -
vielen lieben Dank - ich geb´die Hoffnung nicht auf - ABC Analysen sind echt
grenzwertig.....

Gruß aus dem Rheinland

Franco