Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt, INDEX, Vergleich


Betrifft: Summenprodukt, INDEX, Vergleich
von: xcalimerox
Geschrieben am: 05.12.2018 14:14:09

Hallo zusammen,
ich bin leicht am verzweifeln. Google habe ich nun schon seit mehreren Stunden durchsucht und vieles ausprobiert, leider ohne Erfolg.

Ich habe 2 Tabellenblätter

Auf dem ersten möchte ich einen Wert auswerfen mit Daten aus dem zweiten.
Meine Suchoptionen sind einmal ein Text aus einer festen Zelle und einer Zahl in 1:1 welche sich auf dem zweiten Tabellenblatt auch in 1:1 befindet.

Wie kann ich die Summe ziehen wenn diese beiden Kreterien auf dem zweiten Tabellenblatt erfüllt werden?

Besten Dank im Vorfeld

  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: SF
Geschrieben am: 05.12.2018 14:15:46

Hola,

mit einer Formel.
Mehr ist auf Grund deiner "Beschreibung" nicht drin.

Gruß,
steve1da


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: xcalimerox
Geschrieben am: 05.12.2018 14:36:48




So leichter nachzuvollziehen?

Ich will den Umsatz in GUV ausgegeben haben. Verglichen soll dabei jeweils die Zahl in der oberen Spalte und das Wort Provision.


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: SF
Geschrieben am: 05.12.2018 14:39:21

Hola,

http://excelformeln.de/formeln.html?welcher=39

Gruß,
steve1da


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: xcalimerox
Geschrieben am: 05.12.2018 14:47:00

Danke,
hilft schonmal.

Aus F soll noch die Summe gezogen werden wenn in B das Wort mehrmals vorkommt.

Beste Grüße


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: SF
Geschrieben am: 05.12.2018 14:51:19

Hola,

Summewenn(), Summewenns() vielleicht?

Gruß,
steve1da


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: xcalimerox
Geschrieben am: 05.12.2018 14:57:51

Wenn ich es wüsste, wäre ich nicht hier.
Hab schon alles mögliche ausprobiert, nichts führte zu einem Ergebnis.


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: SF
Geschrieben am: 05.12.2018 14:58:56

Hola,

nochmal, deine Beschreibung und Bildchen helfen nur bedingt. Du hast z.B. in beiden Bildchen eine Spalte F mit Werten. Nur du weißt, was du wo errechnet haben möchtest.
Eine ExcelDatei wäre hilfreich.

Gruß,
steve1da


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: Luschi
Geschrieben am: 05.12.2018 15:52:35

Hallo xcalimerox,

bin mal gespannt, wie lange Du noch so rumeiern willst, anstatt eine Demodatei bereitzustellen,
an der man sich abarbeiten kann. Ich habe es mir schon lange abgewöhnt, diesen Part auch noch zu übernehmen, obwohl meine Schatzkiste mit Lösungsvorschlägen schon überläuft.

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: xcalimerox
Geschrieben am: 05.12.2018 16:06:04

Hi!
Anbei die Datei.
Die Formel funktioniert aktuell.
Ich möchte lediglich, dass das Suchparameter auf beiden Sheets um den Wert aus Zeile 1 erweitert wird umso dynamischer zu sein.
Oder gerne auch einen besseren Lösungsansatz.

BG


http://www.herber.de/bbs/user/125917.xlsx


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: UweD
Geschrieben am: 05.12.2018 16:44:47

Hallo

so...

GUV Plan 2019

 CDEFG
2GUV Plan    
32019Jan 19Feb 19Mrz 192019
4in EuroPlanPlanPlanGESAMT
5     
6Umsatzerlöse5700010 57.001
7Provisionen 5.000 10 5.001
8Hardware520000052000
9Erlösschmälerung0000
10Bestandsveränderungen 1.000 00 1.000
11 Bestvä. unfertige Erzeugnisse (+/-) 1.000    1.000

verwendete Formeln
Zelle Formel Bereich N/A
D6:F6=D7+D8-D9  
D7:F9=SUMMENPRODUKT((Umsatzplanung!$B$4:$B$45=$C7)*(Umsatzplanung!$D$1:$L$1=D$1)*(Umsatzplanung!$D$4:$L$45))  
D10:F10=D11+D12+D13  
G6:G11=SUMMENPRODUKT(D6:F6)  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




Wichtig!!!
In Spalte C vor Provisionen hast du Leerzeichen.
mach die weg und dafür 1x Tabulator drücken.


LG UweD


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: xcalimerox
Geschrieben am: 05.12.2018 17:03:52

Besten Dank Uwe!
Solch einen Ansatz hatte ich auch heute schon, leider irgendwie ohne Erfolg.
Am Ende war ich schon bei Index, Vergleich etc...

DANKE! Es läuft.


  

Betrifft: AW: Summenprodukt, INDEX, Vergleich
von: xcalimerox
Geschrieben am: 05.12.2018 15:03:52

Ja, dass stimmt wohl.
Die Spalte, wo aktuell die NULLEN drin stehen sollen in dem anderen Tabellenblatt summiert werden.

BG