VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Zuschlagszeit aus einer Gesamtzeit filtern

Gruppe

DatumZeit

Bereich

Arbeitszeit

Thema

Zuschlagszeit aus einer Gesamtzeit filtern

Problem

Wie kann ich aus einer durch Start- und Endzeit definierten Gesamtzeit eine zuschlagspflichtige Zeit filtern?

Lösung

Folgende Formel: =WENN(B2>D2;D2+1;B2+1)-WENN(A2<C2;C2;A2)




StandardModule: basMain

Function Zuschlag(dValue As Double) As Double
   Dim dAct As Double
   Dim iValue As Integer
   dAct = dValue Mod 500000
   Select Case dAct
      Case Is < 10000: iValue = 20
      Case Is < 25000: iValue = 40
      Case Is < 50000: iValue = 80
      Case Is < 150000: iValue = 165
      Case Is < 300000: iValue = 315
      Case Is < 500000: iValue = 540
   End Select
   iValue = iValue + _
      ((dValue - (dValue Mod 500000)) / 500000) * 300
   Zuschlag = iValue
End Function

    


Beiträge aus dem Excel-Forum zu den Themen DatumZeit und Arbeitszeit