Microsoft Excel

Herbers Excel/VBA-Archiv

Problem bei Arbeitszeitplanung

Betrifft: Problem bei Arbeitszeitplanung von: Thomas
Geschrieben am: 26.09.2006 09:33:49

Hallo,

ich habe ein Problem bei meiner Arbeitszeitplanung. Eine detaillierte Problembeschreibung befindet sich in der hochgeladenen Excel-Arbeitsmappe:

https://www.herber.de/bbs/user/37015.xls

Vielleicht macht sich jemand die Mühe, und sieht sich das mal an!

Vielen Dank,

Thomas

  


Betrifft: AW: Problem bei Arbeitszeitplanung von: christian
Geschrieben am: 26.09.2006 10:25:09

Hallo thomas
versuch mal das makro in deine testdatei (ev. button "aktulaisieren" anlegen)

Sub aktualisieren()
    Range("H3:H13").Select
    Selection.ClearContents
For i = 3 To 13
    For j = 3 To 13
        If Cells(i, 6) = Cells(j, 1) Then
        Cells(i, 8) = Cells(j, 3)
        End If
    Next j
Next i
End Sub


jedes mal, wenn du dann den button drückst
aktualisiert das makro die Restzeit.

Dann noch Summenformel in deine Summenzelle eingeben.
Fertig
lg
Christian
PS: natürlich kannst du die variablen anpassen wenn du z.B. mehrere Zeilen hast.


  


Betrifft: AW: Problem bei Arbeitszeitplanung von: HermannZ
Geschrieben am: 26.09.2006 10:25:23

Hallo Thomas;

für die Zelle H3 folgende Formel;

{=WENN(SUMME(($A$3:$A$13=F3)*($D$3:$D$13))>0;0;WENN(SUMME(($A$3:$A$13=E3)*($D$3:$D$13))=0;INDEX($C$3:$C$13;MAX(WENN($A$3:$A$13=F3;ZEILE($1:$11)));1)))}


ich Denke das mit der gesamtsumme bekommst du selber hin oder?
sonst musst du dich noch mal melden.

Gruss Hermann


  


Betrifft: AW: Problem bei Arbeitszeitplanung von: Thomas
Geschrieben am: 26.09.2006 12:40:56

Vielen Dank für die schnelle Hilfe, funktioniert schon!


 

Beiträge aus den Excel-Beispielen zum Thema "Problem bei Arbeitszeitplanung"