Microsoft Excel

Herbers Excel/VBA-Archiv

Nachtstunden Arbeitszeitrechnung

Betrifft: Nachtstunden Arbeitszeitrechnung von: kasch
Geschrieben am: 08.11.2007 12:08:32

Hallo,
habe ein Problem mit der Berechnung der Nachtstunden, da an einem Tag aufgrund Bereitschaftszeiten zwei Arbeitsmöglichkeiten vorkommen können :

D1 = Kommen1 z.B. 04.00 Uhr
E1 = Gehen 1 z.B. 06.00 Uhr
F1 = Kommen 2 z.B. 14.00 Uhr
G1 = Gehen 2 z.B. 23.00 Uhr

I1 = Gesamt 9.00 Std.
J1 = Nacht 4.00 Std. ( Nachtzeit vom 21.00 - 6.00 Uhr)

(Tag wird jeweils von 0.00 - 23.99 Uhr eingegeben, also bei Arbeit über Mitternacht Arbeitszeit bis 00.00 in Zeile 1 und nach 00.00 in Zeile 2)

Wer kann mir hier helfen?? Schon jetzt danke !!!

  

Betrifft: Wo ist denn das Problem? owT von: Peter
Geschrieben am: 08.11.2007 12:43:39

Gruß, Peter


  

Betrifft: AW: Wo ist denn das Problem? owT von: kasch
Geschrieben am: 08.11.2007 13:02:18

Das Problem ist, daß ich die Formel für die Berechnung in der Spalte J1 nicht hinbekomme. In meiner Angabe steht nur, was nach Berechnung drinstehen soll.


  

Betrifft: AW: Wo ist denn das Problem? owT von: Peter
Geschrieben am: 08.11.2007 13:09:19

Hallo kasch,

ich habe noch eine Frage: müsste bei der Gesamtzahl der Stunden nicht "11" rauskommen?

Gruß, Peter


  

Betrifft: AW: Wo ist denn das Problem? owT von: Peter
Geschrieben am: 08.11.2007 13:12:14

Hallo kasch,

schau Dir doch mal diese Beispielmappe an. Ist das die Formel, die Du suchst?
https://www.herber.de/bbs/user/47511.xls

Gruß, Peter


  

Betrifft: Fehler in Beispieldatei von: Peter
Geschrieben am: 08.11.2007 13:14:58

Sorry, die Formel in J1 muß heissen:
=MAX(0;G1-F4)+MAX(0;F5-D1)
Ich habe in der Beispielmappe "0;" bei der zweiten MAX-Bedingung vergessen.

Gruß, Peter


  

Betrifft: AW: Fehler in Beispieldatei von: kasch
Geschrieben am: 08.11.2007 14:21:52

Erstmal danke, Formel würde funktionieren, aber es gibt noch folgendes Problem:

mögliche Arbeitszeit von 1:00 - 2:00 Uhr und dann wieder von 4:00 - 15:00 Uhr,
bei dieser Konstellation funktioniert die Formel nicht.

Natürlich sind es beim Erstbeispiel 11 Stunden gesamt, habe mich verrechnet ( eile mit Weile...)

Gruß
Kasch


  

Betrifft: AW: Fehler in Beispieldatei von: Peter
Geschrieben am: 08.11.2007 14:31:58

Hallo kasch,

ja, wann arbeitet ihr denn da immer?
Ich arbeite daran...

Gruß, Peter


  

Betrifft: AW: Fehler in Beispieldatei von: Peter
Geschrieben am: 08.11.2007 14:40:29

Hallo kasch,

ich habe die Beispieldatei modifiziert, jetzt müsste es laufen.
https://www.herber.de/bbs/user/47515.xls


Gruß, Peter


  

Betrifft: @ Peter von: Erich G.
Geschrieben am: 08.11.2007 15:26:39

Hi Peter,
nun bist du genau bei der Formel ausgekommen, die auch in meinem Beitrag
bzw. bei http://www.excelformeln.de/formeln.html?welcher=9 zu finden ist.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: @ Peter von: Kasch
Geschrieben am: 08.11.2007 17:30:44

Hallo,



Formel funktioniert prima, hätte allerdings noch einen Wunsch und einen Hilfe-Tip:

Wunsch: wenn an einem Tag keine Arbeitszeit eingetragen wird, sollte Feld leer bleiben und keine 0:00- Stunden anzeigen


Hilfe-Tip: Wenn ich die markierte Zelle nach unten fortführe, ändert sich auch der Bezug zu den
Nachtzeiten und damit ergibt sich ja eine falsche Berechnung. Wie kann ich die Formel in die
anderen Zellen übertragen, ohne daß ich diese für jeden Tag manuell anpassen muss?


Ich bin begeistert über eure schnellen Antworten und Hilfen !!!!!!!!!!!!


  

Betrifft: AW: @ Peter von: Erich G.
Geschrieben am: 09.11.2007 13:07:30

Hallo Kasch (???),
vielleicht so?
(Das mit den Dollarzeichen hatte ich schon gepostet - siehe 08.11.2007 13:30:26...)

 ABCDEF
121:0006:00  
204:0006:0014:0023:1511:1504:15
301:0009:00  08:0005:00
4  14:0023:1509:1502:15
5      

Formeln der Tabelle
ZelleFormel
E4=WENN(A4+B4+C4+D4=0;"";B4-A4+D4-C4)
F4=WENN(A4+B4+C4+D4=0;"";MAX(;1-MAX($A$1;A4)+MAX(;$B$1-A4) +MIN($B$1;B4)+(B4>$A$1)*(B4-$A$1)-(A4<B4)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B4+(A4>B4)-A4))*($A$1<>$B$1)*(A4<>B4) + MAX(;1-MAX($A$1;C4)+MAX(;$B$1-C4) +MIN($B$1;D4)+(D4>$A$1)*(D4-$A$1)-(C4<D4)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D4+(C4>D4)-C4))*($A$1<>$B$1)*(C4<>D4))
E5=WENN(A5+B5+C5+D5=0;"";B5-A5+D5-C5)
F5=WENN(A5+B5+C5+D5=0;"";MAX(;1-MAX($A$1;A5)+MAX(;$B$1-A5) +MIN($B$1;B5)+(B5>$A$1)*(B5-$A$1)-(A5<B5)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B5+(A5>B5)-A5))*($A$1<>$B$1)*(A5<>B5) + MAX(;1-MAX($A$1;C5)+MAX(;$B$1-C5) +MIN($B$1;D5)+(D5>$A$1)*(D5-$A$1)-(C5<D5)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D5+(C5>D5)-C5))*($A$1<>$B$1)*(C5<>D5))

Schönes Wochenende!

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: @ Peter von: Kasch
Geschrieben am: 09.11.2007 20:50:12

Hallo,
funktioniert einwandfrei. Was man aber an der Optik noch ändern könnte sieht man leider immer erst hinterher. So werden natürlich die Nachtstunden mit 0:00 angezeigt, wenn ein Eintrag in der Tagesarbeitszeit ist. Da aber auch an vielen Tagen gar keine Nachtstunden anfallen, wäre es übersichtlicher in der Tabelle, wenn an solchen Tagen gar nichts in der Spalte steht.
Viele Grüße und Tausend Dank !!!
Karin


  

Betrifft: AW: @ Peter von: Erich G.
Geschrieben am: 10.11.2007 00:23:06

Hallo Karin,
wenn die Anzeige ergbnisabhängig sein soll, macht das die Formel ein wenig länger...:

 ABCDEF
121:0006:00    
207:0009:0018:0020:00  
3  14:0023:1509:1502:15
408:00 05:00   

Formeln der Tabelle
ZelleFormel
E3=WENN(A3*B3+C3*D3=0;"";B3-A3+D3-C3)
F3=WENN(ODER(A3*B3+C3*D3=0; MAX(;1-MAX($A$1;A3)+MAX(;$B$1-A3) +MIN($B$1;B3)+(B3>$A$1)*(B3-$A$1)-(A3<B3)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B3+(A3>B3)-A3))*($A$1<>$B$1)*(A3<>B3) + MAX(;1-MAX($A$1;C3)+MAX(;$B$1-C3) +MIN($B$1;D3)+(D3>$A$1)*(D3-$A$1)-(C3<D3)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D3+(C3>D3)-C3))*($A$1<>$B$1)*(C3<>D3)=0); ""; MAX(;1-MAX($A$1;A3)+MAX(;$B$1-A3) +MIN($B$1;B3)+(B3>$A$1)*(B3-$A$1)-(A3<B3)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B3+(A3>B3)-A3))*($A$1<>$B$1)*(A3<>B3) + MAX(;1-MAX($A$1;C3)+MAX(;$B$1-C3) +MIN($B$1;D3)+(D3>$A$1)*(D3-$A$1)-(C3<D3)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D3+(C3>D3)-C3))*($A$1<>$B$1)*(C3<>D3))
E4=WENN(A4*B4+C4*D4=0;"";B4-A4+D4-C4)
F4=WENN(ODER(A4*B4+C4*D4=0; MAX(;1-MAX($A$1;A4)+MAX(;$B$1-A4) +MIN($B$1;B4)+(B4>$A$1)*(B4-$A$1)-(A4<B4)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B4+(A4>B4)-A4))*($A$1<>$B$1)*(A4<>B4) + MAX(;1-MAX($A$1;C4)+MAX(;$B$1-C4) +MIN($B$1;D4)+(D4>$A$1)*(D4-$A$1)-(C4<D4)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D4+(C4>D4)-C4))*($A$1<>$B$1)*(C4<>D4)=0); ""; MAX(;1-MAX($A$1;A4)+MAX(;$B$1-A4) +MIN($B$1;B4)+(B4>$A$1)*(B4-$A$1)-(A4<B4)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B4+(A4>B4)-A4))*($A$1<>$B$1)*(A4<>B4) + MAX(;1-MAX($A$1;C4)+MAX(;$B$1-C4) +MIN($B$1;D4)+(D4>$A$1)*(D4-$A$1)-(C4<D4)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D4+(C4>D4)-C4))*($A$1<>$B$1)*(C4<>D4))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: @ Peter von: Kasch
Geschrieben am: 13.11.2007 16:14:31

HAllo,
bin erst heute dazu gekommen, an meiner Tabelle weiterzuarbeiten. Angepasst an meine Tabelle müsste die Formel nach deinen Angaben so aussehen:

=WENN(ODER(D6*E6+F6*G6=0; MAX(;1-MAX(Feiertage!$C$20;D6)+MAX(;Feiertage!$C$21-D6) +MIN(Feiertage!$C$21;E6)+(E6> Feiertage!$C$20)*(E6- Feiertage!$C$20)-(D6E6)-D6)) *( Feiertage!$C$20<> Feiertage!$C$21)*(D6<>E6) + MAX(;1-MAX(Feiertage!$C$20;F6)+MAX(; Feiertage!$C$21-F6) +MIN(Feiertage!$C$21;G6)+(G6> Feiertage!$C$20)*(G6- Feiertage!$C$20)-(F6G6)-F6)) *( Feiertage!$C$20<> Feiertage!$C$21)*(F6<>G6)=0); ""; MAX(;1-MAX(Feiertage!$C$20;D6)+MAX(; Feiertage!$C$21-D6) +MIN(Feiertage!$C$21;E6)+(E6> Feiertage!$C$20)*(E6- Feiertage!$C$20)-(D6E6)-D6)) *( Feiertage!$C$20<> Feiertage!$C$21)*(D6<>E6) + MAX(;1-MAX(Feiertage!$C$20;F6)+MAX(; Feiertage!$C$21-F6) +MIN(Feiertage!$C$21;G6)+(G6> Feiertage!$C$20)*(G6- Feiertage!$C$20)-(F6G6)-F6)) *( Feiertage!$C$20<> Feiertage!$C$21)*(F6<>G6))

Wenn ich sie so eingebe, bekomme ich aber die Fehlermeldung "Formel zu lang". Was kann ich tun?

Grüße
Karin


  

Betrifft: AW: Nachtstunden Arbeitszeitrechnung von: AndreasG
Geschrieben am: 08.11.2007 13:14:11

Hallo Kasch,

guckst du hier: http://www.excelformeln.de/formeln.html?welcher=9

Grüße

Andreas


  

Betrifft: AW: Nachtstunden Arbeitszeitrechnung von: Erich G.
Geschrieben am: 08.11.2007 13:30:26

Hallo kasch (??? - böse Eltern?),
isses das, mit der Formel aus
http://www.excelformeln.de/formeln.html?welcher=9

 ABCDEF
121:0006:00    
204:0006:0014:0023:1511:1504:15
304:0006:0014:0023:1511:1504:15

Formeln der Tabelle
ZelleFormel
E2=B2-A2+D2-C2
F2=MAX(;1-MAX($A$1;A2)+MAX(;$B$1-A2) +MIN($B$1;B2)+(B2>$A$1)*(B2-$A$1)-(A2<B2)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B2+(A2>B2)-A2))*($A$1<>$B$1)*(A2<>B2) + MAX(;1-MAX($A$1;C2)+MAX(;$B$1-C2) +MIN($B$1;D2)+(D2>$A$1)*(D2-$A$1)-(C2<D2)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D2+(C2>D2)-C2))*($A$1<>$B$1)*(C2<>D2)
E3=B3-A3+D3-C3
F3=MAX(;1-MAX($A$1;A3)+MAX(;$B$1-A3) +MIN($B$1;B3)+(B3>$A$1)*(B3-$A$1)-(A3<B3)*(1-($A$1-$B$1)) -($A$1<$B$1)*(B3+(A3>B3)-A3))*($A$1<>$B$1)*(A3<>B3) + MAX(;1-MAX($A$1;C3)+MAX(;$B$1-C3) +MIN($B$1;D3)+(D3>$A$1)*(D3-$A$1)-(C3<D3)*(1-($A$1-$B$1)) -($A$1<$B$1)*(D3+(C3>D3)-C3))*($A$1<>$B$1)*(C3<>D3)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Nachtstunden Arbeitszeitrechnung von: Mine
Geschrieben am: 08.11.2007 19:01:58

Hallo,

schau Dir mal die Datei an, vielleicht suchst Du ähnliches.
https://www.herber.de/bbs/user/47522.xls

Gruß Mine


 

Beiträge aus den Excel-Beispielen zum Thema "Nachtstunden Arbeitszeitrechnung"