Microsoft Excel

Herbers Excel/VBA-Archiv

Wiedermal die Arbeitszeit

Betrifft: Wiedermal die Arbeitszeit von: Herbert
Geschrieben am: 02.06.2006 16:34:36

Hallo Profis

Ich habe in der Arbeit eine vorgegebene Excelmappe zur Stundenberechnung und will diese um ein Tabellenblatt erweitern.
Die vorgegebene Tabelle berechnet die Stunden des Tages jeder Woche und beginnt immer am Montag (auch wenn der 1. Montag noch im vergangenen Monat liegt.
Ich möchte auf der 2.Tabelle - unabhängig vom Wochentag, sondern nur auf das Datum bezogen ein "X" setzen, wenn eine Mehrarbeit geleistet worden ist. Ich hab´s mit Formeln versucht - und bin kläglich gescheitert. VBA bin ich nicht so fit und so bitte ich um Eure Hilfe. Auch die Recherche hat´s (ausnahmsweise) nicht gebracht.
Hab ´ne Beispielmappe hochgeladen.

Danke an alle, die sich das mal anschauen

Gruß Herbert

  


Betrifft: Datei Vergessen von: Herbert
Geschrieben am: 02.06.2006 16:37:01

Hier die Beispieldatei
https://www.herber.de/bbs/user/34132.xls

Gruß Herbert


  


Betrifft: AW: Datei Vergessen von: Erich G.
Geschrieben am: 02.06.2006 17:44:21

Hallo Herbert,
vielleicht so?
(Bis zum 28. kannst du die Formeln kopieren. Beim 29. bis 31. steht noch ein Fehlerabfänger drin, weil es das Datum nicht geben muss):
 
 FGHIJKLMNOPQRSTUVW
191.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.18.
20XX   X            
2119.20.21.22.23.24.25.26.27.28.29.30.31.     
22             =3   
Formeln der Tabelle
F20 : =WENN(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);F19);Name!$A$11:$AR$49;44;FALSCH)=0,5;"X";"")
F22 : =WENN(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);F21);Name!$A$11:$AR$49;44;FALSCH)=0,5;"X";"")
O22 : =WENN(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);O21);Name!$A$11:$AR$49;44;FALSCH)=0,5;"X";"")
P22 : =WENN(ISTFEHLER(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);P21);Name!$A$11:$AR$49;44;FALSCH));""; WENN(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);P21);Name!$A$11:$AR$49;44;FALSCH)=0,5;"X";""))
Q22 : =WENN(ISTFEHLER(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);Q21);Name!$A$11:$AR$49;44;FALSCH));""; WENN(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);Q21);Name!$A$11:$AR$49;44;FALSCH)=0,5;"X";""))
R22 : =WENN(ISTFEHLER(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);R21);Name!$A$11:$AR$49;44;FALSCH));""; WENN(SVERWEIS(DATUM(JAHR($B$20);MONAT($B$20);R21);Name!$A$11:$AR$49;44;FALSCH)=0,5;"X";""))
T22 : =ZÄHLENWENN(F20:W20;"X")+ZÄHLENWENN(F22:R22;"X")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  


Betrifft: AW: Datei Vergessen von: fcs
Geschrieben am: 02.06.2006 17:44:44

Hallo Herbert,

ich habe dir eine Formel-Lösung im Tabellenblatt eingetragen.
Grundsätzlich kann man mit SVERWEIS arbeiten, um den Vergleichswert aus der Spalte AR in der Tabelle Name auszulesen.

Für die letzten 7 Tage des Monats ist die Formel dann modifiziert um
a) Fehlerwert zu vermeiden wenn Monat weniger als 31 Tage hat.
b) zu verhindern, dass Tage des Vormonats beim Vergleich mit einbezogen werden.

https://www.herber.de/bbs/user/34133.xls

Gruß
Franz


  


Betrifft: Vielen Dank SPITZE o.T. von: Herbert
Geschrieben am: 02.06.2006 17:52:27




 

Beiträge aus den Excel-Beispielen zum Thema "Wiedermal die Arbeitszeit"