VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Pausenberücksichtigung bei Arbeitszeitberechnungen

Gruppe

DatumZeit

Bereich

Arbeitszeit

Thema

Pausenberücksichtigung bei Arbeitszeitberechnungen

Problem

Wenn A1 kleiner als 06:00 soll A1, wenn größer als 06:30 soll A1 - 00:30, wenn größer als 9 soll A1 - 00:45, sonst soll 06:00 eingetragen werden.

Lösung

Folgende Formel: =WENN(A1*24<6;A1;WENN(A1*24>9;(A1*24-0,75)/24;WENN(A1*24>6,5;(A1*24-0,5)/24;6/24)))




ClassModule: Tabelle2

Private Sub CheckBox1_Click()
   Dim sWord As String
   If CheckBox1.Value = True Then
      sWord = InputBox("Passwort:")
      If sWord = "" Then Exit Sub
      If sWord = Range("IV1").Value Then
         MsgBox "Passwort ist OK"
      Else
         MsgBox "Falsches Passwort"
      End If
   End If
End Sub

StandardModule: basMain

Sub SetPassword()
   Dim sWord As String
   sWord = InputBox("Passwort:")
   If sWord = "" Then Exit Sub
   With Range("IV1")
      .Value = sWord
      .NumberFormat = ";;;"
   End With
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen DatumZeit und Arbeitszeit