Microsoft Excel

Excel und VBA: Formeln, Programmierung, Lösungen

Die Excel/VBA-Beispiele

Thema

Pausenberücksichtigung bei Arbeitszeitberechnungen

Gruppe

Arbeitszeit

Problem

Wenn A1 kleiner als 06:00 soll A1, wenn größer als 06:30 soll A1 - 00:30, wenn größer als 9 soll A1 - 00:45, sonst soll 06:00 eingetragen werden.

Lösung
Folgende Formel: =WENN(A1*24<6;A1;WENN(A1*24>9;(A1*24-0,75)/24;WENN(A1*24>6,5;(A1*24-0,5)/24;6/24)))