Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

Arbeitszeit Erfassung

Betrifft: Arbeitszeit Erfassung von: Werner
Geschrieben am: 17.01.2006 19:30:11

Grüzi,

ich fange oft entweder früh oder auch am Abend zu Arbeiten an. Bin Im Winterdienst eingesetzt. Ich schreibe mir dei Zeiten auf und möchte jetzt gern eine Liste erstellen um die Zeit zu erfassen. Diese sollte mir aber auchg die Nachtzeiten ausrechnen in Std. und Minuten. Beispiel ich Fahre schneeplug von 03:40 morgens bis 09:15 und abends aucgh ab und zu noch sagen wir von 18:00 bis 23:30. Nun sollte mir Excel die Arbeitszeit ausrechnen und die Nachtzeit von 20Uhr bis 6Uhr gibt es Nacht-zuschlag.


Wer kann mir da helfen??
Hab schon gegoogelt aber da ist nichts dabei

Danke im voraus Werner
Euer Forum ist Spitze!!!

  


Betrifft: AW: Arbeitszeit Erfassung von: Ramses
Geschrieben am: 17.01.2006 19:45:38

Hallo

"...Hab schon gegoogelt aber da ist nichts dabei..."

44500 Treffer ;-)

http://www.google.ch/search?hl=de&q=Arbeitszeiterfassung+EXCEL&btnG=Google-Suche&meta=

Bereits die ersten Einträge klingen schon sehr vielversprechend.

Gruss Rainer


  


Betrifft: AW: Arbeitszeit Erfassung von: Klaus-Dieter
Geschrieben am: 17.01.2006 19:57:51

Hallo Werner,

so was?

 
 ABCDEFGHIJKLMNOPQRSTUVWXYZAAAB
1TagZeitMit Zuschlag00:1500:3000:4501:0001:1501:3001:4502:0002:1502:3002:4503:0003:1503:3003:4504:0004:1504:3004:4505:0005:1505:3005:4506:0006:15
201.01.062,751,50                    xxxxx
302.01.060,250,25                       x 
403.01.06                           
504.01.06                           
605.01.06                           
706.01.06                           
807.01.06                           
908.01.06                           
1009.01.06                           
1110.01.06                           
1211.01.06                           
1312.01.06                           
1413.01.06                           
1514.01.06                           
1615.01.06                           
1716.01.06                           
1817.01.06                           
1918.01.06                           
2019.01.06                           
2120.01.06                           
2221.01.06                           
2322.01.06                           
2423.01.06                           
2524.01.06                           
2625.01.06                           
2726.01.06                           
2827.01.06                           
2928.01.06                           
3029.01.06                           
3130.01.06                           
3231.01.06                           
33Summe3,001,75                         
Formeln der Tabelle
B2 : =ZÄHLENWENN(D2:CU2;"x")/4
C2 : =SUMMENPRODUKT((D2:AA2="x")/4)+SUMMENPRODUKT((CE2:CU2="x")/4)
B3 : =ZÄHLENWENN(D3:CU3;"x")/4
C3 : =SUMMENPRODUKT((D3:AA3="x")/4)+SUMMENPRODUKT((CE3:CU3="x")/4)
B33 : =SUMME(B2:B32)
C33 : =SUMME(C2:C32)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel


  


Betrifft: AW: Arbeitszeit Erfassung von: Werner
Geschrieben am: 17.01.2006 20:15:23

Hallo Klaus Dieter, so pompös muss es gar nicht sein mir reichen ein paar Zellen A1= Startzeit B1 = Endezeit A2= Startzeit 2 wenn ich Abends raus muss und in B2 die Ebndzeit. Ergebnis morgens oder Anbends in

warte mal
https://www.herber.de/bbs/user/30142.xls


Ramses soll mal die Seiten anklicken der würde seine Freude haben oder arm sein.


Gruß Werner


  


Betrifft: AW: Arbeitszeit Erfassung von: Ramses
Geschrieben am: 17.01.2006 20:40:37

Hallo

"..der würde seine Freude haben oder arm sein...."

Wo ist denn dein Problem

http://arbeitszeiterfassung.tunesoft.de/download/

"Die Software ist Donationware, das bedeutet, Sie erhalten die Vollversion und können diese uneingeschränkt und kostenlos nutzen!

Was willst du denn noch mehr ?
Das Ding macht grundsätzlich das was du auch willst und als Einstieg in die Zeit- und Lohnberechnung wunderbar geeignet.
Alle Formeln sind sichtbar und nachvollziehbar.

Anyway,.. das war Google auf die Schnelle.
Für dein Problem gibt es tausende fertiger Vorlagen,... aber jeder muss das Rad neu erfinden ;-)

Gruss Rainer


  


Betrifft: AW: Arbeitszeit Erfassung von: Werner
Geschrieben am: 17.01.2006 20:50:00

Lesen kannst du aber oder !!

Lies erst mal meine Bitte durch
Danke aber auf dich kann ich verzichten.

Das Forum lebt besser von denen die speziell auf Fragen von Leuten eingehen die halt nicht so schlau sind wie du. Hast du sonst nichts zu tun

und Tschüss


  


Betrifft: AW: Arbeitszeit Erfassung von: Rene Holtz
Geschrieben am: 17.01.2006 21:09:13

Hallo!

Hier mal ein Lösungsvorschlag. Damit kannst Du die Arbeitszeiten ausrechnen, auch über 24 Uhr hinaus. Das ausrechnen des Zuschlages ist allerdings noch nicht möglich. Dafür bedarf es eines grossen Programmieraufwands, da viele Faktoren zu berücksichtigen sind (arbeite aber daran). Vor allem wenn Du vor 20 Uhr beginnst und über 24 Uhr hinaus arbeitest. Du musst also den Zuschlag noch manuell errechnen. Hier der Link: https://www.herber.de/bbs/user/30146.zip

Entpacke beide Dateien nach C:\Eigene Dateien. Lies vor dem Benutzen der Tabelle bitte die Hilfedatei.


  


Betrifft: AW: mir tun die Augen... von: weh !!
Geschrieben am: 17.01.2006 21:21:10




  


Betrifft: AW: Schalte die Kiste aus von: Dr.Augenarzt
Geschrieben am: 17.01.2006 21:23:42

.


  


Betrifft: AW: Arbeitszeit Erfassung von: Klaus-Dieter
Geschrieben am: 17.01.2006 21:20:11

Hallo Werner,

ich werde mal sehen, was ich machen kann. Wird aber etwas dauern, eventuell bringt Rene was zu Stande. Er hat recht, das Berechnen der Zuschlagzeiten ist nicht ganz trivial. Deshalb mein "aufwändiger" Vorschlag. ;-)

Mit Ramses solltest du nicht so umgehen. So ganz unrecht hat er nicht. Sicher hat er die Anforderung mit den Nachtzeiten übersehen. Wenn du hier öfter reinsiehst, wirst du feststellen, wie oft Anfragen nach Arbeitszeitberechnungen kommen. Oft könnte man in der Tat auf vorhandenes zurückgreifen.


Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel


  


Betrifft: AW: Arbeitszeit Erfassung von: Ramses
Geschrieben am: 17.01.2006 21:38:38

Hallo

Ich wüsste nicht, was in meinem Beitrag steht, dass dich berechtigt derartig zu antworten.

Du schriebst in deinem ersten Mail

"...Hab shon gegoogelt, da ist nichts dabei..."
Mein erster beitrag sollte dir zeigen, dass bei Google genügend zu finden ist, und ich deine Aussage so nicht akzeptiere. Zudem habe ich dir ein paar Links empfohlen.
Wenn du wirklich Interesse gehabt hättest, dann hättest du dir zumindest mal eine oder zwei Beispiele geladen und dann z.B. gefragt: "Ich verstehe diese Formel nicht, könnt ihr mir helfen."

Ausserdem waren Sie kostenlos und wären somit auch für deinen Geldbeutel geeignet.

"...Das Forum lebt besser von denen die speziell auf Fragen von Leuten eingehen .."

Aufgrund deines letzen Beitrages interpretiere ich das nun so:
"...Halt dich hier raus, ich habe keine Lust und suche einen Idioten der mir die Arbeit macht..."

"...Hast du sonst nichts zu tun..."
Doch,... und das werde ich nun auch tun.
Mit Sicherheit kannst du davon ausgehen, dass mich deine Antwort dazu motiviert hat die Kiste nun auszuschalten.
Mit Typen wie Dir hatte ich in letzter Zeit zuviel zu tun.
Ich geb's auf.

Gruss Rainer


  


Betrifft: AW: Arbeitszeit Erfassung von: Hans
Geschrieben am: 17.01.2006 21:20:27

Hallo Werner
ich habe heute schon keine Zeit aber Morgen sende ich die Datei
schreib mal dein Email
mfg Hans


  


Betrifft: Arbeitszeit Erfassung - OK, dann bin ich raus. o.T von: Klaus-Dieter
Geschrieben am: 17.01.2006 21:22:05




  


Betrifft: AW: Arbeitszeit Erfassung von: Werner
Geschrieben am: 17.01.2006 21:30:31

Für Alle

ich möchte hier niemandem zu nahe treten, aber einen Vertrag liest man ja auch bevor man ihn unterschreibt. Wie soll ich als Anfänger das hin bekommen wenn dies offensichtlich doch was größeres ist??

So zusammenbasteln ist nicht mein Ding entweder Hüh oder Hot

Danke euch ALLEN trotzdem und werde morgen Abend wieder reinschauen,vielleicht hat ja jemand ne Lösung

Gruß Werner


  


Betrifft: AW: Arbeitszeit Erfassung von: HansHei
Geschrieben am: 17.01.2006 21:46:35

Hallo Werner,

"Wer kann mir da helfen??"

frag mal Hajo.
Gruß
Hans


  


Betrifft: AW: Arbeitszeit Erfassung von: Hanshei
Geschrieben am: 17.01.2006 21:53:36

Wer ist den überhaupt.
Will ich auch nicht das er für mich was tun soll


  


Betrifft: troll dich nicht mit meinem Namen :-( von: Hanshei
Geschrieben am: 17.01.2006 21:56:41




  


Betrifft: AW: Arbeitszeit Erfassung von: Helga
Geschrieben am: 17.01.2006 22:15:29

Werner versuchmal hier
http://phorum.excelhost.de/list.php?11
da bekommst Du die richtige Antwort


  


Betrifft: AW: Arbeitszeit Erfassung von: HansHei
Geschrieben am: 17.01.2006 22:42:38

Hallo Helga,
eigentlich sollte ich mich ja raushalten, und genau das wirst Du mir gleich empfehlen. Aber die Antwort von Ramses war schon richtig. Vielleicht war sie nur nicht erwünscht. Warum in die Ferne schweifen, wenn das Gute liegt so nah. Auf dem Tablett?
Gruß
Hans


  


Betrifft: AW: Arbeitszeit Erfassung von: Klaus-Dieter
Geschrieben am: 17.01.2006 23:13:41

Hallo Werner,

das Problem hat mich doch interessiert. Hier mein Lösungsvorschlag:

 
 ABCDEFGHIJKL
1   StundenEntlohnung  Nachtzuschlag
2DatumkommtgehtgesamtNachtNormalZuschlagGesamt  vonbis
318.01.0615:0008:0017:0010:00     114,24 €        5,38 €     119,62 €   20:0006:00
419.01.0621:0001:0004:0004:00       32,00 €        2,15 €       34,15 €  Stundenlohn        6,72 €  
5         Nachtzuschlag (%)8 
Formeln der Tabelle
D3 : =REST(C3-B3;1)
E3 : =WENN(UND(B3>=K$3;C3<=L$3);REST(C3-B3;1);WENN(UND(C3>L$3;B3<K$3);REST(L$3-K$3;1);WENN(B3<K$3;REST(C3-K$3;1);WENN(C3>L$3;REST(L$3-B3;1);""))))
F3 : =D3*24*K$4
G3 : =E3*24*K$4*K$5/100
H3 : =F3+G3
D4 : =REST(C4-B4;1)
E4 : =WENN(UND(B4>=K$3;C4<=L$3);REST(C4-B4;1);WENN(UND(C4>L$3;B4<K$3);REST(L$3-K$3;1);WENN(B4<K$3;REST(C4-K$3;1);WENN(C4>L$3;REST(L$3-B4;1);""))))
F4 : =D4*24*K5
G4 : =E4*24*K$4*K$5/100
H4 : =F4+G4
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel


  


Betrifft: AW: Arbeitszeit Erfassung von: Werner
Geschrieben am: 18.01.2006 19:26:36

Danke Klaus Dieter,

habe die Liste gerade abgetippt.D as ist genau das was ich suchte, und genau die Lösung ist sonst nirgends zu Finden und wird es auch nicht geben.

Ich Danke

Werner


  


Betrifft: AW: Arbeitszeit Erfassung von: tipex
Geschrieben am: 18.01.2006 21:04:52

Hi,
wer tippt denn heute noch ab? Markieren und kopieren!
wird schon
Gruß


 

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeit Erfassung"