Microsoft Excel

Herbers Excel/VBA-Archiv

Arbeitszeitberechnung

Betrifft: Arbeitszeitberechnung von: Kevin
Geschrieben am: 22.02.2006 03:57:25

Hallo :)

ich habe die Frage hier zwar schon mal gestellt, aber noch immer keine funktionierende Formel bekommen.

Daher nochmals die Bitte an Euch mir zu helfen :)

Ich denke dass die Formel eigentlich nicht so schwer sein kann, nur habe ich mich vielleicht in den vergangenen Anfragen zu kompliziert ausgedrückt. Weiss nicht :(

Also:

wenn Arbeitszeit <= 6 Stunden dann AZ minus Pause
wenn Arbeitszeit > 6 Stunden und < 9 Stunden dann automatisch Arbeitszeit minus 30 Minuten oder tatsächliche Pausenzeit
wenn Arbeitszeit >= 9 Stunden dann Arbeitszeit automatisch Arbeitszeit minus 45 Minuten oder tatsächliche Pausenzeit

Mit der tatsächlichen Pausenzeit ist gemeint, wenn diese jeweils den automatischen Abzug überschreitet. Also bei über 6 Stunden z.B. 32 Minuten, dann muss die Formel eben die 32 Minuten berücksichigen, wohingegen bei nur 25 Minuten trotzdem 30 Minuten abgezogen werden.

Wäre echt super, wenn sich das nochmal einer anschaut.

Vielen Dank!!! :)

Gruß Kevin

  


Betrifft: AW: Arbeitszeitberechnung von: Mustafa
Geschrieben am: 22.02.2006 04:11:17

Hallo Kevin,

Kannst du denn mal eine kleine Beispieldatei anhängen damit man weiss wo die Daten eingegeben bzw. ausgegeben werden sollen.

Viele Grüße aus Köln.


  


Betrifft: AW: Arbeitszeitberechnung von: Mustafa
Geschrieben am: 22.02.2006 04:19:28

Hallo Kevin,

Kannst du denn mal eine kleine Beispieldatei anhängen damit man weiss wo die Daten eingegeben bzw. ausgegeben werden sollen.

Viele Grüße aus Köln.


  


Betrifft: AW: Arbeitszeitberechnung von: ede
Geschrieben am: 22.02.2006 07:52:36

guten orgen kevin,

schau dir mal mein beispiel an, ob so alles ok?
https://www.herber.de/bbs/user/31305.xls

rückmeldung wäre super
gruss
ede


  


Betrifft: AW: Arbeitszeitberechnung von: Kevin
Geschrieben am: 23.02.2006 11:31:27

Hallo Ede,

vielen Dank für Dein Beispiel :)

Es ist noch ein kleiner? - denk ich Mal - Fehler drin.

Habe dein Beispiel mit den entsprechenden Erläuterungen nochmal angehängt.
https://www.herber.de/bbs/user/31345.xls

Gruß

Kevin


  


Betrifft: AW: Arbeitszeitberechnung von: ede
Geschrieben am: 23.02.2006 13:17:24

hallo,

kann dein problem an hand deiner beschreibung nicht ganz nachvollziehen!
im beispiel der Spalte F ist die reine Arbeitszeit kleiner 9 stunden, das bedeutet,
das 0,5 bzw. 00:30 abgezogen werden müssen. genau das tu ich!

rückmeldung wäre super
gruss


  


Betrifft: AW: Arbeitszeitberechnung von: ede
Geschrieben am: 23.02.2006 13:38:01

du hattest recht, habe noch mal nachgedacht,
bei der ermittlung der stunden für die pausenzeit mus ich die reine arbeitszeit berücksichtigen, aber für die richtige berechnung der IstZeit die GesamtArbeitsZeit verwenden.

habe die Formel mal geänder. bitte prüfen.
https://www.herber.de/bbs/user/31359.xls

über eine rückantwort würde ich mich freuen!
gruss


  


Betrifft: korrektur von: ede
Geschrieben am: 23.02.2006 13:45:29

habe beim kpieren der formel einen fehler gemacht!
bitte die formel in zelle b18 wie folgt ändern
und dann nach rechts ausfüllen

=WENN(B17>=9;WENN(B16<0,75;B15-0,75;B15-B16);WENN(B17>6;WENN(B16<0,5;B15-0,5;B15-B16);B17))


gruss


  


Betrifft: AW: korrektur von: Kevin
Geschrieben am: 23.02.2006 14:48:27

Hallo Ede :)

schaust Du dir bitte nochmal die Korrektur an?

da sind wohl ein paar Zeichen beim Kopieren nicht richtig umgesetzt worden.

Danke

Gruß Kevin

PS: kommt Fehlermeldung "#NAME"


  


Betrifft: AW: korrektur von: Kevin
Geschrieben am: 23.02.2006 14:55:57

Hallo Ede :)

es waren die spitzen Klammern :)

jetzt muss ich das ganze nur noch waagrecht umsetzten und werde es dann nochmal ausgiebig testen.

Ich lass die Frage vorerst noch offen, ich denke aber Du hast die richtige Lösung gefunden.

Nochmals vielen Dank!!!

Gruß Kevin


  


Betrifft: AW: Arbeitszeitberechnung von: Kevin
Geschrieben am: 23.02.2006 22:30:55

Hallo Ede,

ich habe leider etwas vergessen :(

kannst Du mir nochmal helfen?

Danke

Kevin


  


Betrifft: AW: Arbeitszeitberechnung von: ede
Geschrieben am: 24.02.2006 07:05:38

guten morgen,
was fehlt denn noch?
gruss


  


Betrifft: AW: Arbeitszeitberechnung von: ede
Geschrieben am: 24.02.2006 12:49:24

montag wieder!
schönes we


  


Betrifft: AW: Arbeitszeitberechnung von: Kevin
Geschrieben am: 26.02.2006 10:12:02

Hallo Ede :)

hab die Formel mal erweitert, zumindest versucht :(


https://www.herber.de/bbs/user/31425.xls

In Zeile 2 + 3 siehst du, dass er einen Klammerfehler ausgibt, wobei ich nicht weiss wo der sein soll.

Zeile 3:

=WENN(UND(WOCHENTAG(A4;2)< 6;K4>=9);WENN(J4 < 0,75;K4-0,75;I4-J4);WENN(K4 > 6;WENN(J4 < 0,5;I4-0,5;I4-J4);K4);I4-J4)

Zeile 4:
=WENN((UND(WOCHENTAG(A5;2)< 6 ;K5>=9);WENN(J5 < 0,75;K5-0,75;I5-J5);WENN(K5 > 6;WENN(J5<0,5;I5-0,5;I5-J5);K5));I4-J4)


Die Leerzeichen bei spitzen Klammern sind nur, damit hier die spitzen Klammern richtig dargestellt werden.

Wenn dieses Problem gelöst ist, soll er hinten noch eine Bedingung subtrahieren.
Ich dachte an folgende Formel, welche aber auch nicht funktioniert: :(


-C3=(wenn(oder("Gleittag";"frei")))*1/3

Danke dir nochmals :)

Gruß

Kevin


  


Betrifft: AW: Arbeitszeitberechnung von: Kevin
Geschrieben am: 26.02.2006 20:15:50

Hallo Ede :)

vergiss die letzten beiden Formeln.

In Spalte L sollte die Formel so erweitert werden:


=WENN(WOCHENTAG(A2;2)< 6;(K2>=9;WENN(J2< 0,75;K2-0,75;I2-J2);WENN(K2> 6;WENN(J2< 0,5;I2-0,5;I2-J2);K2));I4-J4)

Leerzeichen wie üblich wieder löschen.

Ich hoffe Du hattest ein schönes WE.

Gruß Kevin


  


Betrifft: AW: Arbeitszeitberechnung von: ede
Geschrieben am: 27.02.2006 07:20:16

guten morgen,

hab e mal versucht dein wünsche noch einzubauen, siehe hier:
https://www.herber.de/bbs/user/31445.xls

gruss
rückmeldung wäre super


 

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeitberechnung"