Microsoft Excel

Herbers Excel/VBA-Archiv

Arbeitszeitberechnung

Betrifft: Arbeitszeitberechnung von: Dominik
Geschrieben am: 23.04.2006 18:55:53

Hi,

ich habe folgendes Problem.
Ich will mir ne Tabelle erstellen, die mir meine Arbeitszeit berechnet.
Da ich öfters auch über Mitternacht hinausarbeite, habe ich folgende Formel:

=WENN(UND(D2;E2>0);WENN(D2<=E2;E2-D2;ZEITWERT("23:59")-D2+E2+ZEITWERT("00:01"));"")

Soweit passt sich das ja auch alles super gut.
Nur würd ich in der nächsten Spalte gern die berechnete Stundenanzahl mit einem Stundensatz (von z.B. 10 Euro) multiplizieren. Da kommt aber nur Schotter raus.
Ich bräuchte die berechnete Stundenzahl also in einer Dezimalform und nicht in der Zeitform.

Hat hier jemand eine Lösung für das Problem??

  


Betrifft: AW: Arbeitszeitberechnung von: =Peter=
Geschrieben am: 23.04.2006 19:04:44

Hallo

hilft dir das weiter?

 
 ABCD
1BeginnEndeDezimalZahl
222:0002:3004:304,50
Formeln der Tabelle
C2 : =REST(B2-A2;1)
D2 : =C2*24
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Die Zelle D2 ist als Zahl formatiert. Selbstverständlich kannst du auch die Formel in C2 so verwenden: =REST(B2-A2;1)*24 und dann auf die Spalte D verzichten.


HTH
Gruss
Peter


  


Betrifft: AW: Arbeitszeitberechnung von: Dominik
Geschrieben am: 23.04.2006 19:22:45

Perfekt.. Super.

Das mit der 24 hab ich auch grad noch gesehen im Forum... Aber da hats mir immer "#WERT!" angezeigt. Mit Deiner Formel ist das nun auch weg.

Phates Merci...


  


Betrifft: hilfe von: tunesiahoney
Geschrieben am: 03.09.2006 13:46:14

HI

ich habe paar probleme bei meinen hausaufgaben in datenverarbeitung. ich hab alles mögliche versuch aber ich krieg das nicht hin. ich kann machen was ich will exel werde ich einfach nicht verstehen.
ich weis das gehört sich eigentlich nicht aber ich hoffe ihr könnt mir trotzdem helfen.

ich soll für ein handelbetrieb eine testversion zur arbeitszeiterfassung machen.
die vier mitarbeiter arbeiten nach einem teilzeitmodell: die regelmäßige Arbeitszeit beträgt:

Montag- donnerstag 8,5h
freitag 6h

kernzeit ist 9uhr bis 15uhr und freitags bis 13uhr
die regelmäß9gen pausen betragen 1,5 h freitags nur 1h.

die mitarbeiter können

status a anwesend sein
status k krank sein
status u im urlaub sein

bei status k,u werden die regelarbeitszeiten gutgeschrieben. der regelmäßige urlaubsanspruch beträgt 30 tage im jahr und wird monatlich verbucht.
in den folgemonat können bis zu +/- 10h übertragen werden, der rest verfällt.

die daten dürfen wir uns selber aussuchen.

ich möchte keine lösung haben sondern nur ein tipp wie ich das darstellen könnte. ich hab wirklich keine vorstellung.


  


Betrifft: AW: hilfe von: Orakel
Geschrieben am: 03.09.2006 13:52:45

Hallo tunesiahoney,
deine Frage ist als Antwort in einem ziemlich alten Threed geraten. Du solltets eine NEUE Frage "Beitrag schreiben" im oberen Menü stellen. Das sieht sonst kaum einer.
Gruß
Orakel


  


Betrifft: AW: Arbeitszeitberechnung von: Ramses
Geschrieben am: 23.04.2006 19:07:08

Hallo

Das

=WENN(UND(D2;E2>0)


Funktioniert sicher nicht, weil für D2 keine Bedingung hinterlegt ist.
Wenn schon dann so

=WENN(UND(D2>0;E2>0)


Zum umrechnen brauchst du keine Dezimalzahlen.
Multipliziere die Zeit mit 24 dann geht es auch

 
 ABC
29Uhrzeit 108:00 
30Uhrzeit 217:00 
31Ergebnis09:00 
32LohnSFr. 90.00 
33   
Formeln der Tabelle
B31 : =SUMME(B30-B29)
B32 : =(B31*24)*10
 




Gruss Rainer


  


Betrifft: AW: Arbeitszeitberechnung von: Dominik
Geschrieben am: 23.04.2006 19:24:28

Also, die Formal hat schon geklappt. Warum??? Frag mich nicht... Hab die hier aus dme Forum... *g* Hab die ehrlich gesagt auch nicht wirklich verstanden... ;-)

Danke für deine Hilfe.

Nun klappt alles.


 

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeitberechnung"