VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Doppelt vorkommende Werte farblich kennzeichnen

Gruppe

Feature

Bereich

Bedingt

Thema

Doppelt vorkommende Werte farblich kennzeichnen

Problem

In Spalte A sollen doppelt vorkommende Werte farblich gekennzeichnet werden.

Lösung

Bei der bedingten Formatierung einzutragende Formel: =ZÄHLENWENN(A:A;A1)>1




StandardModule: Modul1

Sub EditText()
   Dim arr() As String
   Dim lRow As Long
   Dim sPath As String, sTxt As String
   sPath = Range("B1").Value
   If Dir(sPath) = "" Then
      Beep
      MsgBox "Datei " & sPath & " wurde nicht gefunden!"
      Exit Sub
   End If
   Close
   Open sPath For Input As #1
   Do Until EOF(1)
      Line Input #1, sTxt
      sTxt = Replace(sTxt, """""""", """")
      lRow = lRow + 1
      ReDim Preserve arr(1 To lRow)
      arr(lRow) = sTxt
   Loop
   Close
   Open sPath For Output As #1
   For lRow = 1 To UBound(arr)
      Print #1, arr(lRow)
   Next lRow
   Close
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Feature und Bedingt