Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung

Betrifft: Bedingte Formatierung von: Hansjochen Steinbrecher
Geschrieben am: 17.06.2008 18:17:50

Ich bereite eine Tabelle vor, in die später die Daten eingegeben werden.

Wie kann ich mit einer bedingten Formatierung die Schift von #DIV/0! (das ist das Ergebnis einer Division durch Null, da ja noch die Werte fehlen) weiß formatieren bzw. verschwinden lassen?

Hansjochen

  

Betrifft: AW: Bedingte Formatierung von: Reinhard
Geschrieben am: 17.06.2008 18:21:36

Hi Hansjochen,

Tabellenblatt: [Mappe2]!Tabelle1
  │    A    │
──┼─────────┤
4 │ #DIV/0! │
──┼─────────┤
5 │ #DIV/0! │
──┼─────────┤
6 │ #DIV/0! │
──┼─────────┤
7 │ #DIV/0! │
──┴─────────┘
Benutzte Formeln:
A4:  =ZEILE()/B4
A5:  =ZEILE()/B5
A6:  =ZEILE()/B6
A7:  =ZEILE()/B7

A4:A7
haben das Zahlenformat: Standard

Bedingte Formatierung(en):
A4: 1.te Bedingung: Formel ist =ISTFEHLER(A4)
Bei erfüllter Bedingung wird die Zelle A4 mit dem Colorindex -4142 eingefärbt
Bei erfüllter Bedingung wird die Zelle A4 mit dem Muster -4142 versehen
Bei erfüllter Bedingung wird die Zellenschrift in A4 mit der Schriftfarbe 2 eingefärbt
A5: 1.te Bedingung: Formel ist =ISTFEHLER(A5)
Bei erfüllter Bedingung wird die Zelle A5 mit dem Colorindex -4142 eingefärbt
Bei erfüllter Bedingung wird die Zelle A5 mit dem Muster -4142 versehen
Bei erfüllter Bedingung wird die Zellenschrift in A5 mit der Schriftfarbe 2 eingefärbt
A6: 1.te Bedingung: Formel ist =ISTFEHLER(A6)
Bei erfüllter Bedingung wird die Zelle A6 mit dem Colorindex -4142 eingefärbt
Bei erfüllter Bedingung wird die Zelle A6 mit dem Muster -4142 versehen
Bei erfüllter Bedingung wird die Zellenschrift in A6 mit der Schriftfarbe 2 eingefärbt
A7 : 1.te Bedingung: Formel ist =ISTFEHLER(A7)
Bei erfüllter Bedingung wird die Zelle A7 mit dem Colorindex -4142 eingefärbt
Bei erfüllter Bedingung wird die Zelle A7 mit dem Muster -4142 versehen
Bei erfüllter Bedingung wird die Zellenschrift in A7 mit der Schriftfarbe 2 eingefärbt


Gruß
Reinhard


  

Betrifft: also ich würde dafür ... von: neopa
Geschrieben am: 17.06.2008 18:48:33

Hallo Hansjochen,

... keine benutzerdefinierte Formatierung einsetzen. Besser ist es, mit Deiner Formel die Division durch 0 zu verhindern, z.B. anstelle =A1/B1 einfach =WENN(B1=0;"";A1/B1) etc.

Gruß Werner
.. , - ...


  

Betrifft: AW: also ich würde dafür ... von: Hansjochen Steinbrecher
Geschrieben am: 17.06.2008 18:51:47

Hallo Reinhard und Werner,

es klappt vorzüglich. DANKE!

Hansjochen


 

Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung"