VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Zeiten summieren

Gruppe

Funktion

Bereich

TEXT

Thema

Zeiten summieren

Problem

In Spalte A werden Zeiten im Sekunden mit Nachkommastellen eingetragen. In Zelle F2 wird die Summe dieser Zeiten in das Format M:SS,00 umgewandelt.

Lösung

Zelle B2: =SUMME(A:A), Zelle C2: =GANZZAHL(B2/60), Zelle D2: =GANZZAHL(B2-GANZZAHL(B2/60)*60), Zelle E2: =(B2-GANZZAHL(B2))*100, Zelle F2: =C2&":"&TEXT(D2;"00")&","&TEXT(E2;"00")




StandardModule: Modul1

Function ScoolHours(datStart As Date, datEnd As Date) As Double
   Dim dHours As Double
   dHours = (datEnd - datStart) * 24 / 3 * 4
   ScoolHours = dHours
End Function

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und TEXT