VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Abweichungen sichtbar machen

Gruppe

Funktion

Bereich

VERGLEICH

Thema

Abweichungen sichtbar machen

Problem

In den Spalten C und D sollen die jeweiligen Abweichungen der Spalte A zu Spalte B angezeigt werden. Formel:=WENN(ISTFEHLER(VERGLEICH(A2;B:B;0));A2;"")

Lösung

Darstellung nur anhand einer Beispielarbeitsmappe möglich.




ClassModule: frmHelmut

Private Sub cmdCancel_Click()
   Unload Me
End Sub

Private Sub cmdOK_Click()
   cmdOK.Enabled = False
   Animation1.Open ThisWorkbook.Path & "\ykohl.avi"
End Sub

StandardModule: Modul1

Sub CallHelmut()
   Dim sFile As String
   sFile = ThisWorkbook.Path & "\ykohl.avi"
   If Dir(sFile) = "" Then
      Beep
      MsgBox "Die AVI-Datei fehlt:" & _
         vbNewLine & sFile
      Exit Sub
   End If
   frmHelmut.Show
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und VERGLEICH