VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Zeichen als Zahlen darstellen

Gruppe

Funktion

Bereich

TEIL

Thema

Zeichen als Zahlen darstellen

Problem

Die Zeichen in Spalte A sollen in den Nebenspalten jeweils mit einem Code dargestellt werden, wobei a=1, b=2 etc. ist. Formel in B2: =WENN(LÄNGE($A2)>=SPALTE()-1;CODE(KLEIN(TEIL($A2;SPALTE()-1;1)))-96;"")

Lösung

Darstellung nur anhand einer Beispielarbeitsmappe möglich.




StandardModule: basMain

Sub ZeichenTabelle()
    Shell "charmap.exe", 1
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und TEIL