VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Wertermittlung in Abhängigkeit eines Zeichens in einem String

Gruppe

Funktion

Bereich

TEIL

Thema

Wertermittlung in Abhängigkeit eines Zeichens in einem String

Problem

Bei dem 6. Zeichen in einer Zeichenfolge handelt es sich um eine 1 oder eine 2. In Abhängigkeit davon soll in einer anderen Zelle der Wert "Mann" oder "Frau" angezeigt werden.

Lösung

Folgende Formel: =WENN(TEIL(A1;6;1)="1";"Mann";"Frau")




ClassModule: Tabelle1

Private Sub Worksheet_Change(ByVal Target As Range)
   If Target.Address <> "$A$1" Then Exit Sub
   Application.EnableEvents = False
   Range("A20").Value = Range("A20").Value - Range("A1").Value
   On Error GoTo ERRORHANDLER
ERRORHANDLER:
   Application.EnableEvents = True
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und TEIL