VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Runden auf 0,05

Gruppe

Funktion

Bereich

RUNDEN

Thema

Runden auf 0,05

Problem

Es soll in der zweiten Kommastelle auf 0,5 gerundet werden.

Lösung

Folgende Formel: =RUNDEN(A1*2;1)/2




ClassModule: Tabelle1

Private Sub CheckBox1_MouseDown( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal X As Single, ByVal Y As Single)
   If MsgBox("Aktion wirklich durchführen?", _
      vbQuestion + vbYesNo) = vbYes Then
      MsgBox "Führe Aktion durch!"
      CheckBox1.Value = Not CheckBox1.Value
   End If
End Sub

Private Sub CheckBox2_Change()
   If MsgBox("Aktion wirklich durchführen?", _
      vbQuestion + vbYesNo) = vbNo Then
      Exit Sub
   Else
      MsgBox "Führe Aktion durch!"
   End If
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und RUNDEN