Microsoft Excel

Herbers Excel/VBA-Archiv

Runden

Betrifft: Runden von: Burghard
Geschrieben am: 12.07.2008 21:45:35

Hallo,

ich habe hier im Forum eine Formel bekommen (geht einwandfrei). Dazu habe ich aber doch noch eine Frage:

Kann man die Formel auch so einstellen, dass auf ganze Zahlen gerundet wird?

Beispiel:

=Runden(Zahl;Kommastelle)

=Runden(279,57;0)

Ergebnis:
280,00

Dies ist die Formel:

=RUNDEN(WENN(A3=1;$C$2*13%;MAX(10,5;$C$2*0,5%)+POTENZ((MAX($A$3:$A$28)-A3);2) /SUMMENPRODUKT(POTENZ((MAX($A$3:$A$28)-$A$3:$A$28)*($A$3:$A$28<>2);2))*($C$2*87%-MAX(10,5;$C$2*0,5%) *(ANZAHL($A$3:$A$28)-SUMMENPRODUKT(--($A$3:$A$28=1)))));2)

Hilfe wäre nett.

Schönen Gruß

Burghard

  

Betrifft: AW: Runden von: Hajo_Zi
Geschrieben am: 12.07.2008 21:48:50

Hallo Burghard,

ersetze ;2 am Ende durch ;0

GrußformelHomepage


  

Betrifft: Oje, oje! Was ist heute nur los,... von: Luc:-?
Geschrieben am: 13.07.2008 01:59:35

...Hajo?
Das hat er doch schon!
Das ist keine Frage der Formel, Burghard,
sondern eine der Formatierung! Du musst im Menü Format - Zellen - Zahlen - Zahl die Anzahl der Dezimalstellen auf 0 stellen!
Gruß + schöSo!
Luc :-?


  

Betrifft: Weshalb ? von: Ramses
Geschrieben am: 13.07.2008 16:26:25

Hallo

Der Fragesteller hat ein Beispiel gezeigt, ist aber offensichtlich nicht in der Lage dieses Beispiel in der Formel entsprechend umzusetzen.
Hast du dich schon so eingeschossen auf Hajo, dass du eine korrekte Antwort nicht mehr erkennst ?
Die Frage ist doch auch entsprechend der Fragestellung: "... Kann man die Formel auch so einstellen..." korrekt beantwortet.
Deine Variante ist allenfalls ein Workaround, ohne die Formel zu verändern.

Gruss Rainer


  

Betrifft: AW: In der Sache von: Gerd L
Geschrieben am: 13.07.2008 17:36:28

könnte man sich evtl. darauf einigen, beides zu tun. Formel u. Zahlenformat anpassen.

Grüße

Gerd


  

Betrifft: AW: In der Sache von: Hajo_Zi
Geschrieben am: 13.07.2008 17:42:42

Hallo Gerd,

bei Zahlenformat fehlt nur die Ergänzung Option Genauigkeit wie angezeigt. Vo dieser Einstellung halte ich nichts. Er wollte bestimmt mit einem Wert ohne kommastellen weiter rechnen, warum sollte ich sonst Runden.

Gruß Hajo


  

Betrifft: AW: In der Sache von: Ramses
Geschrieben am: 13.07.2008 22:05:45

Hallo Gerd

"...beides zu tun. Formel u. Zahlenformat anpassen...."

Nein. Beides hat seine Gründe und Auswirkungen,...und darüber muss sich der Anwender bewusst sein


Tabelle1

 AB
5Zahlenfomat
Keine Dezimalstelle
Fuinktion
Runden
61212
71212
81212
91212
104948

Formeln der Tabelle
ZelleFormel
B6=RUNDEN(A6;0)
B7=RUNDEN(A7;0)
B8=RUNDEN(A8;0)
B9=RUNDEN(A9;0)
A10=SUMME(A6:A9)
B10=SUMME(B6:B9)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruss Rainer


  

Betrifft: Da hast du das genauso "aufmerksam"... von: Luc:-?
Geschrieben am: 22.07.2008 23:40:56

...gelesen wie Hajo, Ramses!
Der Frager hatte bereits die komplette Formel mit RUNDEN geliefert und auch das Ergebnis angegeben. Ihn hat dann nur verwundert, dass dort (richtigerweise) xxx,00 herauskam. Das Unvermögen des Fragestellers bestand also mitnichten im richtigen Einsatz der Fkt, sondern offensichtlich in Unkenntnis der Formatierungswirkung. So etwas kann eigentlich nur Vielschreibern unter permanentem, selbstgeneriertem Zeitdruck entgehen... ;-)
Da ich nicht zu diesen gehöre, komme ich erst jetzt zum Antworten; auch, um keine längere Diskussion vom Zaune zu brechen und damit Mücken zu Elefanten aufzublasen, wozu der Eine oder Andere neigen mag. Ansonsten "schieße" ich nur auf "Schnellschüsse", die dem Problem des Fragestellers nicht gerecht wdn, nicht auf konkrete Personen - also eher als "Raketenabwehrsystem" zu verstehen... :->
Gruß Luc :-?


  

Betrifft: AW: Da hast du das genauso "aufmerksam"... von: Hajo_Zi
Geschrieben am: 23.07.2008 08:31:09

Hallo Luc,

fasse Dir mal an Deine eigene Nase. Hier die Formel
=RUNDEN(WENN(A3=1;$C$2*13%;MAX(10,5;$C$2*0,5%)+POTENZ((MAX($A$3:$A$28)-A3);2) /SUMMENPRODUKT(POTENZ((MAX($A$3:$A$28)-$A$3:$A$28)*($A$3:$A$28<>2);2))*($C$2*87%-MAX(10,5;$C$2*0,5%) *(ANZAHL($A$3:$A$28)-SUMMENPRODUKT(--($A$3:$A$28=1)))));2)

Da wird auf 2 Stellen gerundet. Mir scheint aber Du willst nicht lesen, wie Rainer auch schon festgestellt hat.

Gruß Hajo


 

Beiträge aus den Excel-Beispielen zum Thema "Runden"