VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Erhöhen der Positionsnummer bei Listeneintrag

Gruppe

Funktion

Bereich

ANZAHL2

Thema

Erhöhen der Positionsnummer bei Listeneintrag

Problem

Bei neuen Eingaben in Spalte C soll sich die Positionsnummer in Spalte B für die gesamte Wertetabelle jeweils um 1 erhöhen.

Lösung

Folgende Formel: =WENN(C3<>"";ANZAHL2(INDIREKT("c1:c"&ZEILE()-1));"")




StandardModule: Modul1

Sub ImportHTML()
   Dim sPath As String, sHTML As String
   Application.ScreenUpdating = False
   sHTML = Range("B1").Value
   Workbooks.Add
   With ActiveSheet.QueryTables.Add(Connection:= _
      "URL;" & sHTML, Destination:=Range("A1"))
      .Name = "Waehrungen"
      If Left(Application.Version, 1) <> "8" Then
         .WebSelectionType = xlEntirePage
         .WebFormatting = True
      End If
      .Refresh BackgroundQuery:=False
    End With
    Application.ScreenUpdating = True
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und ANZAHL2