VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Anzahl von Werten nach verschiedenen Bedingungen.

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Anzahl von Werten nach verschiedenen Bedingungen.

Problem

Die Anzahl der in der Tabelle A4:C405 mit den Kriterien im Bereich A2:C2 übereinstimmenden Daten soll ausgelesen werden.

Lösung

Matrixformel: =SUMME((A4:A405=A2)*(B4:B405=B2)*(C4:C405=C2)*1)




ClassModule: frmCheckBoxWerte

Private Sub cmdWeiter_Click()
  Unload Me
End Sub

Private Sub cmdCount_Click()
  Dim cnt As Control
  Dim iCount As Integer
  For Each cnt In Controls
    If TypeName(cnt) = "CheckBox" Then iCount = iCount + 1
  Next cnt
  MsgBox "Diese UserForm besitzt " & iCount & " CheckBoxes!"
End Sub

StandardModule: basMain

Sub CallForm()
   frmCheckBoxWerte.Show
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion