VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Korrespondenzwert einer Gültigkeitslisten-Auswahl abrufen

Gruppe

Funktion

Bereich

SVERWEIS

Thema

Korrespondenzwert einer Gültigkeitslisten-Auswahl abrufen

Problem

In Spalte A werden Werte über ein Auswahlfeld eingetragen werden, wobei in Spalte B der Korrespondenzwert aus der Datenbank eingetragen werden soll.

Lösung

Formel in B1: =SVERWEIS(A1;Datenbank!A:B;2;0)




StandardModule: basMain

Sub WksCopy()
   Const csWks As String = "Tab_Ges"
   Worksheets(csWks).Copy _
      after:=Worksheets(Worksheets.Count)
   Application.DisplayAlerts = False
   Worksheets(csWks).Delete
   Application.DisplayAlerts = True
   ActiveSheet.Name = csWks
   Range("Bereich").ClearContents
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und SVERWEIS