Microsoft Excel

Herbers Excel/VBA-Archiv

Zell-Name in Sverweis möglich?

Betrifft: Zell-Name in Sverweis möglich? von: Bernd
Geschrieben am: 22.07.2008 11:01:25


Hallo Freaks,
ich habe eine SVerweis-Formel, bei der ich den Spaltenindex gerne mit einem Namen austauschen will, weil ab und zu es vorkommen kann, dass Spalten eingefügt werden und dann der Spaltenindex "4" nicht mehr stimmt (Vorabhinweis: Den entsprechenden Zell-Bereich habe ich natürlich mit dem Namen versehen.)

so ist es jetzt und klappt auch: =SVERWEIS(B5;B267:B284;4;0)

und so hatte ich es mir vorgestellt (was aber nicht klappt):
=SVERWEIS(B5;B267:B284;Definition_Monatsteiler;0)

Danke vorab für Eure Tipps.

Grüße
Bernd

  

Betrifft: AW: Zell-Name in Sverweis möglich? von: Rudi Maintaire
Geschrieben am: 22.07.2008 11:10:29

Hallo,

so ist es jetzt und klappt auch: =SVERWEIS(B5;B267:B284;4;0)


kann nicht!Spalte 4 in einem einspaltigen Bereich?

...;Spalte(Definition_Monatsteiler);0)

Gruß
Rudi


  

Betrifft: AW: Zell-Name in Sverweis möglich? von: Bernd
Geschrieben am: 22.07.2008 12:30:57

Hi Rudi,
ja das stimmt, was du schreibst, das ist geschehen, als ich den Fehlvesuch wieder rückgängig machte. So lautet die korrekte Formel: =SVERWEIS(B5;B266:E284;4;0).

Hast du denn einen Tipp für mich?

Grüße
Bernd


  

Betrifft: AW: Zell-Name in Sverweis möglich? von: Rudi Maintaire
Geschrieben am: 22.07.2008 13:07:27

Hast du denn einen Tipp für mich?


den hast du doch schon!

Aber nochmal:
...;Spalte(Definition_Monatsteiler);0)

Gruß
Rudi


  

Betrifft: @Erich von: Bernd
Geschrieben am: 22.07.2008 14:30:51

Hi Erich,
Danke, aber das funktioniert nicht. Der Bereich B267:E284 ist definitiv der korrekte Bereich. Es kommt aber immer die Meldung: #Bezug!

=SVERWEIS(B5;B267:E284;SPALTE(Definition_Monatsteiler);0)


Grüße
Bernd


  

Betrifft: AW: @Rudi von: Bernd
Geschrieben am: 22.07.2008 14:34:59

Rudi,
verzeih bitte, ich habe dir geraden einen falschen Vornahmen gegeben. Ich hatte gedanklich Erich aus Kamp-Limpfort im Kopf.

-----------

Danke, aber das funktioniert nicht. Der Bereich B267:E284 ist definitiv der korrekte Bereich. Es kommt aber immer die Meldung: #Bezug!

=SVERWEIS(B5;B267:E284;SPALTE(Definition_Monatsteiler);0)


Grüße
Bernd


  

Betrifft: AW: @Rudi von: Rudi Maintaire
Geschrieben am: 22.07.2008 14:50:21

Halb so wild, stellt ja keine Beleidigung dar.

Definition_Monatsteiler ist im Moment E?
Dann ergibt Spalte(Definition_Monatsteiler) 5!
Ergo =SVERWEIS(B5;B267:E284;SPALTE(Definition_Monatsteiler)-1;0)
Werden jetzt vor E 2 Spalten eingefügt wird B267:E284 zu B267:G284 und der Spaltenindex zu (7-1).

Alternativ kannst du den Spaltenindex auch durch Vergleich mit der Überschrift ermitteln.
Überschriften in Zeile 267: Vergleich("testüberschrift";B267:IV267;0)
ergibt =SVERWEIS(B5;B267:E284;Vergleich("testüberschrift";B267:IV267;0);0)


Gruß
Rudi


  

Betrifft: AW: @Rudi von: Bernd
Geschrieben am: 22.07.2008 21:12:30

Hi rudi,

vielen Dank für deine Hilfe. Hat geklappt. Sowohl Tipp1 als auch der mit der Überschrift. Nur eine Verständnisfrage hätte ich noch:



wenn die Matrix von B267:E267 lautet und das gesuchte Ergebnis in Spalte E steht, dann ist das doch der Index 4. Du schreibst aber "Dann ergibt Spalte(Definition_Monatsteiler) 5", also Index 5. Warum? Von B bis E sind es doch 4 und nicht 5. Aber deine Formel brignt das richtige Ergebnis...???!!! Zum Schluss ziehst du -1 ab. Ich verstehe das Ganze einfach nicht und würde doch so gerne verstehen.



Ich habe mal eine Bsp.-Datei aufgebaut...: https://www.herber.de/bbs/user/54069.xls






Herzliche Grüße und nochmals vielen Dank.

Bernd


 

Beiträge aus den Excel-Beispielen zum Thema "Zell-Name in Sverweis möglich? "