VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Dynamischer Blattname in SVERWEIS-Formel

Gruppe

Funktion

Bereich

SVERWEIS

Thema

Dynamischer Blattname in SVERWEIS-Formel

Problem

Der Blattname in einer auf ein anderes Blatt verweisenden SVERWEIS-Formel soll dynamisch - gem. Zelleintrag - gehalten werden.

Lösung

Folgende Formel: =SVERWEIS(B2;INDIREKT(B1&"!A:B");2;0)




StandardModule: basMain

Sub CallForm()
   frmDynamisch.Show
End Sub

ClassModule: frmDynamisch

Private Sub cmdContinue_Click()
   Unload Me
End Sub

Private Sub OptionButton1_Change()
   If OptionButton1.Value = True Then
      Me.Width = 226.5
   Else
      Me.Width = 110.25
   End If
End Sub

Private Sub UserForm_Initialize()
   Dim iRow As Integer
   For iRow = 1 To 10
      ListBox1.AddItem "Zeile " & iRow
   Next iRow
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und SVERWEIS