Microsoft Excel

Herbers Excel/VBA-Archiv

wenn + verketten

Betrifft: wenn + verketten von: Lemmi
Geschrieben am: 07.08.2008 16:52:36

Hallo zusammen,
ich möchte eine wenn Bedingung gestalten die folgende Zeichenfolge erzeugt!
Spalte A……… B…….... .C…….......E(Ausgabe)
………....10……...110….....20…….....10x 110x 20
………....20………110……...20…….....20x 110x 20
………....30………110……………...….....d 30x 110
………....30……………………....……....….d 30
………....0………..0……… .0………........keine Maße vorhanden !
…………...………..0……… .0………........keine Maße vorhanden !
………….…...……………… .0……….........keine Maße vorhanden !
………………………………..… ……...............>leer Zelle<

Ich gehe davon aus das man auch ncch eine Verkettung benötigt! aber wie die Dinge zusammen bringen?
…..kann da jemand mir Helfen?

Gruß

Lemmi

  

Betrifft: soviele WENN() habe ich lange nicht ... von: neopa
Geschrieben am: 07.08.2008 17:03:12

Hallo lemmi

... geschrieben:

=WENN(ANZAHL2(A1:C1)=0;"";WENN(ZÄHLENWENN(A1:C1;0)>0;"keine Maße vorh";WENN(ANZAHL2(B1:C1)=0;"d "&A1; WENN(C1="";"d "&A1&" x "&B1;A1&" x "&B1&" x "&C1)))) 


Gruß Werner
.. , - ...


  

Betrifft: AW: soviele WENN() habe ich lange nicht ... von: Lemmi
Geschrieben am: 07.08.2008 17:22:09


Alles prima,

bei dem Einsatz viel mir auf das,
wenn nur in Spalte B und C eine Zahl eingebe größer 0 ist das X vorangestellt!

Könnte man bei dieser Variante ausgeben " Eingabe in erster Zelle fehlt"

Spalte A hat keinen Inhalt
Eingabe...........Ausgabe
10 10 x 10x 10
10 x x 10


Gruß

Lemmi


  

Betrifft: dann eben in WENN() ... von: neopa
Geschrieben am: 07.08.2008 17:31:06

Hallo Lemmi,

...

=WENN(ANZAHL2(A1:C1)=0;"";WENN((B1+C1>0)*(A1="");"Eingabe erste Zelle fehlt";WENN(ZÄHLENWENN(A1:C1;0) >0;"keine Maße vorh";WENN(ANZAHL2(B1:C1)=0;"d "&A1;WENN(C1="";"d "&A1&" x "&B1;A1&" x "&B1&" x "&C1)) ))) 


Aber Achtung, wenn Du eine XL vor 2007 hast, viele WENN() s mehr gehen da nicht mehr ;-)


Gruß Werner
.. , - ...


  

Betrifft: ach so, Du wolltest ja noch ein WENN() ... von: neopa
Geschrieben am: 07.08.2008 17:39:37

nun denn:

=WENN(ANZAHL2(A1:C1)=0;"";WENN((B1+C1>0)*(A1="");"Eingabe erste Zelle fehlt";WENN((A1>0)*(C1>0) *(B1="");"Eingabe zweite Zelle fehlt";WENN(ZÄHLENWENN(A1:C1;0)>0;"keine Maße vorh"; WENN(ANZAHL2(B1:C1)=0;"d "&A1;WENN(C1="";"d "&A1&" x "&B1;A1&" x "&B1&" x "&C1)))))) 



Nun würde nur noch ein weiteres WENN() möglich sein (ohne zu tricksen)

Gruß Werner
.. , - ...


  

Betrifft: AW: ach so, Du wolltest ja noch ein WENN() ... von: Lemmi
Geschrieben am: 07.08.2008 18:18:54

Hallo Werner

ja wunderbar,


Vielen Dank!

Gruß


Lemmi