Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn

Betrifft: Summewenn von: Hartwig
Geschrieben am: 11.08.2008 11:37:24

Hallo Leute,
in Spalte A habe ich Datumsangaben aufsteigend stehen. In Spalte B Werte dazu.
Z.B.
Saplte A Spalte B
17.03.08 135
22.03.08 250
29.03.08 311
05.04.08 175
18.04.08 163
25.04.08 425
usw.

Nun wollte ich mit Hilfe von Summewenn die Werte monatlich zusammenfassen
und in Zellen anderer Spalten darstellen.
Z.B.
Spalte D Spalte F
März 696
April 763
usw.

Ich krieg aber auf die Schnelle die Formel nicht hin.
Könnt ihr mir mal helfen?
Vielen Dank schon mal im Voraus.
Hardi

  

Betrifft: AW: Summewenn von: heikoS
Geschrieben am: 11.08.2008 11:47:45

Hallo Hartwig,

wie wär´s so:

Tabelle1

 AB
117.03.2008135
222.03.2008250
329.03.2008311
405.04.2008175
518.04.2008163
625.04.2008425
7  
8März696
9April763

Formeln der Tabelle
ZelleFormel
B8=SUMMENPRODUKT(--(MONAT($A$1:$A$6)=3); $B$1:$B$6)
B9=SUMMENPRODUKT(--(MONAT($A$1:$A$6)=4); $B$1:$B$6)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Klappt´s?


Gruß Heiko


  

Betrifft: AW: Summewenn von: David
Geschrieben am: 11.08.2008 11:47:53

so zum Beispiel:


Tabellenblattname: Tabelle2

 

A

B

C

D

E

1

01.01.2008

100

 

 

 

2

01.02.2008

200

 

2

900

3

03.02.2008

300

 

01.02.2008

900

4

05.02.2008

400

 

 

 

5

03.03.2008

500

 

 

 


Benutzte Formeln:
E2: =SUMMENPRODUKT((MONAT(A1:A5)=D2)*B1:B5)
E3: =SUMMENPRODUKT((MONAT(A1:A5)=MONAT(D3))*B1:B5)
(Benutzerdefiniertes Format Zelle D3: MMMM)

Rückmeldung wäre nett.

Gruß

David


  

Betrifft: AW: Summewenn von: Tobias
Geschrieben am: 11.08.2008 11:55:51

Ich hätte auch noch zwei Lösungen.

Die eine Lösung ist mit SUMMEWENN, die andere mit einer Matrixformel und einem "Textvergleich":

Tabelle2

 ABCD
117.03.2008135 696
222.03.2008250 696
329.03.2008311  
405.04.2008175  
518.04.2008163  
625.04.2008425  

Formeln der Tabelle
ZelleFormel
D1{=SUMME(WENN(TEXT(A1:A6;"JJJJMM")="200803";B1:B6;0))}
D2=SUMMEWENN(A1:A6;"<1.4.08";B1:B6)+SUMMEWENN(A1:A6;"<1.3.08";B1:B6)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Schönen Gruß, Tobias
http://www.tobiasschmid.de/


  

Betrifft: DANKE EUCH!!! AW: Summewenn von: Hartwig
Geschrieben am: 11.08.2008 12:01:48

Vielen Dank für eure Vorschläge, bin sicher die funzen alle.
Werds dann gleich mal probieren.
Schönen Tag noch...
Hartwig


 

Beiträge aus den Excel-Beispielen zum Thema "Summewenn"