Microsoft Excel

Herbers Excel/VBA-Archiv

Zeile ausgeben lassen

Betrifft: Zeile ausgeben lassen von: Lars
Geschrieben am: 11.08.2008 14:53:23

Hallo zusammen,

ich möchte über "Verweis" eine Spalte nach einer Zahl durchsuchen und mir dann die Zeilennummer ausgeben lassen. Die grundsätzliche Funktionsweise von "Verweis" ist klar. Wie kann ich mir aber die Zeilennummer ausgeben lassen?

Danke

Gruß
Lars

  

Betrifft: AW: Zeile ausgeben lassen von: Mac4
Geschrieben am: 11.08.2008 14:58:17

Hallo Lars,

so in etwa:

=VERWEIS(B1;A1:A100;ZEILE(1:100))

Marc


  

Betrifft: AW: Zeile ausgeben lassen von: David
Geschrieben am: 11.08.2008 14:59:37

Nimm VERGLEICH, diese Funktion gibt dir die Zeilen(Spalten)zahl direkt.

Gruß

David


  

Betrifft: AW: Zeile ausgeben lassen von: Lars
Geschrieben am: 11.08.2008 15:17:42

Hallo zusammen,

danke, aber so richtig scheint beides nicht zu funktionieren. Bei dem Kommentar mit "Verweis" gibt Excel mir eine Zahl an, wo ich nicht weiß, wo die herkommt. Bei "Vergleich" gibt Excel zwar eine Zeile an, aber die Zeile des durchsuchten Vektors. Wenn die Durchsuchung also in Zeile 5 anfängt, das Kriterium in Zeile 10 steht, gibt Excel mir als Lösung 5 an, da die ersten nicht durchsuchten Zeilen nicht berücksichtigt werden.

Gruß
Lars


  

Betrifft: AW: Zeile ausgeben lassen von: David
Geschrieben am: 11.08.2008 15:28:27

Was willst du denn mit der gefundenen Zeile machen? Wenn du den Versatz kennst, kannst du den berücksichtigen. Wenn du die Zeile für eine INDEX-Funktion nutzt, dann musst du nur die darin enthaltene Matrix entsprechend definieren.
Wo ist das Problem?

Du kriegst die Zeile z. Bsp. auch mit einer Matrixformel raus:

{=MAX(WENN(A5:A13=D8;ZEILE(A5:A13);))}
({} nicht eingeben und Eingabe mit STRG-SHIFT-ENTER abschließen)

A5:A13 = Suchbereich
D8 = gesuchter Wert

Gruß

David

PS: Excel gut???


  

Betrifft: AW: Zeile ausgeben lassen von: heikoS
Geschrieben am: 11.08.2008 15:29:06

Hallo Lars,

es geht sicherlich auch eleganter, aber mehr als das hier fällt mir gerade nicht ein. :-)

Tabelle2

 ABCD
1  72
2    
38   
47   
56   
69   

Formeln der Tabelle
ZelleFormel
D1{=VERGLEICH(C1;A1:A10;0)-VERGLEICH(WAHR;A1:A10<>"";0)+1}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Klappt´s?


Gruß Heiko


  

Betrifft: ...Nachtrag... von: David
Geschrieben am: 11.08.2008 15:32:08

Außerdem:

Wenn du die absolute Zeile brauchst, was spricht dagegen, in der VERGLEICH-Formel die komplette Spalte als Suchbereich zu definieren? Da dein Suchkriterium nur einmal vorkommt, bekommst du daraufhin die Zeile geliefert, unabhängig davon, was in den anderen Zeilen steht (Überschrift, Summe etc)

Gruß

David


  

Betrifft: AW: Zeile ausgeben lassen von: Lars
Geschrieben am: 11.08.2008 15:58:45

Hallo zusammen,

funktioniert.

Danke


 

Beiträge aus den Excel-Beispielen zum Thema "Zeile ausgeben lassen"