Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

(Intervall-)Wert aus Matrix über 2 Variablen

(Intervall-)Wert aus Matrix über 2 Variablen
Klaus
Hallo zusammen,
ich habe eine Matrix vorliegen
ich möchte für 2 beliebige Variablen z.b. kg=7 und km=150 einen Wert wiedergeben lassen, der in folgenden Intervallen der Matrix liegt:
[km bis] [5] [10] [15]
[kg bis]
[100] 1,5 3,4 5,6
[200] 4,6 4,9 8
[300] 5,1 6,5 9,2
Ergebnis wäre also der Wert 4,9 aus der Tabelle.
Gibt es da irgendeine Lookup-Funktion? Danke für Eure Hilfe!!
Klaus
BPS DATEI IM ANHANG
https://www.herber.de/bbs/user/64274.xls

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: (Intervall-)Wert aus Matrix über 2 Variablen
08.09.2009 13:37:02
Rudi
Hallo,
Entfernung in G2, Gewicht in H2
{=INDEX(B3:E20;VERGLEICH(WAHR;G2<=A3:A20;0);VERGLEICH(WAHR;H2<=B2:E2;0))}
Matrixformel! {} nicht eingeben, sondern Formel mit shift+strg+enter abschließen.
Gruß
Rudi
AW: (Intervall-)Wert aus Matrix über 2 Variablen
08.09.2009 14:25:31
Luschi
Hallo Rudi,
so wie die Formel dasteht, muß das Gewicht in G2 und die Entfernung in H2.
Gruß von Luschi
aus klein-Paris
AW: (Intervall-)Wert aus Matrix über 2 Variablen
08.09.2009 14:28:37
Rudi
ja,
anscheinend werden große Gewichte über kleine Entfernungen transportiert.
Gruß
Rudi
noch 'ne Frage...
08.09.2009 14:49:33
Luschi
Hallo Rudi,
warum liefern die beiden Vergleichsfunktionen in der Lösung einen Zeilen- bzw. Spaltenindexwert, der um 1 höher ist als die Bedingung es eigentlich verlangt.
Beispiel: {=VERGLEICH(WAHR;H2<=A3:A20;0)} liefert 11, wenn in H2 (Gewicht) 310 steht.
Eigentlich müßte doch 10 als Zeilenindex rauskommen, da gemäß Bedingung der Tabellenwert 300 der letzte Wert ist, der ein WAHR zurückgibt und der Vergleichsparameter mit 0 auf korrekte Wertigkeit prüft.
Gruß von Luschi
aus klein-Paris
Anzeige
AW: noch 'ne Frage...
08.09.2009 15:09:05
Rudi
Hallo,
G2<=A3:A20 liefert die Matrix
{FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;WAHR;WAHR;WAHR;WAHR;WAHR;WAHR;WAHR;WAHR}
Das erste WAHR ist auf Pos. 11
Gruß
Rudi

310 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige