Microsoft Excel

Herbers Excel/VBA-Archiv

Rangliste mit "Gewichtung" | Herbers Excel-Forum


Betrifft: Rangliste mit "Gewichtung" von: Andi
Geschrieben am: 16.11.2009 16:57:58

Hallo zusammen



Folgendes Problem stellt sich mir: ich will in der Turnstunde einen Wettkampf organisieren (12min / 100m/ Weitsprung) und für diesen eine Exceltabelle erstellen. Die Teilnehmer sollen für jede Disziplin in eine Rangreihe aufgelistet werden und zum Schluss soll aus den 3 Ranglisten eine Schlussrangliste erstellt werden.



Nun möchte ich eine Excelformel, die mir die Teilnehmer, die in der Schlussrangliste den gleichen Rang aufweisen, nach dem Abschneiden des 12 Minuten Laufes ordnen.



Wenn z.B zwei Teilnehmer auf dem Rang 3 landen, A jedoch 2000 Meter weit gesprungen ist und B nur 1800, Teilnehmer A vor B geordnet wird.



Ich hoffe, Ihr habt mein Anliegen verstanden. Ich habe zusätzlich eine Beispieldatei angehängt. Danke euch fürs Helfen.



Andi

datei: https://www.herber.de/bbs/user/65952.xls

  

Betrifft: Rangliste mit "Gewichtung" von: Erich G.
Geschrieben am: 16.11.2009 17:39:13

Hi Andi,
dafür dürfte die Formel in Spalte H ausreichen:

 HI
1GesamtpunktzahlGesamtrang
26,021
38,0243
48,0222
510,024
610,035

Formeln der Tabelle
ZelleFormel
H2=SUMME(C2;E2;G2)+B2/100000
I2=RANG(H2;$H$2:$H$6;WAHR)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: Korrektur Rangliste mit "Gewichtung" von: Erich G.
Geschrieben am: 16.11.2009 17:54:00

Hi Andy,
das muss wohl gerade anders herum sein (neue Formel in Spalte H):

 HI
1GesamtpunktzahlGesamtrang
26,981
38,9762
48,9783
510,985
610,974

Formeln der Tabelle
ZelleFormel
H2=C2+E2+G2+1-B2/100000
I2=RANG(H2;$H$2:$H$6;WAHR)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: Spalte H : =SUMME(C2;E2;G2)+C2:C6/1000 von: NoNet
Geschrieben am: 16.11.2009 17:39:18

Hallo Andi,

addiere zur "Gesamtpunktzahl" einfach nochmal einen Teil des Ranges aus dem 12Min-Lauf :

HI
1
2
3
4
5
6

Funktionen im Tabellenblatt :
Zelle Formel 
H2   =SUMME(C2;E2;G2) 
H3   =SUMME(C3;E3;G3) 
H4   =SUMME(C4;E4;G4) 
H5   =SUMME(C5;E5;G5) 
H6   =SUMME(C6;E6;G6) 
I2   =RANG(H2;$H$2:$H$6;WAHR) 
I3   =RANG(H3;$H$2:$H$6;WAHR) 
I4   =RANG(H4;$H$2:$H$6;WAHR) 
I5   =RANG(H5;$H$2:$H$6;WAHR) 
I6   =RANG(H6;$H$2:$H$6;WAHR) 

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


  

Betrifft: sorry : +C2:C6/1000 wurde abgeschnitten ! von: NoNet
Geschrieben am: 16.11.2009 17:41:17

Hallo Andi,

im Beitrag wurde der Zusatz "+C2:C6/1000" abgeschnitten :-(
Korrekte wäre in H2 : =SUMME(C2;E2;G2)+C2:C6/1000
Diese Funktion dann bis H6 runter kopieren.

Gruß, NoNet


Beiträge aus den Excel-Beispielen zum Thema "Rangliste mit "Gewichtung""