Microsoft Excel

Herbers Excel/VBA-Archiv

Jahresauswertung mit summewenn | Herbers Excel-Forum


Betrifft: Jahresauswertung mit summewenn von: rair@gmx.de
Geschrieben am: 22.11.2009 21:53:38

Hallo zusammen!

Ich habe folgendes Problem. Ich möchte gerne eine Jahresauswertung von Vereinbeiträgen machen. _
dabei habe ich folgende Tabelle

Datum	Beitrag
01.01.2009	10
01.01.2009	10
01.04.2009	15
01.06.2009	25
01.11.2009	16
01.11.2009	25

Nun möchte ich gerne die Beiträge pro Jahr und Quartal auflisten. dies möchte ich wenn es geht mit einer einfachen Formel machen. Summewenn klappt, wenn ich Hilfsspalten anlege, in denen ich das Quartal berechne. Das möchte ich aber nicht. Hat jemand ne Idee?

Am Ende soll das result dann so aussehen:
	            Quartal I / 2009   Quartal II / 2009   Quartal III / 2009   Quartal IV/2009
Summe Beitrag	      20,00 €	          40,00 €	               0,00 €	        41,00 €
Bin für jede Hilfe dankbar,

Grüße,

Kurt

  

Betrifft: AW: Jahresauswertung mit summewenn von: oppi
Geschrieben am: 22.11.2009 22:16:37

https://www.herber.de/bbs/user/66098.xls

Schau mal hier
Pivottabelle


  

Betrifft: AW: Jahresauswertung mit summewenn von: Kurt
Geschrieben am: 23.11.2009 22:17:00

Hallo an alle,

war ja sehr interessant zu lesen.

Die Antwort von Oppi hat mir weitergeholfen. Vielen Dank.
Pivot-Tabellen habe ich auch schon probiert, aber die Formel finde ich besser

Grüße,
Kurt


  

Betrifft: Summenprodukt von: Backowe
Geschrieben am: 22.11.2009 22:19:50

Hallo Kurt,

Tabelle1

 ABCDEFGH
1DatumBeitrag  Quartal I / 2009Quartal II / 2009Quartal III / 2009Quartal IV / 2009
201.01.200910 Summe Beitrag20,00 €40,00 €0,00 €41,00 €
301.01.200910      
401.04.200915      
501.06.200925      
601.11.200916      
701.11.200925      

Formeln der Tabelle
ZelleFormel
E2=SUMMENPRODUKT(($A2:$A7>="01.01.2009"*1)*($A2:$A7<="31.03.2009"*1)*$B2:$B7)
F2=SUMMENPRODUKT(($A2:$A7>="01.04.2009"*1)*($A2:$A7<="30.06.2009"*1)*$B2:$B7)
G2=SUMMENPRODUKT(($A2:$A7>="01.07.2009"*1)*($A2:$A7<="30.09.2009"*1)*$B2:$B7)
H2=SUMMENPRODUKT(($A2:$A7>="01.10.2009"*1)*($A2:$A7<="31.12.2009"*1)*$B2:$B7)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Jürgen


  

Betrifft: AW: Summenprodukt von: oppi
Geschrieben am: 22.11.2009 22:23:35

ist das nicht ein wenig kompliziert ?


  

Betrifft: Ich finde Pivot grausamer! ;o) oT von: Backowe
Geschrieben am: 22.11.2009 22:25:29




  

Betrifft: AW: Ich finde Pivot grausamer! ;o) oT von: oppi
Geschrieben am: 22.11.2009 22:29:37

Ist eine einfache Art zur Lösung zu kommen.
Es brauchen keine weiteren Formeln angepaßt zu werden
- zukunftsorientiert, indem man einfach den entsprechenden Datenbereich Bspweise benennt
und die Pivotabelle entweder manuell oder über VBA oder Eigenschaft zum Aktualisieren zwingt.

Was ist daran grausam ???? :-)


  

Betrifft: Einfach auf den Punkt gebracht, ich habe ... von: Backowe
Geschrieben am: 22.11.2009 22:37:32

Hi,

... mich immer erfolgreich davor gedrückt! Ich habe in meinem Umfeld in IT dafür keine Anwendungsmöglichkeiten, ich arbeite beruflich fast nicht mit Excel, ausser ab und zu mit VBA. Ich habe von Pivot absolut keine Ahnung, also sind sie grausam! :)

Gruss Jürgen


  

Betrifft: AW: Einfach auf den Punkt gebracht, ich habe ... von: oppi
Geschrieben am: 22.11.2009 22:47:43

Hallo Jürgen,

ist schon interessant, dass du alles was du nicht kennst für dich als grausam empfindest. Vielleicht einfach nur mal mit der Sache auseinandersetzen. (Wenn da nicht das Zeitproblem wäre) Dann wirst Du schnell erkennen, dass aufwendige IT Programmierungen in schlichten und einfachen Routinen kostengünstiger abgewickelt werden können.

Meine Frau habe ich auch vorher nicht gekannt. Ich fand Sie interessant, hab Sie kennengelernt - und schwupps - alles andere als gausam. BINGO. Hab mir einfach nur Zeit gelassen sie kennenzulernen.

Genauso ist es in der IT. Offen für Neues und Du wirst merken, dass dir manche graue Gehirnzelle erspart bleibt.

Ich bin auch nicht perfekt -nehme aber immer gerne gute Ratschläge an, die mir die Arbeit erleichtern.

Das erspart viel Zeit - und Du glaubst es nicht, ICH HABE MEHR ZEIT FÜR MEINE FRAU!!!

Übrigends, ich arbeite auch in einer IT nahen Abteilung - Über den Tellerrand zu schauen schadet nicht!!

Viele Grüße
Oppi

PS: was machst Du so in der IT?


  

Betrifft: Meine Arbeit von: Backowe
Geschrieben am: 22.11.2009 22:57:56

Hi,

Windows 2008 Administration, Druckerverwaltung, Thin-Client-Verwaltung, Lotus Notes, User-Support um mal die wichstigsten zu nennen.

Gruss Jürgen


  

Betrifft: AW: Meine Arbeit von: oppi
Geschrieben am: 22.11.2009 23:11:45

Hallo Jürgen,

danke für Deine Antwort. Das klingt wie eine Tätigkeit im Bankgewerbe oder einer Sparkasse.

Viele Grüße
Oppi


  

Betrifft: Fast! :) Callcenter im Bankenumfeld! oT von: Backowe
Geschrieben am: 22.11.2009 23:13:07




  

Betrifft: AW: Fast! :) Callcenter im Bankenumfeld! oT von: oppi
Geschrieben am: 22.11.2009 23:20:56

Also der traditionelle Benutzerservice für First Level? oder gar Second Level. Ist ein harter Job, leider immer wieder vom Outsourcing bedroht. die Jungs bei uns sind nicht zu beneiden - ständiger Streß! und schnelles Umschalten auf die Probleme des Kunden.

Viele dieser Tätigkeiten wurden bei uns leider outgesourced zur T-Systems. Hoffe ihr seid noch selbständig.

Viele Grüße
oppi


  

Betrifft: Ja, wir sind noch selbständig oT von: Backowe
Geschrieben am: 23.11.2009 08:28:33




  

Betrifft: Kann ich alles so bestätigen ! von: NoNet
Geschrieben am: 23.11.2009 15:11:24

Siehe auch hier :

http://www.spotlight.de/ms/NoNet/home.html

Gruß, NoNet


  

Betrifft: AW: Ich finde Pivot Super !..... von: robert
Geschrieben am: 23.11.2009 08:15:58

hi,

gerade für solche aufgaben wie geschaffen.

pivot ist variabel, die darstellung ist mit wenigen handgriffen veränderbar-
zb.gruppierung nach datum-

usw....

wenn man mal damit begonnen hat, wird man süchtig ;-)

gruß
robert


  

Betrifft: Na, dann schaff dir mal QlikView von QlikTech,... von: Luc:-?
Geschrieben am: 23.11.2009 17:14:26

...Schweden, an, Robert,
was du damit aus DB-Listen für Kreuztabellen basteln und außerdem noch einfach auf Diagrammdarstellung umschalten kannst... Datenimport, jede Menge Fktt für Berechnungen, darstellungsstabile Diagramme, xlExport...
Gruß Luc :-?


  

Betrifft: ..ja aber, wenn.. von: robert
Geschrieben am: 23.11.2009 17:43:20

..ich nur mit Office arbeiten will oder kann, Luc ?

es wird immer zusatzprogramme geben, die mehr können.....

aber für den hausgebrauch ist pivot toll :-)

gruß
robert


  

Betrifft: Naja, dann, aber als Pivot-Fan... ;-) Gruß owT von: Luc:-?
Geschrieben am: 23.11.2009 21:12:06

:-?


  

Betrifft: AW: Jahresauswertung mit summewenn von: Gert Seler
Geschrieben am: 23.11.2009 12:05:08

Hallo zusammen,
die Formel fürs "I.Qtl." lautet :
{=SUMME(WENN(AUFRUNDEN(MONAT(A2:A7)/3;0)=1;B2:B7;0))}
Die Formel wird mit Strg +Shift+Enter abgeschlossen, da es sich um eine "Matrixformel" handelt.
So werden zum Abschluß die Klammern { bzw } gesetzt.


Änderung pro folgendes "Quartal" =2 ; =3; =4

mfg
Gert


Beiträge aus den Excel-Beispielen zum Thema "Jahresauswertung mit summewenn"