Microsoft Excel

Herbers Excel/VBA-Archiv

Preisänderung bei SUMME berücksichtigen | Herbers Excel-Forum


Betrifft: Preisänderung bei SUMME berücksichtigen von: Gerhard
Geschrieben am: 24.11.2009 13:02:24

Zur Erläuterung

Wir haben ein Bauteil mit dem Preis X. Zu diesem Bauteil gibt es eine Verkaufsprognose vom Kunden und eine Übersicht der bis zum laufenden Monat tatsächlich verkauften Bauteilen. Des weiteren sind Materialkosten und Ausser Hausfertigungen auch mit aufgeführt.

Jetzt zum eigentlichen Problem:
Bauteil VerkaufsPreis bis April 5 €. Ab Mai wird mit einem Preis von 4 € gerechnet.
Wie bekomme ich jetzt Excel dazu bis April die Verkaufsstückzahlen mit 5 € zu rechnen und ab Mai mit 4 €. Und dies dann in der Spalte Gesamt Umsatz tatsächlich
Ausgeben.
Diese Preisänderungen sind variabel, d.h. ich weis am Anfang des Jahres noch nicht wann Preisänderungen auftreten können. Deshalb die Spalte Monat wo ich den Monat eingeben kann ab wann die Änderung ziehen soll.

Was ich noch gar nicht gelöst habe ist, wenn eine 2te Preisänderung auftritt (z.B. die erste im Mai und nochmals eine im Sept.). Mit weiteren Spalten möchte ich eigentlich nicht mehr arbeiten, da diese Preisänderungen auch beim Material und AusserHaus kosten geschehen können.
Ich dachte evtl. schon dies über ein weiteres Sheet zu lösen, auf dem sämtliche Berechnungen passieren und nur auf Sheet 1 dargestellt werden.

Kann mir hierbei jemand unter die Arme greifen?

Vielen Dank!!!

Habe eine Beispielmappe mit angehängt

https://www.herber.de/bbs/user/66129.xls

  

Betrifft: Lösung per SUMMENPRODUKT() von: NoNet
Geschrieben am: 24.11.2009 13:12:22

Hallo Gerhard,

gib in AE4 folgende Funktion ein :

=SUMMENPRODUKT((($S$3:$AD$3<$F$4)*$D$4*$S$4:$AD$4)+(($S$3:$AD$3>=$F$4)*E4*$S$4:$AD$4))

Alle anderen Preisänderungen analog dazu.

Gruß, NoNet


  

Betrifft: AW: Lösung per SUMMENPRODUKT() von: Gerhard
Geschrieben am: 24.11.2009 13:34:10

Hallo NoNet

Klasse danke schon mal hierfür... Zumindest ne "Teillösung" :)
Nur wenn nun KEINE Preisänderung geschieht??? Dann gibt er Null aus...
Ist dies zu evtl. zu lösen über eine WENN Funktion?

Und greift ja wahrscheinlich auch ned wenn ne zweite Preisänderung passieren könnte?

LG Gerhard


  

Betrifft: AW: Lösung per SUMMENPRODUKT() von: Gerhard
Geschrieben am: 25.11.2009 09:39:00

Noch offen...
Jemand noch weitere Vorschläge?
Ich will jetzt ned unbedingt ne Komplettlösung für mein Problem, aber vllt. noch jemand hier der mich in die "richtige"Richtung schubsen kann?

Vielen, vielen Dank!